Fix .repo install
[profile/ivi/ivi-repos.git] / packaging / ivi-repos.spec
1 %bcond_with emulator
2
3 Name:       ivi-repos
4 Summary:    Tizen IVI Repos
5 Version:    8
6 Release:    1
7 Group:      Automotive/Configuration
8 BuildArch:  noarch
9 License:    GPL-2.0
10 URL:        http://www.tizen.org
11 Source0:    %{name}-%{version}.tar.bz2
12
13 %description
14 This package installs the .repo files for Tizen IVI images
15
16 %prep
17 %setup -q -n %{name}-%{version}
18
19 %build
20
21 %install
22 rm -rf %{buildroot}
23 install -d %{buildroot}/etc/zypp/repos.d
24 %if %{with emulator}
25 type='emul-'
26 %endif
27 for release in snapshot daily milestone;
28 do
29 install -m 0644 ivi-$type$release.repo %{buildroot}/etc/zypp/repos.d
30 done
31
32 %files
33 %defattr(-,root,root,-)
34 %dir %{_sysconfdir}/zypp
35 %dir %{_sysconfdir}/zypp/repos.d
36 %config /etc/zypp/repos.d/*.repo