Take two
[profile/ivi/ivi-demo-config.git] / packaging / ivi-demo-config.spec
1 Name:       ivi-demo-config
2 Summary:    Custom configs for Tizen IVI demos
3 Version:    0.0.3
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 URL:        http://www.tizen.org
8 Source0:    xorg-dual.conf
9 Source1:    configwheeldemo
10 Source2:    rundemo.sh
11 Source3:    start_video.sh
12 Requires:   xorg-x11-server
13 Requires:   automotive-message-broker >= 0.3
14 #Conflicts:  wayland
15
16 %description
17 Provides customizations for Tizen IVI demos
18
19 %prep
20
21 %build
22 # >> build pre
23 # << build pre
24
25 # >> build post
26 # << build post
27 %install
28 rm -rf %{buildroot}
29
30 mkdir -p %{buildroot}%{_sysconfdir}/X11/
31 install -m 644 %{SOURCE0} %{buildroot}%{_sysconfdir}/X11/xorg.conf
32
33 mkdir -p %{buildroot}%{_sysconfdir}/ambd/
34 install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/ambd/config
35
36 mkdir -p %{buildroot}%{_libdir}/automotive-message-broker/scripts
37 install -m 755 %{SOURCE2} %{buildroot}%{_libdir}/automotive-message-broker/scripts/rundemo.sh
38 install -m 755 %{SOURCE3} %{buildroot}%{_libdir}/automotive-message-broker/scripts/start_video.sh
39
40 %post
41 # Create a new machine-info file in order to have a friendly name
42 #!/bin/bash
43 if [ ! -e %{_sysconfdir}/machine-info ]; then
44         HOST_ID=$(hostid)
45         cat > %{_sysconfdir}/machine-info <<EOF
46 PRETTY_NAME=Tizen IVI $HOST_ID
47 ICON_NAME=Tizen IVI
48 EOF
49 fi
50
51 %files
52 %defattr(-,root,root,-)
53 %config %{_sysconfdir}/X11/xorg.conf
54 %config %{_sysconfdir}/ambd/config
55 %{_libdir}/automotive-message-broker/scripts/*