2 Summary: Tizen keyboard
5 Group: Graphics & UI Framework/Input
7 Source0: ise-default-%{version}.tar.gz
8 BuildRequires: gettext-tools
9 BuildRequires: edje-bin
11 BuildRequires: pkgconfig(elementary)
12 BuildRequires: pkgconfig(vconf)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(libscl-ui)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(libxml-2.0)
17 BuildRequires: pkgconfig(efl-extension)
18 BuildRequires: pkgconfig(libtzplatform-config)
19 BuildRequires: pkgconfig(stt)
20 BuildRequires: pkgconfig(capi-appfw-application)
21 BuildRequires: pkgconfig(capi-appfw-preference)
22 BuildRequires: pkgconfig(capi-media-audio-io)
23 BuildRequires: pkgconfig(capi-ui-inputmethod)
24 # This is for old profile-based OBS project optimizations.
25 # In 4.0 unified build env, this if statement is always true.
26 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
27 BuildRequires: pkgconfig(cbhm)
29 Requires: %{name}-compat = %{version}-%{release}
30 # This is for old profile-based OBS project optimizations.
31 # In 4.0 unified build env, this if statement is always true.
32 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
33 Recommends: %{name}-profile_common = %{version}-%{release}
37 Description: Tizen keyboard
40 # This is for old profile-based OBS project optimizations.
41 # In 4.0 unified build env, this if statement is always true.
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
43 %package profile_common
44 Summary: ise-default binaries and resources without flavors
45 Provides: %{name}-compat = %{version}-%{release}
46 Conflicts: %{name}-profile_mobile
47 Conflicts: %{name}-profile_tv
48 Conflicts: %{name}-profile_wearable
49 Conflicts: %{name}-profile_ivi
50 %description profile_common
51 Tizen keyboard (ise-default) binaries and resources without flavors, intended
52 to support common profiles, which does not supply any additional options
56 # This is for old profile-based OBS project optimizations.
57 # In 4.0 unified build env, this if statement is always true.
58 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
59 %package profile_mobile
60 Summary: ise-default binaries and resources with mobile profile
61 Provides: %{name}-compat = %{version}-%{release}
62 Conflicts: %{name}-profile_common
63 Conflicts: %{name}-profile_tv
64 Conflicts: %{name}-profile_wearable
65 Conflicts: %{name}-profile_ivi
66 %description profile_mobile
67 Tizen keyboard (ise-default) binaries and resources with mobile options.
68 This is intended to support mobile profiles.
71 # This is for old profile-based OBS project optimizations.
72 # In 4.0 unified build env, this if statement is always true.
73 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
75 Summary: ise-default binaries and resources with tv profile
76 Provides: %{name}-compat = %{version}-%{release}
77 Conflicts: %{name}-profile_common
78 Conflicts: %{name}-profile_mobile
79 Conflicts: %{name}-profile_wearable
80 Conflicts: %{name}-profile_ivi
81 %description profile_tv
82 Tizen keyboard (ise-default) binaries and resources with tv options.
83 This is intended to support tv profiles.
86 # This is for old profile-based OBS project optimizations.
87 # In 4.0 unified build env, this if statement is always true.
88 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
90 Summary: ise-default binaries and resources with ivi profile
91 Provides: %{name}-compat = %{version}-%{release}
92 Conflicts: %{name}-profile_common
93 Conflicts: %{name}-profile_mobile
94 Conflicts: %{name}-profile_wearable
95 Conflicts: %{name}-profile_tv
96 %description profile_ivi
97 Tizen keyboard (ise-default) binaries and resources with ivi options.
98 This is intended to support ivi profiles.
101 # This is for old profile-based OBS project optimizations.
102 # In 4.0 unified build env, this if statement is always true.
103 # Common is blocked because wearable has extra efl-ext entries, which will be
104 # removed for unified build env later.
105 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
106 %package profile_wearable
107 Summary: Meta package of ise-default for wearable profiles. (circle/rectangle)
108 Provides: %{name}-compat = %{version}-%{release}
109 Conflicts: %{name}-profile_common
110 Conflicts: %{name}-profile_mobile
111 Conflicts: %{name}-profile_tv
112 Conflicts: %{name}-profile_ivi
113 Requires: %{name}-profile_wearable-extension = %{version}-%{release}
114 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
115 %description profile_wearable
116 Meta package of Tizen keyboard (ise-default) binaries and resources with
119 %package profile_wearable-extension-circle
120 Summary: ise-default binaries and resources with wearable profile (circle)
121 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
122 Conflicts: %{name}-profile_wearable-extension-rectangle
123 %description profile_wearable-extension-circle
124 Tizen keyboard (ise-default) binaries and resources with wearable options.
125 This is intended to support wearable profiles with circle display.
127 %package profile_wearable-extension-rectangle
128 Summary: ise-default binaries and resources with wearable profile (rectangle)
129 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
130 Conflicts: %{name}-profile_wearable-extension-circle
131 %description profile_wearable-extension-rectangle
132 Tizen keyboard (ise-default) binaries and resources with wearable options.
133 This is intended to support wearable profiles with rectangle display.
141 export CFLAGS_BASE="${CFLGAS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
142 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden"
143 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
146 rm -rf CMakeCache.txt
148 # This is for old profile-based OBS project optimizations.
149 # In 4.0 unified build env, this if statement is always true.
150 # Common is blocked because wearable has extra efl-ext entries, which will be
151 # removed for unified build env later.
152 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
153 mkdir -p build_wearable_rec
154 pushd build_wearable_rec
155 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
156 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
157 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
159 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
160 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
162 make %{?jobs:-j%jobs}
165 mkdir -p build_wearable_cir
166 pushd build_wearable_cir
167 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
168 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
169 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
171 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
172 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
174 make %{?jobs:-j%jobs}
179 # This is for old profile-based OBS project optimizations.
180 # In 4.0 unified build env, this if statement is always true.
181 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
182 mkdir -p build_mobile
184 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
185 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
186 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
188 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
189 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
192 make %{?jobs:-j%jobs}
196 # This is for old profile-based OBS project optimizations.
197 # In 4.0 unified build env, this if statement is always true.
198 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
201 export CFLAGS="${CFLAGS_BASE} -D_TV";
202 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
203 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
205 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
206 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
208 make %{?jobs:-j%jobs}
212 # This is for old profile-based OBS project optimizations.
213 # In 4.0 unified build env, this if statement is always true.
214 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
217 export CFLAGS="${CFLAGS_BASE} -D_IVI";
218 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
219 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
221 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
222 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
224 make %{?jobs:-j%jobs}
228 # This is for old profile-based OBS project optimizations.
229 # In 4.0 unified build env, this if statement is always true.
230 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
231 export CFLAGS="${CFLAGS_BASE}";
232 export CXXFLAGS="${CXXFLAGS_BASE}";
233 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
235 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
236 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
238 make %{?jobs:-j%jobs}
244 # This is for old profile-based OBS project optimizations.
245 # In 4.0 unified build env, this if statement is always true.
246 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
248 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
249 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
253 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
258 # This is for old profile-based OBS project optimizations.
259 # In 4.0 unified build env, this if statement is always true.
260 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
264 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
265 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
269 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
274 # This is for old profile-based OBS project optimizations.
275 # In 4.0 unified build env, this if statement is always true.
276 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
280 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
281 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
285 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
290 # This is for old profile-based OBS project optimizations.
291 # In 4.0 unified build env, this if statement is always true.
292 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
296 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
297 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
301 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
306 # This is for old profile-based OBS project optimizations.
307 # In 4.0 unified build env, this if statement is always true.
308 # Common is blocked because wearable has extra efl-ext entries, which will be
309 # removed for unified build env later.
310 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
311 pushd build_wearable_cir
314 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
315 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
316 mv bin wearable-circle/
317 mkdir -p wearable-circle/res
319 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
323 pushd build_wearable_rec
326 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
327 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
328 mv bin wearable-rectangle/
329 mkdir -p wearable-rectangle/res
331 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
338 %files -f %{name}.lang
339 %manifest %{name}.manifest
340 %defattr(-,root,root,-)
341 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
344 # This is for old profile-based OBS project optimizations.
345 # In 4.0 unified build env, this if statement is always true.
346 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
348 pushd %{TZ_SYS_RO_APP}/ise-default/common/
353 %preun profile_common
354 pushd %{TZ_SYS_RO_APP}/ise-default
357 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
360 %files profile_common
361 %manifest %{name}.manifest
362 %defattr(-,root,root,-)
363 %{TZ_SYS_RO_APP}/ise-default/common/*
367 # This is for old profile-based OBS project optimizations.
368 # In 4.0 unified build env, this if statement is always true.
369 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
371 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
376 %preun profile_mobile
377 pushd %{TZ_SYS_RO_APP}/ise-default
380 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
383 %files profile_mobile
384 %manifest %{name}.manifest
385 %defattr(-,root,root,-)
386 %{TZ_SYS_RO_APP}/ise-default/mobile/*
390 # This is for old profile-based OBS project optimizations.
391 # In 4.0 unified build env, this if statement is always true.
392 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
394 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
400 pushd %{TZ_SYS_RO_APP}/ise-default
403 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
407 %manifest %{name}.manifest
408 %defattr(-,root,root,-)
409 %{TZ_SYS_RO_APP}/ise-default/tv/*
413 # This is for old profile-based OBS project optimizations.
414 # In 4.0 unified build env, this if statement is always true.
415 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
417 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
423 pushd %{TZ_SYS_RO_APP}/ise-default
426 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
430 %manifest %{name}.manifest
431 %defattr(-,root,root,-)
432 %{TZ_SYS_RO_APP}/ise-default/ivi/*
436 # This is for old profile-based OBS project optimizations.
437 # In 4.0 unified build env, this if statement is always true.
438 # Common is blocked because wearable has extra efl-ext entries, which will be
439 # removed for unified build env later.
440 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
441 %files profile_wearable
443 %post profile_wearable-extension-circle
444 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
449 %preun profile_wearable-extension-circle
450 pushd %{TZ_SYS_RO_APP}/ise-default
453 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
456 %files profile_wearable-extension-circle
457 %manifest %{name}.manifest
458 %defattr(-,root,root,-)
459 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
462 %post profile_wearable-extension-rectangle
463 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
468 %preun profile_wearable-extension-rectangle
469 pushd %{TZ_SYS_RO_APP}/ise-default
472 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
475 %files profile_wearable-extension-rectangle
476 %manifest %{name}.manifest
477 %defattr(-,root,root,-)
478 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*