Update package version to 1.10.13
[platform/core/uifw/ise-default.git] / packaging / ise-default.spec
1 Name:       ise-default
2 Summary:    Tizen keyboard
3 Version:    1.10.13
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    ise-default-%{version}.tar.gz
8 BuildRequires:  gettext-tools
9 BuildRequires:  edje-bin
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(libscl-ui)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(efl-extension)
18 BuildRequires:  pkgconfig(libtzplatform-config)
19 BuildRequires:  pkgconfig(stt)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-appfw-preference)
22 BuildRequires:  pkgconfig(capi-appfw-package-manager)
23 BuildRequires:  pkgconfig(capi-media-sound-manager)
24 BuildRequires:  pkgconfig(capi-ui-inputmethod)
25 BuildRequires:  pkgconfig(smartreply)
26 BuildRequires:  pkgconfig(key-manager)
27 BuildRequires:  pkgconfig(capi-system-system-settings)
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(dbus-1)
30 BuildRequires:  pkgconfig(gio-2.0)
31 BuildRequires:  pkgconfig(pkgmgr-info)
32 BuildRequires:  pkgconfig(capi-ui-sticker-consumer)
33 BuildRequires:  pkgconfig(capi-content-mime-type)
34 BuildRequires:  pkgconfig(json-glib-1.0)
35 BuildRequires:  pkgconfig(bundle)
36 BuildRequires:  pkgconfig(rpc-port)
37 BuildRequires:  pkgconfig(capi-appfw-event)
38 BuildRequires:  pkgconfig(notification)
39 Requires:       ise-engine-glm
40 Requires:       ise-engine-default
41
42 # This is for old profile-based OBS project optimizations.
43 # In 4.0 unified build env, this if statement is always true.
44 Requires:       %{name}-compat = %{version}-%{release}
45 # This is for old profile-based OBS project optimizations.
46 # In 4.0 unified build env, this if statement is always true.
47 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
48 Recommends:     %{name}-profile_common = %{version}-%{release}
49 %endif
50
51 %description
52 Description: Tizen keyboard
53
54
55 # This is for old profile-based OBS project optimizations.
56 # In 4.0 unified build env, this if statement is always true.
57 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
58 %package profile_common
59 Summary:    ise-default binaries and resources without flavors
60 Provides:   %{name}-compat = %{version}-%{release}
61 Conflicts:  %{name}-profile_mobile
62 Conflicts:  %{name}-profile_tv
63 Conflicts:  %{name}-profile_wearable
64 Conflicts:  %{name}-profile_ivi
65 %description profile_common
66 Tizen keyboard (ise-default) binaries and resources without flavors, intended
67 to support common profiles, which does not supply any additional options
68 for the build.
69 %endif
70
71 # This is for old profile-based OBS project optimizations.
72 # In 4.0 unified build env, this if statement is always true.
73 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
74 %package profile_mobile
75 Summary:    ise-default binaries and resources with mobile profile
76 Provides:   %{name}-compat = %{version}-%{release}
77 Conflicts:  %{name}-profile_common
78 Conflicts:  %{name}-profile_tv
79 Conflicts:  %{name}-profile_wearable
80 Conflicts:  %{name}-profile_ivi
81 %description profile_mobile
82 Tizen keyboard (ise-default) binaries and resources with mobile options.
83 This is intended to support mobile profiles.
84 %endif
85
86 # This is for old profile-based OBS project optimizations.
87 # In 4.0 unified build env, this if statement is always true.
88 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
89 %package profile_tv
90 Summary:    ise-default binaries and resources with tv profile
91 Provides:   %{name}-compat = %{version}-%{release}
92 Conflicts:  %{name}-profile_common
93 Conflicts:  %{name}-profile_mobile
94 Conflicts:  %{name}-profile_wearable
95 Conflicts:  %{name}-profile_ivi
96 %description profile_tv
97 Tizen keyboard (ise-default) binaries and resources with tv options.
98 This is intended to support tv profiles.
99 %endif
100
101 # This is for old profile-based OBS project optimizations.
102 # In 4.0 unified build env, this if statement is always true.
103 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
104 %package profile_ivi
105 Summary:    ise-default binaries and resources with ivi profile
106 Provides:   %{name}-compat = %{version}-%{release}
107 Conflicts:  %{name}-profile_common
108 Conflicts:  %{name}-profile_mobile
109 Conflicts:  %{name}-profile_wearable
110 Conflicts:  %{name}-profile_tv
111 %description profile_ivi
112 Tizen keyboard (ise-default) binaries and resources with ivi options.
113 This is intended to support ivi profiles.
114 %endif
115
116 # This is for old profile-based OBS project optimizations.
117 # In 4.0 unified build env, this if statement is always true.
118 # Common is blocked because wearable has extra efl-ext entries, which will be
119 # removed for unified build env later.
120 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
121 %package profile_wearable
122 Summary:    Meta package of ise-default for wearable profiles. (circle/rectangle)
123 Provides:   %{name}-compat = %{version}-%{release}
124 Conflicts:  %{name}-profile_common
125 Conflicts:  %{name}-profile_mobile
126 Conflicts:  %{name}-profile_tv
127 Conflicts:  %{name}-profile_ivi
128 Requires:   %{name}-profile_wearable-extension = %{version}-%{release}
129 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
130 %description profile_wearable
131 Meta package of Tizen keyboard (ise-default) binaries and resources with
132 wearable options.
133
134 %package profile_wearable-extension-circle
135 Summary:    ise-default binaries and resources with wearable profile (circle)
136 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
137 Conflicts:  %{name}-profile_wearable-extension-rectangle
138 %description profile_wearable-extension-circle
139 Tizen keyboard (ise-default) binaries and resources with wearable options.
140 This is intended to support wearable profiles with circle display.
141
142 %package profile_wearable-extension-rectangle
143 Summary:    ise-default binaries and resources with wearable profile (rectangle)
144 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
145 Conflicts:  %{name}-profile_wearable-extension-circle
146 %description profile_wearable-extension-rectangle
147 Tizen keyboard (ise-default) binaries and resources with wearable options.
148 This is intended to support wearable profiles with rectangle display.
149 %endif
150
151 %package -n ise-default-config
152 Summary: ISE config file
153 BuildArch: noarch
154 Requires: %{name} = %{version}-%{release}
155
156 %description -n ise-default-config
157 ISE configuration file for default setting
158
159 %prep
160 %setup -q
161
162
163 %build
164 export CFLAGS_BASE="${CFLAGS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
165 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden -fvisibility=hidden"
166 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
167
168 export LD_LIBRARY_PATH=%{TZ_SYS_RO_APP}/ise-default/lib
169
170 rm -rf CMakeFiles
171 rm -rf CMakeCache.txt
172
173 # This is for old profile-based OBS project optimizations.
174 # In 4.0 unified build env, this if statement is always true.
175 # Common is blocked because wearable has extra efl-ext entries, which will be
176 # removed for unified build env later.
177 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
178 mkdir -p build_wearable_rec
179 pushd build_wearable_rec
180 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
181 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
182 %cmake .. -DTARGET=wearable \
183          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
184          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
185
186 make %{?jobs:-j%jobs}
187 popd
188
189 mkdir -p build_wearable_cir
190 pushd build_wearable_cir
191 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
192 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
193 %cmake .. -DTARGET=wearable \
194          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
195          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
196
197 make %{?jobs:-j%jobs}
198 popd
199 %endif
200
201
202 # This is for old profile-based OBS project optimizations.
203 # In 4.0 unified build env, this if statement is always true.
204 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
205 mkdir -p build_mobile
206 pushd build_mobile
207 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
208 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
209 %cmake .. -DTARGET=mobile \
210          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
211          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
212          -Dwith_cbhm=TRUE
213
214 make %{?jobs:-j%jobs}
215 popd
216 %endif
217
218 # This is for old profile-based OBS project optimizations.
219 # In 4.0 unified build env, this if statement is always true.
220 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
221 mkdir -p build_tv
222 pushd build_tv
223 export CFLAGS="${CFLAGS_BASE} -D_TV";
224 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
225 %cmake .. -DTARGET=tv \
226          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
227          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
228
229 make %{?jobs:-j%jobs}
230 popd
231 %endif
232
233 # This is for old profile-based OBS project optimizations.
234 # In 4.0 unified build env, this if statement is always true.
235 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
236 mkdir -p build_ivi
237 pushd build_ivi
238 export CFLAGS="${CFLAGS_BASE} -D_IVI";
239 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
240 %cmake .. -DTARGET=ivi \
241          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
242          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
243
244 make %{?jobs:-j%jobs}
245 popd
246 %endif
247
248 # This is for old profile-based OBS project optimizations.
249 # In 4.0 unified build env, this if statement is always true.
250 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
251 export CFLAGS="${CFLAGS_BASE} -D_COMMON";
252 export CXXFLAGS="${CXXFLAGS_BASE} -D_COMMON";
253 %cmake . -DTARGET=common \
254         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
255         -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
256         -Dwith_cbhm=TRUE
257
258 make %{?jobs:-j%jobs}
259 %endif
260
261 %install
262 rm -rf %{buildroot}
263
264 %make_install
265 %__mkdir_p %{buildroot}%{_sysconfdir}/ise/conf
266 %__cp ise-default-config/config/* %{buildroot}%{_sysconfdir}/ise/conf
267
268 # This is for old profile-based OBS project optimizations.
269 # In 4.0 unified build env, this if statement is always true.
270 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
271 %make_install
272 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
273 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
274 mv bin common/
275 mkdir -p common/res
276 pushd res
277 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
278 popd
279 popd
280 %endif
281
282 # This is for old profile-based OBS project optimizations.
283 # In 4.0 unified build env, this if statement is always true.
284 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
285 pushd build_mobile
286 %make_install
287 popd
288 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
289 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
290 mv bin mobile/
291 mkdir -p mobile/res
292 pushd res
293 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
294 popd
295 popd
296 %endif
297
298 # This is for old profile-based OBS project optimizations.
299 # In 4.0 unified build env, this if statement is always true.
300 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
301 pushd build_tv
302 %make_install
303 popd
304 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
305 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
306 mv bin tv/
307 mkdir -p tv/res
308 pushd res
309 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
310 popd
311 popd
312 %endif
313
314 # This is for old profile-based OBS project optimizations.
315 # In 4.0 unified build env, this if statement is always true.
316 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
317 pushd build_ivi
318 %make_install
319 popd
320 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
321 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
322 mv bin ivi/
323 mkdir -p ivi/res
324 pushd res
325 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
326 popd
327 popd
328 %endif
329
330 # This is for old profile-based OBS project optimizations.
331 # In 4.0 unified build env, this if statement is always true.
332 # Common is blocked because wearable has extra efl-ext entries, which will be
333 # removed for unified build env later.
334 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
335 pushd build_wearable_cir
336 %make_install
337 popd
338 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
339 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
340 mv bin wearable-circle/
341 mkdir -p wearable-circle/res
342 pushd res
343 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
344 popd
345 popd
346
347 pushd build_wearable_rec
348 %make_install
349 popd
350 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
351 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
352 mv bin wearable-rectangle/
353 mkdir -p wearable-rectangle/res
354 pushd res
355 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
356 popd
357 popd
358 %endif
359
360 %find_lang %{name}
361
362 %files -f %{name}.lang
363 %manifest %{name}.manifest
364 %defattr(-,root,root,-)
365 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
366 %ifarch %{arm} aarch64
367 %{TZ_SYS_RO_APP}/ise-default/lib/*
368 %endif
369 %license LICENSE
370
371 # This is for old profile-based OBS project optimizations.
372 # In 4.0 unified build env, this if statement is always true.
373 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
374 %post profile_common
375 pushd %{TZ_SYS_RO_APP}/ise-default/common/
376 mkdir -p ../res
377 mkdir -p ../bin
378 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
379 if [ "$1" = "2" ]; then
380     rm -Rf ../bin/*
381     pushd ../res
382     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
383     popd
384 fi
385 for FILE in bin/*; do ln -sf "../common/${FILE}" ../bin; done
386 for FILE in res/*; do ln -sf "../common/${FILE}" ../res; done
387 popd
388 %preun profile_common
389 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
390 if [ "$1" = "0" ]; then
391     pushd %{TZ_SYS_RO_APP}/ise-default
392     rm -Rf bin
393     pushd res
394     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
395     popd
396     popd
397 fi
398 %files profile_common
399 %manifest %{name}.manifest
400 %defattr(-,root,root,-)
401 %{TZ_SYS_RO_APP}/ise-default/common/*
402 %endif
403
404
405 # This is for old profile-based OBS project optimizations.
406 # In 4.0 unified build env, this if statement is always true.
407 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
408 %post profile_mobile
409 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
410 mkdir -p ../res
411 mkdir -p ../bin
412 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
413 if [ "$1" = "2" ]; then
414     rm -Rf ../bin/*
415     pushd ../res
416     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
417     popd
418 fi
419 for FILE in bin/*; do ln -sf "../mobile/${FILE}" ../bin; done
420 for FILE in res/*; do ln -sf "../mobile/${FILE}" ../res; done
421 popd
422 %preun profile_mobile
423 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
424 if [ "$1" = "0" ]; then
425     pushd %{TZ_SYS_RO_APP}/ise-default
426     rm -Rf bin
427     pushd res
428     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
429     popd
430     popd
431 fi
432 %files profile_mobile
433 %manifest %{name}.manifest
434 %defattr(-,root,root,-)
435 %{TZ_SYS_RO_APP}/ise-default/mobile/*
436 %endif
437
438
439 # This is for old profile-based OBS project optimizations.
440 # In 4.0 unified build env, this if statement is always true.
441 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
442 %post profile_tv
443 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
444 mkdir -p ../res
445 mkdir -p ../bin
446 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
447 if [ "$1" = "2" ]; then
448     rm -Rf ../bin/*
449     pushd ../res
450     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
451     popd
452 fi
453 for FILE in bin/*; do ln -sf "../tv/${FILE}" ../bin; done
454 for FILE in res/*; do ln -sf "../tv/${FILE}" ../res; done
455 popd
456 %preun profile_tv
457 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
458 if [ "$1" = "0" ]; then
459     pushd %{TZ_SYS_RO_APP}/ise-default
460     rm -Rf bin
461     pushd res
462     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
463     popd
464     popd
465 fi
466 %files profile_tv
467 %manifest %{name}.manifest
468 %defattr(-,root,root,-)
469 %{TZ_SYS_RO_APP}/ise-default/tv/*
470 %endif
471
472
473 # This is for old profile-based OBS project optimizations.
474 # In 4.0 unified build env, this if statement is always true.
475 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
476 %post profile_ivi
477 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
478 mkdir -p ../res
479 mkdir -p ../bin
480 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
481 if [ "$1" = "2" ]; then
482     rm -Rf ../bin/*
483     pushd ../res
484     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
485     popd
486 fi
487 for FILE in bin/*; do ln -sf "../ivi/${FILE}" ../bin; done
488 for FILE in res/*; do ln -sf "../ivi/${FILE}" ../res; done
489 popd
490 %preun profile_ivi
491 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
492 if [ "$1" = "0" ]; then
493     pushd %{TZ_SYS_RO_APP}/ise-default
494     rm -Rf bin
495     pushd res
496     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
497     popd
498     popd
499 fi
500 %files profile_ivi
501 %manifest %{name}.manifest
502 %defattr(-,root,root,-)
503 %{TZ_SYS_RO_APP}/ise-default/ivi/*
504 %endif
505
506
507 # This is for old profile-based OBS project optimizations.
508 # In 4.0 unified build env, this if statement is always true.
509 # Common is blocked because wearable has extra efl-ext entries, which will be
510 # removed for unified build env later.
511 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
512 %files profile_wearable
513
514 %post profile_wearable-extension-circle
515 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
516 mkdir -p ../res
517 mkdir -p ../bin
518 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
519 if [ "$1" = "2" ]; then
520     rm -Rf ../bin/*
521     pushd ../res
522     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
523     popd
524 fi
525 for FILE in bin/*; do ln -sf "../wearable-circle/${FILE}" ../bin; done
526 for FILE in res/*; do ln -sf "../wearable-circle/${FILE}" ../res; done
527 popd
528 %preun profile_wearable-extension-circle
529 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
530 if [ "$1" = "0" ]; then
531     pushd %{TZ_SYS_RO_APP}/ise-default
532     rm -Rf bin
533     pushd res
534     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
535     popd
536     popd
537 fi
538 %files profile_wearable-extension-circle
539 %manifest %{name}.manifest
540 %defattr(-,root,root,-)
541 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
542
543
544 %post profile_wearable-extension-rectangle
545 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
546 mkdir -p ../res
547 mkdir -p ../bin
548 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
549 if [ "$1" = "2" ]; then
550     rm -Rf ../bin/*
551     pushd ../res
552     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
553     popd
554 fi
555 for FILE in bin/*; do ln -sf "../wearable-rectangle/${FILE}" ../bin; done
556 for FILE in res/*; do ln -sf "../wearable-rectangle/${FILE}" ../res; done
557 popd
558 %preun profile_wearable-extension-rectangle
559 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
560 if [ "$1" = "0" ]; then
561     pushd %{TZ_SYS_RO_APP}/ise-default
562     rm -Rf bin
563     pushd res
564     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
565     popd
566     popd
567 fi
568 %files profile_wearable-extension-rectangle
569 %manifest %{name}.manifest
570 %defattr(-,root,root,-)
571 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*
572 %endif
573
574 %files -n ise-default-config
575 %manifest ise-default-config/ise-default-config.manifest
576 %{_sysconfdir}/ise/conf/*
577 %license LICENSE