2 Summary: Tizen keyboard
5 Group: Graphics & UI Framework/Input
7 Source0: ise-default-%{version}.tar.gz
8 BuildRequires: gettext-tools
9 BuildRequires: edje-bin
11 BuildRequires: pkgconfig(elementary)
12 BuildRequires: pkgconfig(vconf)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(libscl-ui)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(libxml-2.0)
17 BuildRequires: pkgconfig(efl-extension)
18 BuildRequires: pkgconfig(libtzplatform-config)
19 BuildRequires: pkgconfig(stt)
20 BuildRequires: pkgconfig(capi-appfw-application)
21 BuildRequires: pkgconfig(capi-appfw-preference)
22 BuildRequires: pkgconfig(capi-media-audio-io)
23 BuildRequires: pkgconfig(capi-ui-inputmethod)
24 BuildRequires: pkgconfig(smartreply)
26 # This is for old profile-based OBS project optimizations.
27 # In 4.0 unified build env, this if statement is always true.
28 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
29 BuildRequires: pkgconfig(cbhm)
31 Requires: %{name}-compat = %{version}-%{release}
32 # This is for old profile-based OBS project optimizations.
33 # In 4.0 unified build env, this if statement is always true.
34 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
35 Recommends: %{name}-profile_common = %{version}-%{release}
39 Description: Tizen keyboard
42 # This is for old profile-based OBS project optimizations.
43 # In 4.0 unified build env, this if statement is always true.
44 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
45 %package profile_common
46 Summary: ise-default binaries and resources without flavors
47 Provides: %{name}-compat = %{version}-%{release}
48 Conflicts: %{name}-profile_mobile
49 Conflicts: %{name}-profile_tv
50 Conflicts: %{name}-profile_wearable
51 Conflicts: %{name}-profile_ivi
52 %description profile_common
53 Tizen keyboard (ise-default) binaries and resources without flavors, intended
54 to support common profiles, which does not supply any additional options
58 # This is for old profile-based OBS project optimizations.
59 # In 4.0 unified build env, this if statement is always true.
60 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
61 %package profile_mobile
62 Summary: ise-default binaries and resources with mobile profile
63 Provides: %{name}-compat = %{version}-%{release}
64 Conflicts: %{name}-profile_common
65 Conflicts: %{name}-profile_tv
66 Conflicts: %{name}-profile_wearable
67 Conflicts: %{name}-profile_ivi
68 %description profile_mobile
69 Tizen keyboard (ise-default) binaries and resources with mobile options.
70 This is intended to support mobile profiles.
73 # This is for old profile-based OBS project optimizations.
74 # In 4.0 unified build env, this if statement is always true.
75 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
77 Summary: ise-default binaries and resources with tv profile
78 Provides: %{name}-compat = %{version}-%{release}
79 Conflicts: %{name}-profile_common
80 Conflicts: %{name}-profile_mobile
81 Conflicts: %{name}-profile_wearable
82 Conflicts: %{name}-profile_ivi
83 %description profile_tv
84 Tizen keyboard (ise-default) binaries and resources with tv options.
85 This is intended to support tv profiles.
88 # This is for old profile-based OBS project optimizations.
89 # In 4.0 unified build env, this if statement is always true.
90 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
92 Summary: ise-default binaries and resources with ivi profile
93 Provides: %{name}-compat = %{version}-%{release}
94 Conflicts: %{name}-profile_common
95 Conflicts: %{name}-profile_mobile
96 Conflicts: %{name}-profile_wearable
97 Conflicts: %{name}-profile_tv
98 %description profile_ivi
99 Tizen keyboard (ise-default) binaries and resources with ivi options.
100 This is intended to support ivi profiles.
103 # This is for old profile-based OBS project optimizations.
104 # In 4.0 unified build env, this if statement is always true.
105 # Common is blocked because wearable has extra efl-ext entries, which will be
106 # removed for unified build env later.
107 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
108 %package profile_wearable
109 Summary: Meta package of ise-default for wearable profiles. (circle/rectangle)
110 Provides: %{name}-compat = %{version}-%{release}
111 Conflicts: %{name}-profile_common
112 Conflicts: %{name}-profile_mobile
113 Conflicts: %{name}-profile_tv
114 Conflicts: %{name}-profile_ivi
115 Requires: %{name}-profile_wearable-extension = %{version}-%{release}
116 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
117 %description profile_wearable
118 Meta package of Tizen keyboard (ise-default) binaries and resources with
121 %package profile_wearable-extension-circle
122 Summary: ise-default binaries and resources with wearable profile (circle)
123 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
124 Conflicts: %{name}-profile_wearable-extension-rectangle
125 %description profile_wearable-extension-circle
126 Tizen keyboard (ise-default) binaries and resources with wearable options.
127 This is intended to support wearable profiles with circle display.
129 %package profile_wearable-extension-rectangle
130 Summary: ise-default binaries and resources with wearable profile (rectangle)
131 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
132 Conflicts: %{name}-profile_wearable-extension-circle
133 %description profile_wearable-extension-rectangle
134 Tizen keyboard (ise-default) binaries and resources with wearable options.
135 This is intended to support wearable profiles with rectangle display.
143 export CFLAGS_BASE="${CFLGAS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
144 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden"
145 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
148 rm -rf CMakeCache.txt
150 # This is for old profile-based OBS project optimizations.
151 # In 4.0 unified build env, this if statement is always true.
152 # Common is blocked because wearable has extra efl-ext entries, which will be
153 # removed for unified build env later.
154 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
155 mkdir -p build_wearable_rec
156 pushd build_wearable_rec
157 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
158 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
159 %cmake .. -DTARGET=wearable \
160 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
161 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
163 make %{?jobs:-j%jobs}
166 mkdir -p build_wearable_cir
167 pushd build_wearable_cir
168 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
169 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
170 %cmake .. -DTARGET=wearable \
171 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
172 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
174 make %{?jobs:-j%jobs}
179 # This is for old profile-based OBS project optimizations.
180 # In 4.0 unified build env, this if statement is always true.
181 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
182 mkdir -p build_mobile
184 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
185 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
186 %cmake .. -DTARGET=mobile \
187 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
188 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
191 make %{?jobs:-j%jobs}
195 # This is for old profile-based OBS project optimizations.
196 # In 4.0 unified build env, this if statement is always true.
197 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
200 export CFLAGS="${CFLAGS_BASE} -D_TV";
201 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
202 %cmake .. -DTARGET=tv \
203 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
204 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
206 make %{?jobs:-j%jobs}
210 # This is for old profile-based OBS project optimizations.
211 # In 4.0 unified build env, this if statement is always true.
212 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
215 export CFLAGS="${CFLAGS_BASE} -D_IVI";
216 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
217 %cmake .. -DTARGET=ivi \
218 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
219 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
221 make %{?jobs:-j%jobs}
225 # This is for old profile-based OBS project optimizations.
226 # In 4.0 unified build env, this if statement is always true.
227 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
228 export CFLAGS="${CFLAGS_BASE}";
229 export CXXFLAGS="${CXXFLAGS_BASE}";
230 %cmake . -DTARGET=common \
231 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
232 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
234 make %{?jobs:-j%jobs}
240 # This is for old profile-based OBS project optimizations.
241 # In 4.0 unified build env, this if statement is always true.
242 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
244 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
245 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
249 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
254 # This is for old profile-based OBS project optimizations.
255 # In 4.0 unified build env, this if statement is always true.
256 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
260 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
261 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
265 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
270 # This is for old profile-based OBS project optimizations.
271 # In 4.0 unified build env, this if statement is always true.
272 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
276 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
277 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
281 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
286 # This is for old profile-based OBS project optimizations.
287 # In 4.0 unified build env, this if statement is always true.
288 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
292 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
293 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
297 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
302 # This is for old profile-based OBS project optimizations.
303 # In 4.0 unified build env, this if statement is always true.
304 # Common is blocked because wearable has extra efl-ext entries, which will be
305 # removed for unified build env later.
306 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
307 pushd build_wearable_cir
310 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
311 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
312 mv bin wearable-circle/
313 mkdir -p wearable-circle/res
315 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
319 pushd build_wearable_rec
322 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
323 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
324 mv bin wearable-rectangle/
325 mkdir -p wearable-rectangle/res
327 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
334 %files -f %{name}.lang
335 %manifest %{name}.manifest
336 %defattr(-,root,root,-)
337 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
340 # This is for old profile-based OBS project optimizations.
341 # In 4.0 unified build env, this if statement is always true.
342 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
344 pushd %{TZ_SYS_RO_APP}/ise-default/common/
347 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
348 if [ "$1" = "2" ]; then
351 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
354 for FILE in bin/*; do ln -sf "../common/${FILE}" ../bin; done
355 for FILE in res/*; do ln -sf "../common/${FILE}" ../res; done
357 %preun profile_common
358 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
359 if [ "$1" = "0" ]; then
360 pushd %{TZ_SYS_RO_APP}/ise-default
363 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
367 %files profile_common
368 %manifest %{name}.manifest
369 %defattr(-,root,root,-)
370 %{TZ_SYS_RO_APP}/ise-default/common/*
374 # This is for old profile-based OBS project optimizations.
375 # In 4.0 unified build env, this if statement is always true.
376 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
378 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
381 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
382 if [ "$1" = "2" ]; then
385 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
388 for FILE in bin/*; do ln -sf "../mobile/${FILE}" ../bin; done
389 for FILE in res/*; do ln -sf "../mobile/${FILE}" ../res; done
391 %preun profile_mobile
392 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
393 if [ "$1" = "0" ]; then
394 pushd %{TZ_SYS_RO_APP}/ise-default
397 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
401 %files profile_mobile
402 %manifest %{name}.manifest
403 %defattr(-,root,root,-)
404 %{TZ_SYS_RO_APP}/ise-default/mobile/*
408 # This is for old profile-based OBS project optimizations.
409 # In 4.0 unified build env, this if statement is always true.
410 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
412 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
415 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
416 if [ "$1" = "2" ]; then
419 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
422 for FILE in bin/*; do ln -sf "../tv/${FILE}" ../bin; done
423 for FILE in res/*; do ln -sf "../tv/${FILE}" ../res; done
426 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
427 if [ "$1" = "0" ]; then
428 pushd %{TZ_SYS_RO_APP}/ise-default
431 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
436 %manifest %{name}.manifest
437 %defattr(-,root,root,-)
438 %{TZ_SYS_RO_APP}/ise-default/tv/*
442 # This is for old profile-based OBS project optimizations.
443 # In 4.0 unified build env, this if statement is always true.
444 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
446 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
449 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
450 if [ "$1" = "2" ]; then
453 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
456 for FILE in bin/*; do ln -sf "../ivi/${FILE}" ../bin; done
457 for FILE in res/*; do ln -sf "../ivi/${FILE}" ../res; done
460 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
461 if [ "$1" = "0" ]; then
462 pushd %{TZ_SYS_RO_APP}/ise-default
465 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
470 %manifest %{name}.manifest
471 %defattr(-,root,root,-)
472 %{TZ_SYS_RO_APP}/ise-default/ivi/*
476 # This is for old profile-based OBS project optimizations.
477 # In 4.0 unified build env, this if statement is always true.
478 # Common is blocked because wearable has extra efl-ext entries, which will be
479 # removed for unified build env later.
480 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
481 %files profile_wearable
483 %post profile_wearable-extension-circle
484 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
487 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
488 if [ "$1" = "2" ]; then
491 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
494 for FILE in bin/*; do ln -sf "../wearable-circle/${FILE}" ../bin; done
495 for FILE in res/*; do ln -sf "../wearable-circle/${FILE}" ../res; done
497 %preun profile_wearable-extension-circle
498 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
499 if [ "$1" = "0" ]; then
500 pushd %{TZ_SYS_RO_APP}/ise-default
503 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
507 %files profile_wearable-extension-circle
508 %manifest %{name}.manifest
509 %defattr(-,root,root,-)
510 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
513 %post profile_wearable-extension-rectangle
514 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
517 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
518 if [ "$1" = "2" ]; then
521 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
524 for FILE in bin/*; do ln -sf "../wearable-rectangle/${FILE}" ../bin; done
525 for FILE in res/*; do ln -sf "../wearable-rectangle/${FILE}" ../res; done
527 %preun profile_wearable-extension-rectangle
528 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
529 if [ "$1" = "0" ]; then
530 pushd %{TZ_SYS_RO_APP}/ise-default
533 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
537 %files profile_wearable-extension-rectangle
538 %manifest %{name}.manifest
539 %defattr(-,root,root,-)
540 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*