2 Summary: Tizen keyboard
5 Group: Graphics & UI Framework/Input
7 Source0: ise-default-%{version}.tar.gz
8 BuildRequires: gettext-tools
9 BuildRequires: edje-bin
11 BuildRequires: pkgconfig(elementary)
12 BuildRequires: pkgconfig(vconf)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(libscl-ui)
15 BuildRequires: pkgconfig(ecore-imf)
16 BuildRequires: pkgconfig(libxml-2.0)
17 BuildRequires: pkgconfig(efl-extension)
18 BuildRequires: pkgconfig(libtzplatform-config)
19 BuildRequires: pkgconfig(stt)
20 BuildRequires: pkgconfig(capi-appfw-application)
21 BuildRequires: pkgconfig(capi-appfw-preference)
22 BuildRequires: pkgconfig(capi-media-audio-io)
23 BuildRequires: pkgconfig(capi-ui-inputmethod)
24 BuildRequires: pkgconfig(smartreply)
25 BuildRequires: pkgconfig(key-manager)
26 BuildRequires: pkgconfig(ode)
27 Requires: ise-engine-tables
28 Requires: ise-engine-tables-zh
29 Requires: ise-engine-hangul
30 Requires: ise-engine-glm
31 Requires: ise-engine-anthy
32 Requires: ise-engine-default
34 # This is for old profile-based OBS project optimizations.
35 # In 4.0 unified build env, this if statement is always true.
36 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires: pkgconfig(cbhm)
39 Requires: %{name}-compat = %{version}-%{release}
40 # This is for old profile-based OBS project optimizations.
41 # In 4.0 unified build env, this if statement is always true.
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
43 Recommends: %{name}-profile_common = %{version}-%{release}
47 Description: Tizen keyboard
50 # This is for old profile-based OBS project optimizations.
51 # In 4.0 unified build env, this if statement is always true.
52 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
53 %package profile_common
54 Summary: ise-default binaries and resources without flavors
55 Provides: %{name}-compat = %{version}-%{release}
56 Conflicts: %{name}-profile_mobile
57 Conflicts: %{name}-profile_tv
58 Conflicts: %{name}-profile_wearable
59 Conflicts: %{name}-profile_ivi
60 %description profile_common
61 Tizen keyboard (ise-default) binaries and resources without flavors, intended
62 to support common profiles, which does not supply any additional options
66 # This is for old profile-based OBS project optimizations.
67 # In 4.0 unified build env, this if statement is always true.
68 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
69 %package profile_mobile
70 Summary: ise-default binaries and resources with mobile profile
71 Provides: %{name}-compat = %{version}-%{release}
72 Conflicts: %{name}-profile_common
73 Conflicts: %{name}-profile_tv
74 Conflicts: %{name}-profile_wearable
75 Conflicts: %{name}-profile_ivi
76 %description profile_mobile
77 Tizen keyboard (ise-default) binaries and resources with mobile options.
78 This is intended to support mobile profiles.
81 # This is for old profile-based OBS project optimizations.
82 # In 4.0 unified build env, this if statement is always true.
83 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
85 Summary: ise-default binaries and resources with tv profile
86 Provides: %{name}-compat = %{version}-%{release}
87 Conflicts: %{name}-profile_common
88 Conflicts: %{name}-profile_mobile
89 Conflicts: %{name}-profile_wearable
90 Conflicts: %{name}-profile_ivi
91 %description profile_tv
92 Tizen keyboard (ise-default) binaries and resources with tv options.
93 This is intended to support tv profiles.
96 # This is for old profile-based OBS project optimizations.
97 # In 4.0 unified build env, this if statement is always true.
98 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
100 Summary: ise-default binaries and resources with ivi profile
101 Provides: %{name}-compat = %{version}-%{release}
102 Conflicts: %{name}-profile_common
103 Conflicts: %{name}-profile_mobile
104 Conflicts: %{name}-profile_wearable
105 Conflicts: %{name}-profile_tv
106 %description profile_ivi
107 Tizen keyboard (ise-default) binaries and resources with ivi options.
108 This is intended to support ivi profiles.
111 # This is for old profile-based OBS project optimizations.
112 # In 4.0 unified build env, this if statement is always true.
113 # Common is blocked because wearable has extra efl-ext entries, which will be
114 # removed for unified build env later.
115 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
116 %package profile_wearable
117 Summary: Meta package of ise-default for wearable profiles. (circle/rectangle)
118 Provides: %{name}-compat = %{version}-%{release}
119 Conflicts: %{name}-profile_common
120 Conflicts: %{name}-profile_mobile
121 Conflicts: %{name}-profile_tv
122 Conflicts: %{name}-profile_ivi
123 Requires: %{name}-profile_wearable-extension = %{version}-%{release}
124 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
125 %description profile_wearable
126 Meta package of Tizen keyboard (ise-default) binaries and resources with
129 %package profile_wearable-extension-circle
130 Summary: ise-default binaries and resources with wearable profile (circle)
131 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
132 Conflicts: %{name}-profile_wearable-extension-rectangle
133 %description profile_wearable-extension-circle
134 Tizen keyboard (ise-default) binaries and resources with wearable options.
135 This is intended to support wearable profiles with circle display.
137 %package profile_wearable-extension-rectangle
138 Summary: ise-default binaries and resources with wearable profile (rectangle)
139 Provides: %{name}-profile_wearable-extension = %{version}-%{release}
140 Conflicts: %{name}-profile_wearable-extension-circle
141 %description profile_wearable-extension-rectangle
142 Tizen keyboard (ise-default) binaries and resources with wearable options.
143 This is intended to support wearable profiles with rectangle display.
151 export CFLAGS_BASE="${CFLAGS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
152 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden -fvisibility=hidden"
153 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
156 rm -rf CMakeCache.txt
158 # This is for old profile-based OBS project optimizations.
159 # In 4.0 unified build env, this if statement is always true.
160 # Common is blocked because wearable has extra efl-ext entries, which will be
161 # removed for unified build env later.
162 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
163 mkdir -p build_wearable_rec
164 pushd build_wearable_rec
165 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
166 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
167 %cmake .. -DTARGET=wearable \
168 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
169 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
171 make %{?jobs:-j%jobs}
174 mkdir -p build_wearable_cir
175 pushd build_wearable_cir
176 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
177 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
178 %cmake .. -DTARGET=wearable \
179 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
180 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
182 make %{?jobs:-j%jobs}
187 # This is for old profile-based OBS project optimizations.
188 # In 4.0 unified build env, this if statement is always true.
189 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
190 mkdir -p build_mobile
192 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
193 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
194 %cmake .. -DTARGET=mobile \
195 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
196 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
199 make %{?jobs:-j%jobs}
203 # This is for old profile-based OBS project optimizations.
204 # In 4.0 unified build env, this if statement is always true.
205 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
208 export CFLAGS="${CFLAGS_BASE} -D_TV";
209 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
210 %cmake .. -DTARGET=tv \
211 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
212 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
214 make %{?jobs:-j%jobs}
218 # This is for old profile-based OBS project optimizations.
219 # In 4.0 unified build env, this if statement is always true.
220 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
223 export CFLAGS="${CFLAGS_BASE} -D_IVI";
224 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
225 %cmake .. -DTARGET=ivi \
226 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
227 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
229 make %{?jobs:-j%jobs}
233 # This is for old profile-based OBS project optimizations.
234 # In 4.0 unified build env, this if statement is always true.
235 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
236 export CFLAGS="${CFLAGS_BASE}";
237 export CXXFLAGS="${CXXFLAGS_BASE}";
238 %cmake . -DTARGET=common \
239 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
240 -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
242 make %{?jobs:-j%jobs}
248 # This is for old profile-based OBS project optimizations.
249 # In 4.0 unified build env, this if statement is always true.
250 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
252 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
253 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
257 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
262 # This is for old profile-based OBS project optimizations.
263 # In 4.0 unified build env, this if statement is always true.
264 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
268 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
269 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
273 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
278 # This is for old profile-based OBS project optimizations.
279 # In 4.0 unified build env, this if statement is always true.
280 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
284 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
285 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
289 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
294 # This is for old profile-based OBS project optimizations.
295 # In 4.0 unified build env, this if statement is always true.
296 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
300 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
301 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
305 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
310 # This is for old profile-based OBS project optimizations.
311 # In 4.0 unified build env, this if statement is always true.
312 # Common is blocked because wearable has extra efl-ext entries, which will be
313 # removed for unified build env later.
314 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
315 pushd build_wearable_cir
318 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
319 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
320 mv bin wearable-circle/
321 mkdir -p wearable-circle/res
323 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
327 pushd build_wearable_rec
330 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
331 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
332 mv bin wearable-rectangle/
333 mkdir -p wearable-rectangle/res
335 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
342 %files -f %{name}.lang
343 %manifest %{name}.manifest
344 %defattr(-,root,root,-)
345 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
348 # This is for old profile-based OBS project optimizations.
349 # In 4.0 unified build env, this if statement is always true.
350 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
352 pushd %{TZ_SYS_RO_APP}/ise-default/common/
355 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
356 if [ "$1" = "2" ]; then
359 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
362 for FILE in bin/*; do ln -sf "../common/${FILE}" ../bin; done
363 for FILE in res/*; do ln -sf "../common/${FILE}" ../res; done
365 %preun profile_common
366 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
367 if [ "$1" = "0" ]; then
368 pushd %{TZ_SYS_RO_APP}/ise-default
371 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
375 %files profile_common
376 %manifest %{name}.manifest
377 %defattr(-,root,root,-)
378 %{TZ_SYS_RO_APP}/ise-default/common/*
382 # This is for old profile-based OBS project optimizations.
383 # In 4.0 unified build env, this if statement is always true.
384 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
386 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
389 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
390 if [ "$1" = "2" ]; then
393 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
396 for FILE in bin/*; do ln -sf "../mobile/${FILE}" ../bin; done
397 for FILE in res/*; do ln -sf "../mobile/${FILE}" ../res; done
399 %preun profile_mobile
400 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
401 if [ "$1" = "0" ]; then
402 pushd %{TZ_SYS_RO_APP}/ise-default
405 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
409 %files profile_mobile
410 %manifest %{name}.manifest
411 %defattr(-,root,root,-)
412 %{TZ_SYS_RO_APP}/ise-default/mobile/*
416 # This is for old profile-based OBS project optimizations.
417 # In 4.0 unified build env, this if statement is always true.
418 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
420 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
423 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
424 if [ "$1" = "2" ]; then
427 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
430 for FILE in bin/*; do ln -sf "../tv/${FILE}" ../bin; done
431 for FILE in res/*; do ln -sf "../tv/${FILE}" ../res; done
434 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
435 if [ "$1" = "0" ]; then
436 pushd %{TZ_SYS_RO_APP}/ise-default
439 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
444 %manifest %{name}.manifest
445 %defattr(-,root,root,-)
446 %{TZ_SYS_RO_APP}/ise-default/tv/*
450 # This is for old profile-based OBS project optimizations.
451 # In 4.0 unified build env, this if statement is always true.
452 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
454 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
457 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
458 if [ "$1" = "2" ]; then
461 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
464 for FILE in bin/*; do ln -sf "../ivi/${FILE}" ../bin; done
465 for FILE in res/*; do ln -sf "../ivi/${FILE}" ../res; done
468 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
469 if [ "$1" = "0" ]; then
470 pushd %{TZ_SYS_RO_APP}/ise-default
473 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
478 %manifest %{name}.manifest
479 %defattr(-,root,root,-)
480 %{TZ_SYS_RO_APP}/ise-default/ivi/*
484 # This is for old profile-based OBS project optimizations.
485 # In 4.0 unified build env, this if statement is always true.
486 # Common is blocked because wearable has extra efl-ext entries, which will be
487 # removed for unified build env later.
488 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
489 %files profile_wearable
491 %post profile_wearable-extension-circle
492 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
495 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
496 if [ "$1" = "2" ]; then
499 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
502 for FILE in bin/*; do ln -sf "../wearable-circle/${FILE}" ../bin; done
503 for FILE in res/*; do ln -sf "../wearable-circle/${FILE}" ../res; done
505 %preun profile_wearable-extension-circle
506 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
507 if [ "$1" = "0" ]; then
508 pushd %{TZ_SYS_RO_APP}/ise-default
511 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
515 %files profile_wearable-extension-circle
516 %manifest %{name}.manifest
517 %defattr(-,root,root,-)
518 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
521 %post profile_wearable-extension-rectangle
522 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
525 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
526 if [ "$1" = "2" ]; then
529 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
532 for FILE in bin/*; do ln -sf "../wearable-rectangle/${FILE}" ../bin; done
533 for FILE in res/*; do ln -sf "../wearable-rectangle/${FILE}" ../res; done
535 %preun profile_wearable-extension-rectangle
536 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
537 if [ "$1" = "0" ]; then
538 pushd %{TZ_SYS_RO_APP}/ise-default
541 for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
545 %files profile_wearable-extension-rectangle
546 %manifest %{name}.manifest
547 %defattr(-,root,root,-)
548 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*