Update package version to 1.6.21
[platform/core/uifw/ise-default.git] / packaging / ise-default.spec
1 Name:       ise-default
2 Summary:    Tizen keyboard
3 Version:    1.6.21
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    ise-default-%{version}.tar.gz
8 BuildRequires:  gettext-tools
9 BuildRequires:  edje-bin
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(libscl-ui)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(efl-extension)
18 BuildRequires:  pkgconfig(libtzplatform-config)
19 BuildRequires:  pkgconfig(stt)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-appfw-preference)
22 BuildRequires:  pkgconfig(capi-media-sound-manager)
23 BuildRequires:  pkgconfig(capi-ui-inputmethod)
24 BuildRequires:  pkgconfig(smartreply)
25 BuildRequires:  pkgconfig(key-manager)
26 BuildRequires:  pkgconfig(ode)
27 BuildRequires:  pkgconfig(capi-system-system-settings)
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(gio-2.0)
30 BuildRequires:  pkgconfig(pkgmgr-info)
31 Requires:       ise-engine-glm
32 Requires:       ise-engine-default
33
34 # This is for old profile-based OBS project optimizations.
35 # In 4.0 unified build env, this if statement is always true.
36 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(cbhm)
38 %endif
39 Requires:       %{name}-compat = %{version}-%{release}
40 # This is for old profile-based OBS project optimizations.
41 # In 4.0 unified build env, this if statement is always true.
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
43 Recommends:     %{name}-profile_common = %{version}-%{release}
44 %endif
45
46 %description
47 Description: Tizen keyboard
48
49
50 # This is for old profile-based OBS project optimizations.
51 # In 4.0 unified build env, this if statement is always true.
52 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
53 %package profile_common
54 Summary:    ise-default binaries and resources without flavors
55 Provides:   %{name}-compat = %{version}-%{release}
56 Conflicts:  %{name}-profile_mobile
57 Conflicts:  %{name}-profile_tv
58 Conflicts:  %{name}-profile_wearable
59 Conflicts:  %{name}-profile_ivi
60 %description profile_common
61 Tizen keyboard (ise-default) binaries and resources without flavors, intended
62 to support common profiles, which does not supply any additional options
63 for the build.
64 %endif
65
66 # This is for old profile-based OBS project optimizations.
67 # In 4.0 unified build env, this if statement is always true.
68 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
69 %package profile_mobile
70 Summary:    ise-default binaries and resources with mobile profile
71 Provides:   %{name}-compat = %{version}-%{release}
72 Conflicts:  %{name}-profile_common
73 Conflicts:  %{name}-profile_tv
74 Conflicts:  %{name}-profile_wearable
75 Conflicts:  %{name}-profile_ivi
76 %description profile_mobile
77 Tizen keyboard (ise-default) binaries and resources with mobile options.
78 This is intended to support mobile profiles.
79 %endif
80
81 # This is for old profile-based OBS project optimizations.
82 # In 4.0 unified build env, this if statement is always true.
83 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
84 %package profile_tv
85 Summary:    ise-default binaries and resources with tv profile
86 Provides:   %{name}-compat = %{version}-%{release}
87 Conflicts:  %{name}-profile_common
88 Conflicts:  %{name}-profile_mobile
89 Conflicts:  %{name}-profile_wearable
90 Conflicts:  %{name}-profile_ivi
91 %description profile_tv
92 Tizen keyboard (ise-default) binaries and resources with tv options.
93 This is intended to support tv profiles.
94 %endif
95
96 # This is for old profile-based OBS project optimizations.
97 # In 4.0 unified build env, this if statement is always true.
98 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
99 %package profile_ivi
100 Summary:    ise-default binaries and resources with ivi profile
101 Provides:   %{name}-compat = %{version}-%{release}
102 Conflicts:  %{name}-profile_common
103 Conflicts:  %{name}-profile_mobile
104 Conflicts:  %{name}-profile_wearable
105 Conflicts:  %{name}-profile_tv
106 %description profile_ivi
107 Tizen keyboard (ise-default) binaries and resources with ivi options.
108 This is intended to support ivi profiles.
109 %endif
110
111 # This is for old profile-based OBS project optimizations.
112 # In 4.0 unified build env, this if statement is always true.
113 # Common is blocked because wearable has extra efl-ext entries, which will be
114 # removed for unified build env later.
115 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
116 %package profile_wearable
117 Summary:    Meta package of ise-default for wearable profiles. (circle/rectangle)
118 Provides:   %{name}-compat = %{version}-%{release}
119 Conflicts:  %{name}-profile_common
120 Conflicts:  %{name}-profile_mobile
121 Conflicts:  %{name}-profile_tv
122 Conflicts:  %{name}-profile_ivi
123 Requires:   %{name}-profile_wearable-extension = %{version}-%{release}
124 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
125 %description profile_wearable
126 Meta package of Tizen keyboard (ise-default) binaries and resources with
127 wearable options.
128
129 %package profile_wearable-extension-circle
130 Summary:    ise-default binaries and resources with wearable profile (circle)
131 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
132 Conflicts:  %{name}-profile_wearable-extension-rectangle
133 %description profile_wearable-extension-circle
134 Tizen keyboard (ise-default) binaries and resources with wearable options.
135 This is intended to support wearable profiles with circle display.
136
137 %package profile_wearable-extension-rectangle
138 Summary:    ise-default binaries and resources with wearable profile (rectangle)
139 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
140 Conflicts:  %{name}-profile_wearable-extension-circle
141 %description profile_wearable-extension-rectangle
142 Tizen keyboard (ise-default) binaries and resources with wearable options.
143 This is intended to support wearable profiles with rectangle display.
144 %endif
145
146 %prep
147 %setup -q
148
149
150 %build
151 export CFLAGS_BASE="${CFLAGS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
152 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden -fvisibility=hidden"
153 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
154
155 rm -rf CMakeFiles
156 rm -rf CMakeCache.txt
157
158 # This is for old profile-based OBS project optimizations.
159 # In 4.0 unified build env, this if statement is always true.
160 # Common is blocked because wearable has extra efl-ext entries, which will be
161 # removed for unified build env later.
162 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
163 mkdir -p build_wearable_rec
164 pushd build_wearable_rec
165 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
166 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
167 %cmake .. -DTARGET=wearable \
168          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
169          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
170
171 make %{?jobs:-j%jobs}
172 popd
173
174 mkdir -p build_wearable_cir
175 pushd build_wearable_cir
176 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
177 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
178 %cmake .. -DTARGET=wearable \
179          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
180          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
181
182 make %{?jobs:-j%jobs}
183 popd
184 %endif
185
186
187 # This is for old profile-based OBS project optimizations.
188 # In 4.0 unified build env, this if statement is always true.
189 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
190 mkdir -p build_mobile
191 pushd build_mobile
192 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
193 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
194 %cmake .. -DTARGET=mobile \
195          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
196          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
197          -Dwith_cbhm=TRUE
198
199 make %{?jobs:-j%jobs}
200 popd
201 %endif
202
203 # This is for old profile-based OBS project optimizations.
204 # In 4.0 unified build env, this if statement is always true.
205 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
206 mkdir -p build_tv
207 pushd build_tv
208 export CFLAGS="${CFLAGS_BASE} -D_TV";
209 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
210 %cmake .. -DTARGET=tv \
211          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
212          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
213
214 make %{?jobs:-j%jobs}
215 popd
216 %endif
217
218 # This is for old profile-based OBS project optimizations.
219 # In 4.0 unified build env, this if statement is always true.
220 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
221 mkdir -p build_ivi
222 pushd build_ivi
223 export CFLAGS="${CFLAGS_BASE} -D_IVI";
224 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
225 %cmake .. -DTARGET=ivi \
226          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
227          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
228
229 make %{?jobs:-j%jobs}
230 popd
231 %endif
232
233 # This is for old profile-based OBS project optimizations.
234 # In 4.0 unified build env, this if statement is always true.
235 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
236 export CFLAGS="${CFLAGS_BASE}";
237 export CXXFLAGS="${CXXFLAGS_BASE}";
238 %cmake . -DTARGET=common \
239         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
240         -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
241
242 make %{?jobs:-j%jobs}
243 %endif
244
245 %install
246 rm -rf %{buildroot}
247
248 # This is for old profile-based OBS project optimizations.
249 # In 4.0 unified build env, this if statement is always true.
250 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
251 %make_install
252 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
253 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
254 mv bin common/
255 mkdir -p common/res
256 pushd res
257 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
258 popd
259 popd
260 %endif
261
262 # This is for old profile-based OBS project optimizations.
263 # In 4.0 unified build env, this if statement is always true.
264 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
265 pushd build_mobile
266 %make_install
267 popd
268 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
269 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
270 mv bin mobile/
271 mkdir -p mobile/res
272 pushd res
273 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
274 popd
275 popd
276 %endif
277
278 # This is for old profile-based OBS project optimizations.
279 # In 4.0 unified build env, this if statement is always true.
280 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
281 pushd build_tv
282 %make_install
283 popd
284 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
285 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
286 mv bin tv/
287 mkdir -p tv/res
288 pushd res
289 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
290 popd
291 popd
292 %endif
293
294 # This is for old profile-based OBS project optimizations.
295 # In 4.0 unified build env, this if statement is always true.
296 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
297 pushd build_ivi
298 %make_install
299 popd
300 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
301 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
302 mv bin ivi/
303 mkdir -p ivi/res
304 pushd res
305 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
306 popd
307 popd
308 %endif
309
310 # This is for old profile-based OBS project optimizations.
311 # In 4.0 unified build env, this if statement is always true.
312 # Common is blocked because wearable has extra efl-ext entries, which will be
313 # removed for unified build env later.
314 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
315 pushd build_wearable_cir
316 %make_install
317 popd
318 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
319 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
320 mv bin wearable-circle/
321 mkdir -p wearable-circle/res
322 pushd res
323 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
324 popd
325 popd
326
327 pushd build_wearable_rec
328 %make_install
329 popd
330 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
331 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
332 mv bin wearable-rectangle/
333 mkdir -p wearable-rectangle/res
334 pushd res
335 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
336 popd
337 popd
338 %endif
339
340 %find_lang %{name}
341
342 %files -f %{name}.lang
343 %manifest %{name}.manifest
344 %defattr(-,root,root,-)
345 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
346 %license LICENSE
347
348 # This is for old profile-based OBS project optimizations.
349 # In 4.0 unified build env, this if statement is always true.
350 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
351 %post profile_common
352 pushd %{TZ_SYS_RO_APP}/ise-default/common/
353 mkdir -p ../res
354 mkdir -p ../bin
355 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
356 if [ "$1" = "2" ]; then
357     rm -Rf ../bin/*
358     pushd ../res
359     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
360     popd
361 fi
362 for FILE in bin/*; do ln -sf "../common/${FILE}" ../bin; done
363 for FILE in res/*; do ln -sf "../common/${FILE}" ../res; done
364 popd
365 %preun profile_common
366 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
367 if [ "$1" = "0" ]; then
368     pushd %{TZ_SYS_RO_APP}/ise-default
369     rm -Rf bin
370     pushd res
371     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
372     popd
373     popd
374 fi
375 %files profile_common
376 %manifest %{name}.manifest
377 %defattr(-,root,root,-)
378 %{TZ_SYS_RO_APP}/ise-default/common/*
379 %endif
380
381
382 # This is for old profile-based OBS project optimizations.
383 # In 4.0 unified build env, this if statement is always true.
384 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
385 %post profile_mobile
386 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
387 mkdir -p ../res
388 mkdir -p ../bin
389 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
390 if [ "$1" = "2" ]; then
391     rm -Rf ../bin/*
392     pushd ../res
393     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
394     popd
395 fi
396 for FILE in bin/*; do ln -sf "../mobile/${FILE}" ../bin; done
397 for FILE in res/*; do ln -sf "../mobile/${FILE}" ../res; done
398 popd
399 %preun profile_mobile
400 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
401 if [ "$1" = "0" ]; then
402     pushd %{TZ_SYS_RO_APP}/ise-default
403     rm -Rf bin
404     pushd res
405     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
406     popd
407     popd
408 fi
409 %files profile_mobile
410 %manifest %{name}.manifest
411 %defattr(-,root,root,-)
412 %{TZ_SYS_RO_APP}/ise-default/mobile/*
413 %endif
414
415
416 # This is for old profile-based OBS project optimizations.
417 # In 4.0 unified build env, this if statement is always true.
418 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
419 %post profile_tv
420 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
421 mkdir -p ../res
422 mkdir -p ../bin
423 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
424 if [ "$1" = "2" ]; then
425     rm -Rf ../bin/*
426     pushd ../res
427     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
428     popd
429 fi
430 for FILE in bin/*; do ln -sf "../tv/${FILE}" ../bin; done
431 for FILE in res/*; do ln -sf "../tv/${FILE}" ../res; done
432 popd
433 %preun profile_tv
434 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
435 if [ "$1" = "0" ]; then
436     pushd %{TZ_SYS_RO_APP}/ise-default
437     rm -Rf bin
438     pushd res
439     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
440     popd
441     popd
442 fi
443 %files profile_tv
444 %manifest %{name}.manifest
445 %defattr(-,root,root,-)
446 %{TZ_SYS_RO_APP}/ise-default/tv/*
447 %endif
448
449
450 # This is for old profile-based OBS project optimizations.
451 # In 4.0 unified build env, this if statement is always true.
452 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
453 %post profile_ivi
454 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
455 mkdir -p ../res
456 mkdir -p ../bin
457 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
458 if [ "$1" = "2" ]; then
459     rm -Rf ../bin/*
460     pushd ../res
461     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
462     popd
463 fi
464 for FILE in bin/*; do ln -sf "../ivi/${FILE}" ../bin; done
465 for FILE in res/*; do ln -sf "../ivi/${FILE}" ../res; done
466 popd
467 %preun profile_ivi
468 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
469 if [ "$1" = "0" ]; then
470     pushd %{TZ_SYS_RO_APP}/ise-default
471     rm -Rf bin
472     pushd res
473     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
474     popd
475     popd
476 fi
477 %files profile_ivi
478 %manifest %{name}.manifest
479 %defattr(-,root,root,-)
480 %{TZ_SYS_RO_APP}/ise-default/ivi/*
481 %endif
482
483
484 # This is for old profile-based OBS project optimizations.
485 # In 4.0 unified build env, this if statement is always true.
486 # Common is blocked because wearable has extra efl-ext entries, which will be
487 # removed for unified build env later.
488 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
489 %files profile_wearable
490
491 %post profile_wearable-extension-circle
492 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
493 mkdir -p ../res
494 mkdir -p ../bin
495 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
496 if [ "$1" = "2" ]; then
497     rm -Rf ../bin/*
498     pushd ../res
499     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
500     popd
501 fi
502 for FILE in bin/*; do ln -sf "../wearable-circle/${FILE}" ../bin; done
503 for FILE in res/*; do ln -sf "../wearable-circle/${FILE}" ../res; done
504 popd
505 %preun profile_wearable-extension-circle
506 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
507 if [ "$1" = "0" ]; then
508     pushd %{TZ_SYS_RO_APP}/ise-default
509     rm -Rf bin
510     pushd res
511     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
512     popd
513     popd
514 fi
515 %files profile_wearable-extension-circle
516 %manifest %{name}.manifest
517 %defattr(-,root,root,-)
518 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
519
520
521 %post profile_wearable-extension-rectangle
522 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
523 mkdir -p ../res
524 mkdir -p ../bin
525 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
526 if [ "$1" = "2" ]; then
527     rm -Rf ../bin/*
528     pushd ../res
529     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
530     popd
531 fi
532 for FILE in bin/*; do ln -sf "../wearable-rectangle/${FILE}" ../bin; done
533 for FILE in res/*; do ln -sf "../wearable-rectangle/${FILE}" ../res; done
534 popd
535 %preun profile_wearable-extension-rectangle
536 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
537 if [ "$1" = "0" ]; then
538     pushd %{TZ_SYS_RO_APP}/ise-default
539     rm -Rf bin
540     pushd res
541     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
542     popd
543     popd
544 fi
545 %files profile_wearable-extension-rectangle
546 %manifest %{name}.manifest
547 %defattr(-,root,root,-)
548 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*
549 %endif