Fix up to work with IVI kernel-headers
[profile/ivi/iptables.git] / packaging / iptables.spec
1 Name: iptables
2 Summary: administration tools for packet filtering and NAT
3 Version: 1.4.9.1
4 Release: 1
5 Source: %{name}-%{version}.tar.gz
6 Group: System/Base
7 URL: http://www.netfilter.org/
8 License: GPLv2
9 BuildRequires: kernel-headers
10 Conflicts: kernel < 2.4.20
11 Patch1: aligned_u64_error.patch
12
13
14 %description
15 These are the user-space administration tools for the Linux
16 kernel's netfilter and iptables. netfilter and iptables provide
17 a framework for stateful and stateless packet filtering, network 
18 and port address translation, and other IP packet manipulation.
19 The framework is the successor to ipchains.
20 netfilter and iptables are used in applications such as Internet
21 connection sharing, firewalls, IP accounting, transparent proxying,
22 advanced routing and traffic control.
23
24 %package ipv6
25 Summary: IPv6 support for iptables
26 Group: System/Base
27 Requires: %{name} = %{version}-%{release}
28
29 %description ipv6
30 The iptables package contains IPv6 (the next version of the IP
31 protocol) support for iptables. Iptables controls the Linux kernel
32 network packet filtering code, allowing you to set up firewalls and IP
33 masquerading. 
34
35 Install iptables-ipv6 if you need to set up firewalling for your
36 network and you are using ipv6.
37
38 %package devel
39 Summary: development files for iptable's libipq
40 Group: System/Base
41 Requires: %{name} = %{version}-%{release}
42
43 %description devel
44 Header files, static libs and documentation for libipq, iptables'
45 user-space packet queuing library.
46
47 %prep
48 %setup -q
49 %patch1 -p1
50
51 %build
52 %autogen
53 %configure --prefix=%{_prefix}
54 make %{?jobs:-j%jobs}
55
56 %install
57 rm -rf %{buildroot}
58 make install DESTDIR=%{buildroot}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT 
62
63 %post
64 /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(-,root,root)
70 /usr/bin/iptables-xml
71 /usr/lib/libip4tc.so
72 /usr/lib/libip4tc.so.*
73 /usr/lib/libiptc.so
74 /usr/lib/libiptc.so.*
75 /usr/lib/libxtables.so
76 /usr/lib/libxtables.so.*
77 /usr/libexec/xtables/libipt*
78 /usr/libexec/xtables/libxt*
79 /usr/sbin/iptables*
80
81 %files ipv6
82 %defattr(-,root,root)
83 /usr/sbin/ip6tables*
84 /usr/lib/libip6tc.so
85 /usr/lib/libip6tc.so.*
86 /usr/libexec/xtables/libip6t*
87
88 %files devel
89 %defattr(-,root,root)
90 /usr/include/*
91 /usr/lib/*.la
92 /usr/lib/pkgconfig/*
93 %{_mandir}/man8/iptables*
94 %{_mandir}/man8/ip6tables*