packaging: use parallel build
[profile/ivi/intel-emgd-kmod.git] / packaging / intel-emgd-kmod.spec
1 #----------------------------------------------------------------------------
2 # Copyright (c) 2002-2010, Intel Corporation.
3 #
4 # Permission is hereby granted, free of charge, to any person obtaining a copy
5 # of this software and associated documentation files (the "Software"), to deal
6 # in the Software without restriction, including without limitation the rights
7 # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
8 # copies of the Software, and to permit persons to whom the Software is
9 # furnished to do so, subject to the following conditions:
10 #
11 # The above copyright notice and this permission notice shall be included in
12 # all copies or substantial portions of the Software.
13 #
14 # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
15 # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
16 # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
17 # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
18 # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
19 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
20 # THE SOFTWARE.
21 #----------------------------------------------------------------------------
22
23 %define debug_package %{nil}
24 %define kernel_number_str "%(/bin/rpm -q kernel-adaptation-intel-automotive --queryformat \"%{VERSION}-%{RELEASE}\"|grep -iv 'installed')"
25 %define kernel_number %(echo %{kernel_number_str})
26 %define kernel_version %{kernel_number}-adaptation-intel-automotive
27 %define modpath /lib/modules/%{kernel_version}/kernel/drivers/gpu/drm/emgd
28
29 Name: intel-emgd-kmod
30 Summary: Intel EMGD kernel module
31 Version: 2667
32 Release: 1%{?dist}
33 License: GPL v2
34 Vendor: Intel
35 Group: System Environment/Kernel
36 BuildRoot: %{_tmppath}/%{name}-%{version}
37 Source0: %{name}-%{version}.tar.gz
38 BuildRequires: kernel-adaptation-intel-automotive-devel
39 BuildRequires: kmod
40 Requires: pciutils
41 Requires: kmod
42 Requires(post): /bin/ln
43 %if %{kernel_number_str} != ""
44 Requires: kernel-adaptation-intel-automotive = %{kernel_number}
45 %else
46 Requires: kernel-adaptation-intel-automotive
47 %endif
48
49 %description
50 Intel EMGD kernel module for kernel
51
52 %prep
53 %setup -q
54
55 %build
56 make -C drivers %{?_smp_mflags}
57
58 %install
59
60 mkdir -p $RPM_BUILD_ROOT/usr/lib/systemd/system/
61 mkdir -p $RPM_BUILD_ROOT/usr/libexec/
62 install -m 755 -d $RPM_BUILD_ROOT%{modpath}
63 install -m 744 drivers/emgd.ko $RPM_BUILD_ROOT%{modpath}
64 install -m 755 -D service/intel-emgd-kmod.service $RPM_BUILD_ROOT/usr/lib/systemd/system/
65 install -m 755 -D service/intel-emgd-kmod.init $RPM_BUILD_ROOT/usr/libexec/
66
67 %clean  
68 rm -Rf $RPM_BUILD_ROOT
69
70 %post
71 ## create the dependency of kernel modules
72 /sbin/depmod -av %{kernel_version} >/dev/null 2>&1 
73
74 mkdir -p /usr/lib/systemd/system/basic.target.wants/
75 pushd /usr/lib/systemd/system/basic.target.wants/
76 ln -sf ../intel-emgd-kmod.service intel-emgd-kmod.service
77 popd
78
79 if [ -x /bin/systemctl ]; then
80     /bin/systemctl daemon-reload >/dev/null 2>&1 || :
81     /bin/systemctl start intel-emgd-kmod.service > /dev/null 2>&1 || :
82 fi
83
84 %postun
85 /sbin/depmod -av %{kernel_version} >/dev/null 2>&1 
86 rm -f /usr/lib/systemd/system/basic.target.wants/intel-emgd-kmod.service
87 if [ -x /bin/systemctl ]; then
88     systemctl daemon-reload >/dev/null 2>&1 || :
89 fi
90
91 %preun
92 if [ -x /bin/systemctl ]; then
93     sytemctl stop intel-emgd-kmod.service >/dev/null 2>&1 || :
94 fi
95
96 %files
97 %defattr(-,root,root,-)
98 %{modpath}/emgd.ko
99 %{_libdir}/systemd/system/intel-emgd-kmod.service
100 /usr/libexec/intel-emgd-kmod.init