b9860eabee6bae7fadbc777b2bf292af89ba9dc7
[platform/core/multimedia/inference-engine-opencv.git] / packaging / inference-engine-opencv.spec
1 Name:       inference-engine-opencv
2 Summary:    OpenCV based implementation of inference-engine-interface
3 Version:    0.0.2
4 Release:    6
5 Group:      Multimedia/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(opencv)
13 BuildRequires: pkgconfig(inference-engine-interface-common)
14
15 %description
16 OpenCV based implementation of inference-engine-interface
17
18
19 %prep
20 %setup -q
21
22 %build
23 %if 0%{?sec_build_binary_debug_enable}
24 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
25 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
26 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
27 %endif
28
29 #MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
30 %cmake .
31
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36
37 %make_install
38
39 %post -p /sbin/ldconfig
40 %postun -p /sbin/ldconfig
41
42 %files
43 %manifest %{name}.manifest
44 %license LICENSE.APLv2
45 %defattr(-,root,root,-)
46 %{_libdir}/*.so