CLtuner generator initial drafts
[platform/core/multimedia/inference-engine-interface.git] / packaging / inference-engine-interface.spec
1 Name:        inference-engine-interface
2 Summary:     Interface of inference engines
3 Version:     0.0.2
4 Release:     14
5 Group:       Multimedia/Framework
6 License:     Apache-2.0
7 Source0:     %{name}-%{version}.tar.gz
8 BuildRequires: cmake
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(libtzplatform-config)
11 BuildRequires: pkgconfig(python)
12 BuildRequires: pkgconfig(iniparser)
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: gtest-devel
15
16 %description
17 Interface of inference engines
18
19 %package devel
20 Summary:    Interface of inference engines
21 Group:      Multimedia/Framework
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25 Interface of inference engines (Dev)
26
27
28 %package common
29 Summary:    Common interface of inference engines
30 Group:      Multimedia/Framework
31
32 %description common
33 Common interface of inference engines
34
35 %package common-devel
36 Summary:    Common interface of inference engines
37 Group:      Multimedia/Framework
38 Requires:   inference-engine-interface-common
39
40 %description common-devel
41 Common interface of inference engines (Dev)
42
43 %prep
44 %setup -q
45
46 %build
47 %if 0%{?sec_build_binary_debug_enable}
48 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
50 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
51 %endif
52
53 export CFLAGS+=" -DPATH_LIBDIR=\\\"%{_libdir}\\\" -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\""
54 export CXXFLAGS+=" -DPATH_LIBDIR=\\\"%{_libdir}\\\" -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\""
55
56 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
57 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTZ_SYS_BIN=%TZ_SYS_BIN \
58
59 make %{?jobs:-j%jobs}
60
61 %install
62 rm -rf %{buildroot}
63
64 mkdir -p %{buildroot}/usr/bin/
65 mkdir -p %{buildroot}/opt/usr/images/
66 %make_install
67
68 install -m 755 test/bin/inference_engine_profiler %{buildroot}%{_bindir}
69 install -m 755 test/bin/inference_engine_tc %{buildroot}%{_bindir}
70 install -m 755 start_profiler.sh %{buildroot}%{_bindir}
71 install -m 666 test/res/*.bin %{buildroot}/opt/usr/images
72 install -m 755 test/bin/inference_engine_cltuner %{buildroot}%{_bindir}
73
74 %post -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files common
78 %manifest inference-engine-interface-common.manifest
79 %license LICENSE.APLv2
80 %{_libdir}/libinference-engine-interface-common.so.*
81
82 %files common-devel
83 %{_includedir}/media/*.h
84 %{_libdir}/pkgconfig/*common.pc
85 %{_libdir}/lib*-common.so
86 %{_bindir}/inference_engine_profiler
87 %{_bindir}/inference_engine_tc
88 %{_bindir}/start_profiler.sh
89 %{_bindir}/inference_engine_cltuner
90 /opt/usr/images/*.bin