resetting manifest requested domain to floor
[platform/upstream/imake.git] / packaging / imake.spec
1 Name:           imake
2 Version:        1.0.5
3 Release:        0
4 License:        MIT
5 Summary:        C preprocessor interface to the make utility
6 Url:            http://xorg.freedesktop.org/
7 Group:          Development/Tools/Building
8 Source:         %{name}-%{version}.tar.bz2
9 Source1001:     imake.manifest
10 BuildRequires:  pkg-config
11 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
12 BuildRequires:  pkgconfig(xproto)
13 # This was part of the xorg-x11-util-devel package up to version 7.6
14 Requires:       xorg-cf-files
15
16 %description
17 Imake is used to generate Makefiles from a template, a set of cpp macro
18 functions, and a per-directory input file called an Imakefile.
19
20 The X Window System used imake extensively up through the X11R6.9
21 release, for both full builds within the source tree and external
22 software. X has since moved to GNU autoconf and automake for its build
23 system in X11R7.0 and later releases, but still maintains imake for
24 building existing external software programs that have not yet
25 converted.
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %configure --with-config-dir=%{_datadir}/X11/config
33 make %{?_smp_mflags}
34
35 %install
36 %make_install
37
38 %files
39 %manifest %{name}.manifest
40 %defattr(-,root,root)
41 %doc COPYING README
42 %{_bindir}/ccmakedep
43 %{_bindir}/cleanlinks
44 %{_bindir}/imake
45 %{_bindir}/makeg
46 %{_bindir}/mergelib
47 %{_bindir}/mkdirhier
48 %{_bindir}/mkhtmlindex
49 %{_bindir}/revpath
50 %{_bindir}/xmkmf
51
52 %docs_package
53
54 %changelog