add packaging
[platform/upstream/imake.git] / packaging / imake.spec
1 Name:           imake
2 Version:        1.0.5
3 Release:        0
4 License:        MIT
5 Summary:        C preprocessor interface to the make utility
6 Url:            http://xorg.freedesktop.org/
7 Group:          Development/Tools/Building
8 Source:         %{name}-%{version}.tar.bz2
9 BuildRequires:  pkg-config
10 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
11 BuildRequires:  pkgconfig(xproto)
12 # This was part of the xorg-x11-util-devel package up to version 7.6
13 Requires:       xorg-cf-files
14
15 %description
16 Imake is used to generate Makefiles from a template, a set of cpp macro
17 functions, and a per-directory input file called an Imakefile.
18
19 The X Window System used imake extensively up through the X11R6.9
20 release, for both full builds within the source tree and external
21 software. X has since moved to GNU autoconf and automake for its build
22 system in X11R7.0 and later releases, but still maintains imake for
23 building existing external software programs that have not yet
24 converted.
25
26 %prep
27 %setup -q
28
29 %build
30 %configure --with-config-dir=%{_datadir}/X11/config
31 make %{?_smp_mflags}
32
33 %install
34 %make_install
35
36 %files
37 %defattr(-,root,root)
38 %doc COPYING README
39 %{_bindir}/ccmakedep
40 %{_bindir}/cleanlinks
41 %{_bindir}/imake
42 %{_bindir}/makeg
43 %{_bindir}/mergelib
44 %{_bindir}/mkdirhier
45 %{_bindir}/mkhtmlindex
46 %{_bindir}/revpath
47 %{_bindir}/xmkmf
48
49 %docs_package
50
51 %changelog