add spec
[platform/upstream/icu.git] / packaging / icu.spec
1 Name:      icu
2 Version:   4.8.1.1
3 Release:   1
4 Summary:   International Components for Unicode
5 Group:     Development/Tools
6 License:   ICU
7 URL:       http://www.icu-project.org/
8 Source0:   /tmp/icu4c-4_8_1_1-src.tgz
9 BuildRequires: doxygen
10 BuildRequires: autoconf
11
12 %description
13 Tools and utilities for developing with icu.
14
15 %package -n lib%{name}
16 Summary: International Components for Unicode - libraries
17 Group:   System/Libraries
18
19 %description -n lib%{name}
20 The International Components for Unicode (ICU) libraries provide
21 robust and full-featured Unicode services on a wide variety of
22 platforms. ICU supports the most current version of the Unicode
23 standard, and they provide support for supplementary Unicode
24 characters (needed for GB 18030 repertoire support).
25 As computing environments become more heterogeneous, software
26 portability becomes more important. ICU lets you produce the same
27 results across all the various platforms you support, without
28 sacrificing performance. It offers great flexibility to extend and
29 customize the supplied services.
30
31 %package  -n lib%{name}-devel
32 Summary:  Development files for International Components for Unicode
33 Group:    Development/Libraries
34 Requires: lib%{name} = %{version}-%{release}
35 Requires: pkgconfig
36
37 %description -n lib%{name}-devel
38 Includes and definitions for developing with icu.
39
40 %prep
41 %setup -q -n %{name}
42
43 %build
44 cd source
45 %configure ./runConfigureICU Linux --disable-renaming --prefix=%{_prefix}
46 make
47
48 %install
49 cd source
50 %make_install
51
52 # bugs of rpmdeps
53 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
54
55 %remove_docs
56
57
58 %post -n lib%{name} -p /sbin/ldconfig
59
60 %postun -n lib%{name} -p /sbin/ldconfig
61
62 %files
63
64 %files -n lib%{name}
65 %{_libdir}/*.so*
66 %{_bindir}/derb
67 %{_bindir}/genbrk
68 %{_bindir}/gencfu
69 %{_bindir}/gencnval
70 %{_bindir}/genctd
71 %{_bindir}/genrb
72 %{_bindir}/makeconv
73 %{_bindir}/pkgdata
74 %{_bindir}/uconv
75 %{_bindir}/icuinfo
76 %{_bindir}/icu-config
77 %{_sbindir}/*
78 %dir %{_datadir}/icu/4.8.1.1
79 %{_datadir}/icu/4.8.1.1/config/mh-linux
80 %{_datadir}/icu/4.8.1.1/install-sh
81 %{_datadir}/icu/4.8.1.1/license.html
82 %{_datadir}/icu/4.8.1.1/mkinstalldirs
83
84 %files -n lib%{name}-devel
85 %{_includedir}/layout
86 %{_includedir}/unicode
87 %{_libdir}/*.so
88 %{_libdir}/pkgconfig/icu-*.pc
89 %{_libdir}/%{name}