Hardcode exact version in Source0 field
[platform/upstream/icu.git] / packaging / icu.spec
1 Name:      icu
2 Version:   4.8.1.1
3 Release:   1
4 Summary:   International Components for Unicode
5 Group:      System/Libraries
6 License:   ICU
7 URL:       http://www.icu-project.org/
8 Source0:   icu4c-4_8_1_1-src.tgz
9 Source1001:     icu.manifest
10 BuildRequires: doxygen
11 BuildRequires: autoconf
12
13 %description
14 Tools and utilities for developing with icu.
15
16 %package -n libicu
17 Summary: International Components for Unicode - libraries
18
19 %description -n libicu
20 The International Components for Unicode (ICU) libraries provide
21 robust and full-featured Unicode services on a wide variety of
22 platforms. ICU supports the most current version of the Unicode
23 standard, and they provide support for supplementary Unicode
24 characters (needed for GB 18030 repertoire support).
25 As computing environments become more heterogeneous, software
26 portability becomes more important. ICU lets you produce the same
27 results across all the various platforms you support, without
28 sacrificing performance. It offers great flexibility to extend and
29 customize the supplied services.
30
31 %package  -n libicu-devel
32 Summary:  Development files for International Components for Unicode
33 Requires: libicu = %{version}-%{release}
34 Requires: pkgconfig
35
36 %description -n libicu-devel
37 Includes and definitions for developing with icu.
38
39 %prep
40 %setup -q -n %{name}
41 cp %{SOURCE1001} .
42
43 %build
44 cd source
45 %configure --disable-static \
46             --disable-renaming \
47             --enable-shared \
48             --disable-samples
49 make %{?_smp_mflags}
50
51 %install
52 cd source
53 %make_install
54
55 # bugs of rpmdeps
56 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
57
58 %remove_docs
59
60
61 %post -n libicu -p /sbin/ldconfig
62
63 %postun -n libicu -p /sbin/ldconfig
64
65 %files
66 %manifest %{name}.manifest
67
68 %files -n libicu
69 %manifest %{name}.manifest
70 %{_libdir}/*.so*
71 %{_bindir}/derb
72 %{_bindir}/genbrk
73 %{_bindir}/gencfu
74 %{_bindir}/gencnval
75 %{_bindir}/genctd
76 %{_bindir}/genrb
77 %{_bindir}/makeconv
78 %{_bindir}/pkgdata
79 %{_bindir}/uconv
80 %{_bindir}/icuinfo
81 %{_bindir}/icu-config
82 %{_sbindir}/*
83 %dir %{_datadir}/icu/%{version}
84 %{_datadir}/icu/%{version}/config/mh-linux
85 %{_datadir}/icu/%{version}/install-sh
86 %{_datadir}/icu/%{version}/license.html
87 %{_datadir}/icu/%{version}/mkinstalldirs
88
89 %files -n libicu-devel
90 %manifest %{name}.manifest
91 %{_includedir}/layout
92 %{_includedir}/unicode
93 %{_libdir}/*.so
94 %{_libdir}/pkgconfig/icu-*.pc
95 %{_libdir}/%{name}