Rebase for icu 57.1
[platform/upstream/icu.git] / packaging / icu.spec
1 %define run_tests 0
2 %if %{run_tests}
3     # check is defined off at .rpmmacros file.
4     %define check %%check
5 %endif
6
7 Name:      icu
8 Version:   57.1
9 Release:   1
10 Summary:   International Components for Unicode
11 Group:     System/Libraries
12 License:   ICU and Unicode-TOU and BSD-2.0
13 URL:       http://www.icu-project.org/
14 Source0:   %{name}-%{version}.tar.gz
15 Source1001:     icu.manifest
16 BuildRequires: doxygen
17 BuildRequires: autoconf
18
19 %description
20 Tools and utilities for developing with icu.
21
22 %package -n libicu
23 Summary: International Components for Unicode - libraries
24
25 %description -n libicu
26 The International Components for Unicode (ICU) libraries provide
27 robust and full-featured Unicode services on a wide variety of
28 platforms. ICU supports the most current version of the Unicode
29 standard, and they provide support for supplementary Unicode
30 characters (needed for GB 18030 repertoire support).
31 As computing environments become more heterogeneous, software
32 portability becomes more important. ICU lets you produce the same
33 results across all the various platforms you support, without
34 sacrificing performance. It offers great flexibility to extend and
35 customize the supplied services.
36
37 %package  -n libicu-devel
38 Summary:  Development files for International Components for Unicode
39 Requires: libicu = %{version}-%{release}
40 Requires: pkgconfig
41
42 %description -n libicu-devel
43 Includes and definitions for developing with icu.
44
45 %prep
46 %setup -q -n %{name}
47 cp %{SOURCE1001} .
48
49 %build
50 cd source
51 %configure --enable-static=no \
52             --enable-renaming=no \
53             --enable-shared \
54             --enable-plugins \
55             --enable-samples=no
56 make %{?_smp_mflags}
57
58 %check
59 %if %{run_tests}
60     pushd source
61     %__make check || exit 0
62     popd
63 %endif
64
65 %install
66 cd source
67 %make_install
68
69 # bugs of rpmdeps
70 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
71
72 %remove_docs
73
74
75 %post -n libicu -p /sbin/ldconfig
76
77 %postun -n libicu -p /sbin/ldconfig
78
79 %files
80 %manifest %{name}.manifest
81
82 %files -n libicu
83 %manifest %{name}.manifest
84 %{_libdir}/*.so*
85 %{_bindir}/derb
86 %{_bindir}/genbrk
87 %{_bindir}/gencfu
88 %{_bindir}/gencnval
89 %{_bindir}/gendict
90 %{_bindir}/genrb
91 %{_bindir}/makeconv
92 %{_bindir}/pkgdata
93 %{_bindir}/uconv
94 %{_bindir}/icuinfo
95 %{_bindir}/icu-config
96 %{_sbindir}/*
97 %dir %{_datadir}/icu/%{version}
98 %{_datadir}/icu/%{version}/config/mh-linux
99 %{_datadir}/icu/%{version}/install-sh
100 %{_datadir}/icu/%{version}/LICENSE
101 %{_datadir}/icu/%{version}/mkinstalldirs
102
103 %files -n libicu-devel
104 %manifest %{name}.manifest
105 %{_includedir}/layout
106 %{_includedir}/unicode
107 %{_libdir}/*.so
108 %{_libdir}/pkgconfig/icu-*.pc
109 %{_libdir}/%{name}