resetting manifest requested domain to floor
[platform/upstream/icu.git] / packaging / icu.spec
1 Name:      icu
2 Version:   4.8.1.1
3 Release:   1
4 Summary:   International Components for Unicode
5 Group:     Development/Tools
6 License:   ICU
7 URL:       http://www.icu-project.org/
8 Source0:   icu4c-4_8_1_1-src.tgz
9 Source1001:     icu.manifest
10 BuildRequires: doxygen
11 BuildRequires: autoconf
12
13 %description
14 Tools and utilities for developing with icu.
15
16 %package -n lib%{name}
17 Summary: International Components for Unicode - libraries
18 Group:   System/i18n
19
20 %description -n lib%{name}
21 The International Components for Unicode (ICU) libraries provide
22 robust and full-featured Unicode services on a wide variety of
23 platforms. ICU supports the most current version of the Unicode
24 standard, and they provide support for supplementary Unicode
25 characters (needed for GB 18030 repertoire support).
26 As computing environments become more heterogeneous, software
27 portability becomes more important. ICU lets you produce the same
28 results across all the various platforms you support, without
29 sacrificing performance. It offers great flexibility to extend and
30 customize the supplied services.
31
32 %package  -n lib%{name}-devel
33 Summary:  Development files for International Components for Unicode
34 Group:    Development/Libraries
35 Requires: lib%{name} = %{version}-%{release}
36 Requires: pkgconfig
37
38 %description -n lib%{name}-devel
39 Includes and definitions for developing with icu.
40
41 %prep
42 %setup -q -n %{name}
43 cp %{SOURCE1001} .
44
45 %build
46 cd source
47 %configure ./runConfigureICU Linux --disable-renaming --prefix=%{_prefix}
48 make
49
50 %install
51 cd source
52 %make_install
53
54 # bugs of rpmdeps
55 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
56
57 %remove_docs
58
59
60 %post -n lib%{name} -p /sbin/ldconfig
61
62 %postun -n lib%{name} -p /sbin/ldconfig
63
64 %files
65 %manifest %{name}.manifest
66
67 %files -n lib%{name}
68 %manifest %{name}.manifest
69 %{_libdir}/*.so*
70 %{_bindir}/derb
71 %{_bindir}/genbrk
72 %{_bindir}/gencfu
73 %{_bindir}/gencnval
74 %{_bindir}/genctd
75 %{_bindir}/genrb
76 %{_bindir}/makeconv
77 %{_bindir}/pkgdata
78 %{_bindir}/uconv
79 %{_bindir}/icuinfo
80 %{_bindir}/icu-config
81 %{_sbindir}/*
82 %dir %{_datadir}/icu/4.8.1.1
83 %{_datadir}/icu/4.8.1.1/config/mh-linux
84 %{_datadir}/icu/4.8.1.1/install-sh
85 %{_datadir}/icu/4.8.1.1/license.html
86 %{_datadir}/icu/4.8.1.1/mkinstalldirs
87
88 %files -n lib%{name}-devel
89 %manifest %{name}.manifest
90 %{_includedir}/layout
91 %{_includedir}/unicode
92 %{_libdir}/*.so
93 %{_libdir}/pkgconfig/icu-*.pc
94 %{_libdir}/%{name}