Bump to ICU 58.1
[platform/upstream/icu.git] / packaging / icu.spec
1
2 %define run_tests 0
3 %if %{run_tests}
4     # check is defined off at .rpmmacros file.
5     %define check %%check
6 %endif
7
8 Name:      icu
9 Version:   58.1
10 Release:   1
11 Summary:   International Components for Unicode
12 Group:     System/Libraries
13 License:   ICU and Unicode-TOU and BSD-3-Clause
14 URL:       http://www.icu-project.org/
15 Source0:   %{name}-%{version}.tar.gz
16 Source1001:     icu.manifest
17 BuildRequires: doxygen
18 BuildRequires: autoconf
19
20 %description
21 ICU is a set of C and C++ libraries that provides robust and full-featured
22 Unicode and locale support. The library provides calendar support, conversions
23 for many character sets, language sensitive collation, date
24 and time formatting, support for many locales, message catalogs
25 and resources, message formatting, normalization, number and currency
26 formatting, time zones support, transliteration, word, line and
27 sentence breaking, etc.
28
29 This package contains the Unicode character database and derived
30 properties, along with converters and time zones data.
31
32 This package contains the runtime libraries for ICU. It does
33 not contain any of the data files needed at runtime and present in the
34 `icu' and `icu-locales` packages.
35
36 %package -n libicu
37 Summary: International Components for Unicode (libraries)
38
39 %description -n libicu
40 ICU is a set of C and C++ libraries that provides robust and full-featured
41 Unicode support. This package contains the runtime libraries for ICU. It does
42 not contain any of the data files needed at runtime and present in the
43 `icu' and `icu-locales` packages.
44
45 %package  -n libicu-devel
46 Summary: International Components for Unicode (development files)
47 Requires: libicu = %{version}-%{release}
48 Requires: pkgconfig
49
50 %description -n libicu-devel
51 Includes and definitions for developing with icu.
52
53 %prep
54 %setup -q -n %{name}
55 cp %{SOURCE1001} .
56
57 %build
58 cd source
59 %configure --disable-static \
60             --disable-renaming \
61             --enable-shared \
62             --enable-plugins \
63             --disable-samples
64 make %{?_smp_mflags}
65
66 %check
67 %if %{run_tests}
68     pushd source
69     %__make check || exit 0
70     popd
71 %endif
72
73 %install
74 cd source
75 %make_install
76
77 # bugs of rpmdeps
78 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
79
80 %remove_docs
81
82
83 %post -n libicu -p /sbin/ldconfig
84
85 %postun -n libicu -p /sbin/ldconfig
86
87 %files
88 %manifest %{name}.manifest
89
90 %files -n libicu
91 %manifest %{name}.manifest
92 %{_libdir}/*.so*
93 %{_bindir}/derb
94 %{_bindir}/genbrk
95 %{_bindir}/gencfu
96 %{_bindir}/gencnval
97 %{_bindir}/gendict
98 %{_bindir}/genrb
99 %{_bindir}/makeconv
100 %{_bindir}/pkgdata
101 %{_bindir}/uconv
102 %{_bindir}/icuinfo
103 %{_bindir}/icu-config
104 %{_sbindir}/*
105 %dir %{_datadir}/icu/%{version}
106 %{_datadir}/icu/%{version}/config/mh-linux
107 %{_datadir}/icu/%{version}/install-sh
108 %{_datadir}/icu/%{version}/LICENSE
109 %{_datadir}/icu/%{version}/mkinstalldirs
110
111 %files -n libicu-devel
112 %manifest %{name}.manifest
113 %{_includedir}/unicode
114 %{_libdir}/*.so
115 %{_libdir}/pkgconfig/icu-*.pc
116 %{_libdir}/%{name}