add spec
[platform/upstream/icu.git] / packaging / icu.spec
1 Name:      icu
2 Version:   4.8.1.1
3 Release:   1
4 Summary:   International Components for Unicode
5 Group:     Development/Tools
6 License:   ICU
7 URL:       http://www.icu-project.org/
8 Source0:   /tmp/icu4c-4_8_1_1-src.tgz
9 BuildRequires: doxygen
10 BuildRequires: autoconf
11
12 %description
13 Tools and utilities for developing with icu.
14
15 %package -n lib%{name}
16 Summary: International Components for Unicode - libraries
17 Group:   System/Libraries
18
19 %description -n lib%{name}
20 The International Components for Unicode (ICU) libraries provide
21 robust and full-featured Unicode services on a wide variety of
22 platforms. ICU supports the most current version of the Unicode
23 standard, and they provide support for supplementary Unicode
24 characters (needed for GB 18030 repertoire support).
25 As computing environments become more heterogeneous, software
26 portability becomes more important. ICU lets you produce the same
27 results across all the various platforms you support, without
28 sacrificing performance. It offers great flexibility to extend and
29 customize the supplied services.
30
31 %package  -n lib%{name}-devel
32 Summary:  Development files for International Components for Unicode
33 Group:    Development/Libraries
34 Requires: lib%{name} = %{version}-%{release}
35 Requires: pkgconfig
36
37 %description -n lib%{name}-devel
38 Includes and definitions for developing with icu.
39
40 %prep
41 %setup -q
42
43 %build
44 cd source
45 %configure ./runConfigureICU Linux --disable-renaming --prefix=%{_prefix}
46 make
47
48 %install
49 %make_install
50
51 # bugs of rpmdeps
52 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
53
54 %remove_docs
55
56
57 %post -n lib%{name} -p /sbin/ldconfig
58
59 %postun -n lib%{name} -p /sbin/ldconfig
60
61 %files
62
63 %files -n lib%{name}
64 %{_libdir}/*.so*
65 %{_bindir}/derb
66 %{_bindir}/genbrk
67 %{_bindir}/gencfu
68 %{_bindir}/gencnval
69 %{_bindir}/genctd
70 %{_bindir}/genrb
71 %{_bindir}/makeconv
72 %{_bindir}/pkgdata
73 %{_bindir}/uconv
74 %{_bindir}/icuinfo
75 %{_bindir}/icu-config
76 %{_sbindir}/*
77 %dir /usr/share/icu/4.8.1
78 /usr/share/icu/4.8.1/config/mh-linux
79 /usr/share/icu/4.8.1/install-sh
80 /usr/share/icu/4.8.1/license.html
81 /usr/share/icu/4.8.1/mkinstalldirs
82
83 %files -n lib%{name}-devel
84 %{_includedir}/layout
85 %{_includedir}/unicode
86 %{_libdir}/*.so
87 %{_libdir}/pkgconfig/icu-*.pc
88 %{_libdir}/%{name}