Change license from BSD-2.0 to BSD-3-Clause
[platform/upstream/icu.git] / packaging / icu.spec
1 Name:      icu
2 Version:   54.1
3 Release:   1
4 Summary:   International Components for Unicode
5 Group:     System/Libraries
6 License:   ICU and Unicode-TOU and BSD-3-Clause
7 URL:       http://www.icu-project.org/
8 %define tar_version 54.1
9 Source0:   %{name}-%{tar_version}.tar.gz
10 Source1001:     icu.manifest
11 BuildRequires: doxygen
12 BuildRequires: autoconf
13
14 %description
15 Tools and utilities for developing with icu.
16
17 %package -n libicu
18 Summary: International Components for Unicode - libraries
19
20 %description -n libicu
21 The International Components for Unicode (ICU) libraries provide
22 robust and full-featured Unicode services on a wide variety of
23 platforms. ICU supports the most current version of the Unicode
24 standard, and they provide support for supplementary Unicode
25 characters (needed for GB 18030 repertoire support).
26 As computing environments become more heterogeneous, software
27 portability becomes more important. ICU lets you produce the same
28 results across all the various platforms you support, without
29 sacrificing performance. It offers great flexibility to extend and
30 customize the supplied services.
31
32 %package  -n libicu-devel
33 Summary:  Development files for International Components for Unicode
34 Requires: libicu = %{version}-%{release}
35 Requires: pkgconfig
36
37 %description -n libicu-devel
38 Includes and definitions for developing with icu.
39
40 %prep
41 %setup -q -n %{name}
42 cp %{SOURCE1001} .
43
44 %build
45 cd source
46 %configure --disable-static \
47             --disable-renaming \
48             --enable-shared \
49             --disable-samples
50 make %{?_smp_mflags}
51
52 %install
53 cd source
54 %make_install
55
56 # bugs of rpmdeps
57 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
58
59 %remove_docs
60
61
62 %post -n libicu -p /sbin/ldconfig
63
64 %postun -n libicu -p /sbin/ldconfig
65
66 %files
67 %manifest %{name}.manifest
68
69 %files -n libicu
70 %manifest %{name}.manifest
71 %{_libdir}/*.so*
72 %{_bindir}/derb
73 %{_bindir}/genbrk
74 %{_bindir}/gencfu
75 %{_bindir}/gencnval
76 %{_bindir}/gendict
77 %{_bindir}/genrb
78 %{_bindir}/makeconv
79 %{_bindir}/pkgdata
80 %{_bindir}/uconv
81 %{_bindir}/icuinfo
82 %{_bindir}/icu-config
83 %{_sbindir}/*
84 %dir %{_datadir}/icu/%{version}
85 %{_datadir}/icu/%{version}/config/mh-linux
86 %{_datadir}/icu/%{version}/install-sh
87 %{_datadir}/icu/%{version}/license.html
88 %{_datadir}/icu/%{version}/mkinstalldirs
89
90 %files -n libicu-devel
91 %manifest %{name}.manifest
92 %{_includedir}/layout
93 %{_includedir}/unicode
94 %{_libdir}/*.so
95 %{_libdir}/pkgconfig/icu-*.pc
96 %{_libdir}/%{name}