Rebase for icu 58.2
[platform/upstream/icu.git] / packaging / icu.spec
1 %define run_tests 0
2 %if %{run_tests}
3     # check is defined off at .rpmmacros file.
4     %define check %%check
5 %endif
6
7 Name:      icu
8 Version:   59.1
9 Release:   1
10 Summary:   International Components for Unicode
11 Group:     System/Libraries
12 License:   ICU and Unicode-TOU and BSD-2.0
13 URL:       http://www.icu-project.org/
14 Source0:   %{name}-%{version}.tar.gz
15 Source1001:     icu.manifest
16 BuildRequires: doxygen
17 BuildRequires: autoconf
18
19 %description
20 Tools and utilities for developing with icu.
21
22 %package -n libicu
23 Summary: International Components for Unicode - libraries
24
25 %description -n libicu
26 The International Components for Unicode (ICU) libraries provide
27 robust and full-featured Unicode services on a wide variety of
28 platforms. ICU supports the most current version of the Unicode
29 standard, and they provide support for supplementary Unicode
30 characters (needed for GB 18030 repertoire support).
31 As computing environments become more heterogeneous, software
32 portability becomes more important. ICU lets you produce the same
33 results across all the various platforms you support, without
34 sacrificing performance. It offers great flexibility to extend and
35 customize the supplied services.
36
37 %package  -n libicu-devel
38 Summary:  Development files for International Components for Unicode
39 Requires: libicu = %{version}-%{release}
40 Requires: pkgconfig
41
42 %description -n libicu-devel
43 Includes and definitions for developing with icu.
44
45 %prep
46 %setup -q -n %{name}
47 cp %{SOURCE1001} .
48
49 %build
50 export CFLAGS="$CFLAGS -D_TIZEN_FEATURE_"
51 export CXXFLAGS="$CXXFLAGS -D_TIZEN_FEATURE_"
52
53 cd source
54 %configure --enable-static=no \
55             --enable-renaming=no \
56             --enable-shared \
57             --enable-plugins \
58             --enable-samples=no
59 make %{?_smp_mflags}
60
61 %check
62 %if %{run_tests}
63     pushd source
64     %__make check || exit 0
65     popd
66 %endif
67
68 %install
69 cd source
70 %make_install
71
72 # bugs of rpmdeps
73 chmod +x %{buildroot}/%{_libdir}/lib*.so.*
74
75 %remove_docs
76
77
78 %post -n libicu -p /sbin/ldconfig
79
80 %postun -n libicu -p /sbin/ldconfig
81
82 %files
83 %manifest %{name}.manifest
84 %license LICENSE
85
86 %files -n libicu
87 %manifest %{name}.manifest
88 %license LICENSE
89 %{_libdir}/*.so*
90 %{_bindir}/derb
91 %{_bindir}/genbrk
92 %{_bindir}/gencfu
93 %{_bindir}/gencnval
94 %{_bindir}/gendict
95 %{_bindir}/genrb
96 %{_bindir}/makeconv
97 %{_bindir}/pkgdata
98 %{_bindir}/uconv
99 %{_bindir}/icuinfo
100 %{_bindir}/icu-config
101 %{_sbindir}/*
102 %dir %{_datadir}/icu/%{version}
103 %{_datadir}/icu/%{version}/config/mh-linux
104 %{_datadir}/icu/%{version}/install-sh
105 %{_datadir}/icu/%{version}/LICENSE
106 %{_datadir}/icu/%{version}/mkinstalldirs
107
108 %files -n libicu-devel
109 %manifest %{name}.manifest
110 %license LICENSE
111 %{_includedir}/unicode
112 %{_libdir}/*.so
113 %{_libdir}/pkgconfig/icu-*.pc
114 %{_libdir}/%{name}