82e67d0fe7265a46d9037a236ff00dcbe52ce5b7
[profile/ivi/ico-uxf-pulse-plugin.git] / packaging / ico-uxf-pulse-plugin.spec
1 Name:           ico-uxf-pulse-plugin
2 Version:        0.1.3
3 Release:        1
4 Summary:        ico-uxf-pulse-plugin is a pulseaudio plugin. And this is a sound resource controller.
5
6 Group:          System/GUI/Other
7 License:        Toyota Motor Corporation
8 URL:            www.toyota.com
9 Source0:        %{name}-%{version}.tar.bz2
10
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: libwebsockets-devel
13 BuildRequires: pulseaudio-module-devel >= 2.0
14 BuildRequires: libatomic_ops-devel
15 BuildRequires: libtool-ltdl-devel
16 Requires:      pulseaudio >= 2.0
17
18 %description
19 This is a pulseaudio plugin.
20 And this is a sound resource(stream of pulseaudio) controller.
21
22 %package devel
23 Summary:    Development files for %{name}
24 Group:      Development/Libraries
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 Development files that expose the libico_uxfw API.
29
30 %prep
31 %setup -q
32
33 %build
34 autoreconf --install
35 %configure --libdir /usr/lib/pulse-2.1/modules/
36 make %{?_smp_mflags}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41 %define confdir /opt/etc/ico/
42 %define testsdir /opt/etc/ico/tests/ico-uxf-pulse-plugin
43 install -m 0777 -d %{buildroot}%{confdir}
44 install -m 0777 -d %{buildroot}%{testsdir}
45 install -m 0777 src/tests/audio1.sh %{buildroot}%{testsdir}
46 install -m 0777 src/tests/audio2.sh %{buildroot}%{testsdir}
47 install -m 0777 src/tests/test_scenario.sh %{buildroot}%{testsdir}
48 install -m 0777 src/tests/tp_controller %{buildroot}%{testsdir}
49 install -m 0777 data/soundmgr.conf %{buildroot}%{confdir}
50 install -m 0777 data/tests/mediation_table.txt.for_test %{buildroot}%{testsdir}
51 install -m 0777 data/tests/mediation_table.txt.send %{buildroot}%{testsdir}
52 install -m 0777 data/tests/musicbox.wav %{buildroot}%{testsdir}
53 install -m 0777 data/tests/violin.wav %{buildroot}%{testsdir}
54
55 %post -p /sbin/ldconfig
56
57 %postun -p /sbin/ldconfig
58
59 %files
60 %defattr(-,root,root,-)
61 %{_libdir}/pulse-2.1/modules/ico_module-soundmgr.so*
62 /opt/etc/ico/soundmgr.conf
63 %defattr(777,root,root,-)
64 /opt/etc/ico
65 /opt/etc/ico/tests/ico-uxf-pulse-plugin/
66 %defattr(755,root,root,-)
67 /opt/etc/ico/tests/ico-uxf-pulse-plugin/audio1.sh
68 /opt/etc/ico/tests/ico-uxf-pulse-plugin/audio2.sh
69 /opt/etc/ico/tests/ico-uxf-pulse-plugin/test_scenario.sh
70 /opt/etc/ico/tests/ico-uxf-pulse-plugin/tp_controller
71 %defattr(777,root,root,-)
72 /opt/etc/ico/tests/ico-uxf-pulse-plugin/musicbox.wav
73 /opt/etc/ico/tests/ico-uxf-pulse-plugin/violin.wav
74 /opt/etc/ico/tests/ico-uxf-pulse-plugin/mediation_table.txt.for_test
75 /opt/etc/ico/tests/ico-uxf-pulse-plugin/mediation_table.txt.send
76
77
78 %files devel
79