Merge branch 'tizen_2.2' into tizen
[platform/core/appfw/heynoti.git] / packaging / heynoti.spec
1 Name:           heynoti
2 Version:        0.0.2
3 Release:        0
4 License:        Apache-2.0
5 Summary:        HEY (ligHt Easy speedy) notification library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     heynoti.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(libtzplatform-config)
15
16 %description
17 HEY (ligHt Easy speedy) notification library is a lightweight
18 notification library with service APIs.
19
20 %package devel
21 Summary:        Notification library
22 Group:          Development/Libraries
23 Requires:       %{name} = %{version}
24 Requires:       heynoti
25
26 %description devel
27 Development files for HEY (ligHt Easy speedy) notification library. HEY
28 is a lightweight notification library with service APIs.
29
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34
35
36 %build
37 %cmake . -DCMAKE_BUILD_TYPE="Debug"
38
39
40 make %{?_smp_mflags}
41
42 %install
43 %make_install
44
45 mkdir -p %{buildroot}%{TZ_SYS_SHARE}/noti
46 mkdir -p %{buildroot}/usr/share/license
47 install LICENSE %{buildroot}/usr/share/license/%{name}
48
49 %post -p /sbin/ldconfig
50
51 %postun -p /sbin/ldconfig
52
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-,root,root,-)
57 %{_libdir}/libheynoti.so.0
58 %{_libdir}/libheynoti.so.0.0.2
59 %{_bindir}/heynotitool
60 %attr(1755,root,root) %{TZ_SYS_SHARE}/noti
61 /usr/share/license/%{name}
62
63
64 %files devel
65 %manifest %{name}.manifest
66 %defattr(-,root,root,-)
67 %{_includedir}/heynoti/SLP_Heynoti_PG.h
68 %{_includedir}/heynoti/heynoti.h
69 %{_libdir}/pkgconfig/heynoti.pc
70 %{_libdir}/libheynoti.so
71