Add multi-user support
[platform/core/appfw/heynoti.git] / packaging / heynoti.spec
1 Name:           heynoti
2 Version:        0.0.2
3 Release:        0
4 License:        Apache-2.0
5 Summary:        HEY (ligHt Easy speedy) notification library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     heynoti.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(libtzplatform-config)
15
16 %description
17 HEY (ligHt Easy speedy) notification library is a lightweight
18 notification library with service APIs.
19
20 %package devel
21 Summary:        Notification library
22 Group:          Development/Libraries
23 Requires:       %{name} = %{version}
24 Requires:       heynoti
25
26 %description devel
27 Development files for HEY (ligHt Easy speedy) notification library. HEY
28 is a lightweight notification library with service APIs.
29
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34
35
36 %build
37 %cmake . -DCMAKE_BUILD_TYPE="Debug"
38
39
40 make %{?_smp_mflags}
41
42 %install
43 %make_install
44
45 mkdir -p %{buildroot}%{TZ_SYS_SHARE}/noti
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root,-)
55 %{_libdir}/libheynoti.so.0
56 %{_libdir}/libheynoti.so.0.0.2
57 %{_bindir}/heynotitool
58 %attr(1755,root,root) %{TZ_SYS_SHARE}/noti
59
60
61 %files devel
62 %manifest %{name}.manifest
63 %defattr(-,root,root,-)
64 %{_includedir}/heynoti/SLP_Heynoti_PG.h
65 %{_includedir}/heynoti/heynoti.h
66 %{_libdir}/pkgconfig/heynoti.pc
67 %{_libdir}/libheynoti.so
68