install license file
[platform/core/appfw/heynoti.git] / packaging / heynoti.spec
1 #
2
3 Name:           heynoti
4 Version:        0.0.2
5 Release:        41
6 License:        Apache License, Version 2.0
7 Summary:        HEY (ligHt Easy speedy) notification library
8 Group:          System/Libraries
9 Source0:        %{name}-%{version}.tar.gz
10
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(ecore)
14 BuildRequires:  pkgconfig(glib-2.0)
15
16 %description
17 lightweight notification library, service APIs
18
19 %package devel
20 Summary:        Notification library
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}
23 Requires:       heynoti
24
25 %description devel
26 heynoti API (devel)
27
28 %prep
29 %setup -q
30
31
32 %build
33 %cmake . -DCMAKE_BUILD_TYPE="Debug"
34
35
36 make %{?_smp_mflags}
37
38 %install
39 %make_install
40 mkdir -p %{buildroot}/usr/share/license
41 install LICENSE %{buildroot}/usr/share/license/%{name}
42 mkdir -p %{buildroot}/opt/share/noti
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48
49 %files
50 %manifest heynoti.manifest
51 %defattr(-,root,root,-)
52 %{_libdir}/libheynoti.so.0
53 %{_libdir}/libheynoti.so.0.0.2
54 %{_bindir}/heynotitool
55 %attr(1755,root,root) /opt/share/noti
56 /usr/share/license/%{name}
57
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/heynoti/SLP_Heynoti_PG.h
62 %{_includedir}/heynoti/heynoti.h
63 %{_libdir}/pkgconfig/heynoti.pc
64 %{_libdir}/libheynoti.so
65