6e208a7bfbce88968855c6e90c1931a89fdd599d
[framework/appfw/heynoti.git] / packaging / heynoti.spec
1
2 Name:       heynoti
3 Summary:    HEY (ligHt Easy speedy) notification library
4 Version:    0.0.2
5 Release:    39
6 Group:      System/Libraries
7 License:    Apache License, Version 2.0
8 Source0:    %{name}-%{version}.tar.gz
9
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12
13 BuildRequires:  cmake
14
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(ecore)
18
19
20 %description
21 lightweight notification library, service APIs
22
23
24 %package devel
25 Summary:    Notification library
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28 Requires:   heynoti
29
30 %description devel
31 heynoti API (devel)
32
33
34 %prep
35 %setup -q
36
37
38 %build
39 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_BUILD_TYPE="Debug"
40
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47
48
49 %post
50 /sbin/ldconfig
51 mkdir -p /opt/share/noti
52 chmod 1755 /opt/share/noti
53
54 %postun -p /sbin/ldconfig
55
56
57 %files
58 %manifest heynoti.manifest
59 %defattr(-,root,root,-)
60 %{_libdir}/libheynoti.so.0
61 %{_libdir}/libheynoti.so.0.0.2
62 %{_bindir}/heynotitool
63
64
65 %files devel
66 %defattr(-,root,root,-)
67 %{_includedir}/heynoti/SLP_Heynoti_PG.h
68 %{_includedir}/heynoti/heynoti.h
69 %{_libdir}/pkgconfig/heynoti.pc
70 %{_libdir}/libheynoti.so
71