Install libs in %_libdir and cleanup spec
[framework/appfw/heynoti.git] / packaging / heynoti.spec
1 #
2
3 Name:           heynoti
4 Version:        0.0.2
5 Release:        39
6 License:        Apache License, Version 2.0
7 Summary:        HEY (ligHt Easy speedy) notification library
8 Group:          System/Libraries
9 Source0:        %{name}-%{version}.tar.gz
10
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(ecore)
14 BuildRequires:  pkgconfig(glib-2.0)
15
16 %description
17 lightweight notification library, service APIs
18
19 %package devel
20 Summary:        Notification library
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}
23 Requires:       heynoti
24
25 %description devel
26 heynoti API (devel)
27
28 %prep
29 %setup -q
30
31
32 %build
33 %cmake . -DCMAKE_BUILD_TYPE="Debug"
34
35
36 make %{?_smp_mflags}
37
38 %install
39 %make_install
40
41 mkdir -p %{buildroot}/opt/share/noti
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %manifest heynoti.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/libheynoti.so.0
52 %{_libdir}/libheynoti.so.0.0.2
53 %{_bindir}/heynotitool
54 %attr(1755,root,root) /opt/share/noti
55
56
57 %files devel
58 %defattr(-,root,root,-)
59 %{_includedir}/heynoti/SLP_Heynoti_PG.h
60 %{_includedir}/heynoti/heynoti.h
61 %{_libdir}/pkgconfig/heynoti.pc
62 %{_libdir}/libheynoti.so
63