Fixed continuous vibration along with system hang.
[platform/core/system/haptic-module-tizen.git] / packaging / haptic-module-tizen.spec
1 #sbs-git:slp/pkgs/d/devman devman 0.1.6 5bf2e95e0bb15c43ff928f7375e1978b0accb0f8
2 Name:       haptic-module-tizen
3 Summary:    Haptic Module library
4 Version:    0.1.0
5 Release:    9
6 Group:      System/Libraries
7 License:    APLv2
8 Source0:    %{name}-%{version}.tar.gz
9 Source1001:     haptic-module-tizen.manifest
10 BuildRequires: cmake
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(vconf)
13 BuildRequires: pkgconfig(haptic-plugin)
14 BuildRequires: pkgconfig(device-node)
15
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19 %description
20
21 %prep
22 %setup -q
23 cp %{SOURCE1001} .
24
25 %build
26 %if 0%{?simulator}
27 %cmake . -DSIMULATOR=yes
28 %else
29 %ifarch %{ix86}
30 CFLAGS=`echo %{optflags} |sed 's/\-fexceptions//g'`
31 %endif
32 %cmake . -DSIMULATOR=no
33 %endif
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %manifest %{name}.manifest
46 %{_libdir}/libhaptic-module.so