memory: change return value when node is not supported
[platform/hal/backend/tw3/device-tw3.git] / packaging / hal-backend-device-tw3.spec
1 Name:       hal-backend-device-tw3
2 Summary:    Device HAL backend drivers for TW3
3 Version:    0.0.1
4 Release:    0
5 Group:      System/Hardware Adaptation
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:    cmake
10 BuildRequires:    pkgconfig(glib-2.0)
11 BuildRequires:    pkgconfig(libusbgx)
12 BuildRequires:    pkgconfig(capi-system-info)
13 BuildRequires:    pkgconfig(hal-api-common)
14 BuildRequires:    pkgconfig(hal-api-device)
15 BuildRequires:    pkgconfig(libsyscommon)
16 BuildRequires:    pkgconfig(hal-backend-device-common)
17 Requires(post):   /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 %description
21 Device HAL backend drivers for TW3
22
23 %prep
24 %setup -q
25 cp %{SOURCE1} .
26
27 %build
28 %cmake . -DENABLE_DLOG=on \
29         -DHAL_LIB_DIR=%{_hal_libdir} \
30         -DHAL_LICENSE_DIR=%{_hal_licensedir}
31
32 make %{?jobs:-j%jobs}
33
34 %install
35 %make_install
36
37 %post
38 /sbin/ldconfig
39
40 %postun
41 /sbin/ldconfig
42
43 %files
44 %manifest %{name}.manifest
45 %{_hal_licensedir}/%{name}/LICENSE.Apache-2.0
46 %{_hal_libdir}/*.so*