tizen 2.3.1 release
[external/gupnp.git] / packaging / gupnp.spec
1 Name: gupnp
2 Version: 0.14.1_6
3 Release: 1
4 Summary: GUPNP
5 Group: <group>/<group>
6 License: LGPL-2.0+
7 URL: http://www.gupnp.org/
8 Source0: %{name}-%{version}.tar.gz
9 Patch1: missed_service_node_bug.patch
10 BuildRequires:  pkgconfig(glib-2.0) >= 2.18
11 BuildRequires:  pkgconfig(gobject-2.0) >= 2.18
12 BuildRequires:  pkgconfig(gmodule-2.0)
13 BuildRequires:  pkgconfig(gssdp-1.0) >= 0.7.1
14 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.4.1
15 BuildRequires:  pkgconfig(libxml-2.0)
16 # need dbus-glib-1 for use network-manager
17 BuildRequires:  pkgconfig(dbus-glib-1) >= 0.76
18 BuildRequires:  pkgconfig(uuid)
19 BuildRequires:  pkgconfig(gthread-2.0)
20 BuildRequires:  autoconf >= 2.67
21 Requires: ldconfig
22 %description
23 GUPnP is an object-oriented open source framework for creating UPnP devices and
24 control points, written in C using GObject and libsoup. The GUPnP API is
25 intended to be easy to use, efficient and flexible.
26
27 %package devel
28 Summary:    GUPNP (devel)
29 Group:      Development/Headers
30 License:    LGPL-2.0+
31 Requires:   %{name} = %{version}-%{release}
32
33 %description devel
34 GUPnP is an object-oriented open source framework for creating UPnP devices and
35 control points, written in C using GObject and libsoup. The GUPnP API is
36 intended to be easy to use, efficient and flexible.
37
38 %prep  
39 %setup -q  
40 %patch1 -p1
41   
42 %build  
43 %configure --prefix=/usr --with-context-manager=network-manager
44   
45 make %{?jobs:-j%jobs}  
46   
47 %install  
48 rm -rf %{buildroot}  
49 %make_install
50 rm -rf %{buildroot}/usr/share/
51 mkdir -p %{buildroot}/usr/share/license
52 cp COPYING %{buildroot}/usr/share/license/%{name}
53
54 %clean
55 rm -rf %{buildroot}
56
57 %post
58
59 %postun
60
61 %files
62 %defattr(-,root,root,-)
63 %doc
64 /usr/lib/*.so.*
65 /usr/share/license/%{name}
66
67 %files devel
68 %defattr(-,root,root,-)
69 /usr/bin/gupnp-binding-tool
70 /usr/include/gupnp-1.0/*
71 #/usr/lib/*.a
72 /usr/lib/*.so
73 /usr/lib/pkgconfig/*
74