7a560731f3b02f058180a9f88cad455203aa9e1c
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
1 %define gst_branch 1.0
2
3 Name:           gstreamer
4 Version:        1.12.2
5 Release:        0
6 Summary:        Streaming-Media Framework Runtime
7 License:        LGPL-2.0+
8 Group:          Multimedia/Framework
9 Url:            http://gstreamer.freedesktop.org/
10 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
11 Source100:      common.tar.gz
12 BuildRequires:  bison
13 BuildRequires:  gettext-tools
14 BuildRequires:  check-devel
15 BuildRequires:  fdupes
16 BuildRequires:  flex
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.32.0
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig(libxml-2.0)
20 BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 1.31.1
21 BuildRequires:  pkgconfig(dlog)
22
23 %description
24 GStreamer is a streaming-media framework, based on graphs of filters
25 which operate on media data. Applications using this library can do
26 anything from real-time sound processing to playing videos, and just
27 about anything else media-related.  Its plug-in-based architecture
28 means that new data types or processing capabilities can be added by
29 installing new plug-ins.
30
31 %package utils
32 Summary:        Streaming-Media Framework Runtime
33 Group:          Multimedia/Framework
34 Provides:       gstreamer:%{_bindir}/gst-launch-%{gst_branch} = %{version}
35 # Symbol for unversioned wrappers:
36 Provides:       gstreamer-utils_versioned = %{version}
37
38 %description utils
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related.  Its plug-in-based architecture
43 means that new data types or processing capabilities can be added by
44 installing new plug-ins.
45
46 %package devel
47 Summary:        Include Files and Libraries mandatory for Development
48 Group:          Development/Libraries
49 # gstreamer-utils is required for the gstreamer-provides rpm magic.
50 Requires:       gstreamer-utils = %{version}
51 Requires:       %{name} = %{version}
52
53 %description devel
54 This package contains all necessary include files and libraries needed
55 to develop applications that require these.
56
57 %lang_package
58
59 %prep
60 %setup -q -n gstreamer-%{version}
61 %setup -q -T -D -a 100
62
63 %build
64 # FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
65 # Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
66 export V=1
67 NOCONFIGURE=1 ./autogen.sh
68 export CFLAGS="%{optflags} \
69         -DTIZEN_FEATURE_QUEUE2_MODIFICATION\
70         -DTIZEN_FEATURE_FILESINK_MODIFICATION\
71         -DTIZEN_FEATURE_MQ_MODIFICATION\
72         -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
73         -DTIZEN_FEATURE_QUEUE_MODIFICATION\
74 %if "%{TIZEN_PRODUCT_TV}" == "1"
75         -DTIZEN_PROFILE_TV\
76         -DRVU_LIVESTREAMING_OPTIMIZATION\
77         -DTIZEN_FEATURE_TRUSTZONE\
78 %endif
79         -DTIZEN_FEATURE_RTSPSRC_MODIFICATION\
80         -fno-strict-aliasing"
81
82 %configure\
83 %if %{with introspection}
84         --enable-introspection\
85 %endif
86         --disable-static\
87         --disable-docbook\
88         --disable-gtk-doc\
89         --enable-dlog\
90 %if "%{TIZEN_PRODUCT_TV}" == "1"
91         --enable-tv-profile\
92 %endif
93         --disable-examples\
94         --disable-tests
95 make %{?_smp_mflags}
96
97 %install
98 %make_install
99 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
100 mkdir -p %{buildroot}%{_docdir}/%{name}
101 %find_lang %{name}-%{gst_branch}
102 mv %{name}-%{gst_branch}.lang %{name}.lang
103 rm -rf %{buildroot}%{_datadir}/gtk-doc
104 rm -rf %{buildroot}%{_docdir}/%{name}/manual
105 rm -rf %{buildroot}%{_docdir}/%{name}/pwg
106 rm -rf %{buildroot}%{_libdir}/girepository-%{gst_branch}/*.typelib
107 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
108 %fdupes %{buildroot}
109
110 %post -p /sbin/ldconfig
111
112 %postun -p /sbin/ldconfig
113
114 %files
115 %manifest %{name}.manifest
116 %defattr(-, root, root)
117 %license COPYING
118
119 %dir %{_datadir}/gstreamer-%{gst_branch}
120 %dir %{_datadir}/gstreamer-%{gst_branch}/presets
121 %dir %{_libdir}/gstreamer-%{gst_branch}
122 %{_libdir}/gstreamer-%{gst_branch}/*.so
123 %dir %{_libexecdir}/gstreamer-%{gst_branch}
124 #%{_libdir}/include/gstreamer-%{gst_branch}/gst/gstconfig.h
125 %{_libexecdir}/gstreamer-%{gst_branch}/gst-plugin-scanner
126 %{_libexecdir}/gstreamer-%{gst_branch}/gst-ptp-helper
127 %{_libdir}/*.so.*
128 #%{_libdir}/girepository-1.0/Gst-1.0.typelib
129 #%{_libdir}/girepository-1.0/GstBase-1.0.typelib
130 #%{_libdir}/girepository-1.0/GstCheck-1.0.typelib
131 #%{_libdir}/girepository-1.0/GstController-1.0.typelib
132 #%{_libdir}/girepository-1.0/GstNet-1.0.typelib
133
134 %files utils
135 %manifest %{name}.manifest
136 %defattr(-, root, root)
137 %license COPYING
138 %{_bindir}/*-%{gst_branch}
139 %doc %{_mandir}/man?/*-%{gst_branch}.*
140
141 %files devel
142 %manifest %{name}.manifest
143 %defattr(-, root, root)
144 %{_datadir}/aclocal/*.m4
145 %{_includedir}/*
146 %{_libdir}/*.so
147 %{_libdir}/pkgconfig/*.pc
148 %{_datadir}/gir-1.0/*.gir
149
150 %changelog