disable jpeg/mpeg4 decoder in spec file
[profile/ivi/gstreamer-vaapi.git] / packaging / gstreamer-vaapi.spec
1 Name:       gstreamer-vaapi
2 Version:    0.4.0.02.f9604f48
3 Release:    0
4 Summary:    VA-API based plugins for GStreamer and helper libraries
5 Group:      Multimedia/Gstreamer
6 License:    LGPLv2+ and GPLv2+
7 URL:        http://gitorious.org/vaapi/gstreamer-vaapi
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1001: packaging/gstreamer-vaapi.manifest
10 BuildRequires:  pkgconfig(x11)
11 BuildRequires:  pkgconfig(libva)
12 BuildRequires:  pkgconfig(gstreamer-0.10)
13 BuildRequires:  pkgconfig(gstreamer-basevideo-0.10)
14 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
15 ## BuildRequires:  pvr-bin-mdfld-devel
16 BuildRequires:  libdrm
17 BuildRequires:  which
18
19 %description
20 Gstreamer-vaapi is a collection of VA-API based plugins for GStreamer
21 and helper libraries. vaapidecode is used to decode MPEG-2, MPEG-4,
22 H.264, VC-1, WMV3 videos to video/x-vaapi-surface surfaces, depending
23 on the underlying HW capabilities. vaapiconvert is used to convert from
24 video/x-raw-yuv pixels to video/x-vaapi-surface surfaces. vaapisink is
25 used to display video/x-vaapi-surface surfaces to the screen.
26
27 %package devel
28 Summary:    Development files for %{name}
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31 Requires:   pkgconfig
32
33 %description devel
34 The %{name}-devel package contains libraries and header files for
35 developing applications that use %{name}.
36
37 %prep
38 %setup -q -n %{name}-%{version}
39
40 %build
41 cp %{SOURCE1001} .
42
43 %autogen --disable-jpeg --disable-mpeg4
44 make %{?_smp_mflags}
45
46 %install
47 rm -rf %{buildroot}
48 make install DESTDIR=%{buildroot}
49 find %{buildroot} -regex ".*\.la$" | xargs rm -f --
50 find %{buildroot} -regex ".*\.a$" | xargs rm -f --
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56 %files
57 %manifest gstreamer-vaapi.manifest
58 %defattr(-,root,root,-)
59 %doc AUTHORS COPYING.LIB NEWS README
60 %{_libdir}/*.so.*
61 %{_libdir}/gstreamer-0.10/*.so
62
63 %files devel
64 %manifest gstreamer-vaapi.manifest
65 %defattr(-,root,root,-)
66 %doc README COPYING.LIB
67 %{_includedir}/gstreamer-0.10/gst/vaapi
68 %{_libdir}/*.so
69 %{_libdir}/pkgconfig/%{name}*.pc