Enable encoders
[profile/ivi/gstreamer-vaapi.git] / packaging / gstreamer-vaapi.spec
1 Name:       gstreamer-vaapi
2 Version:    0.4.0.03.48c3e0f
3 Release:    0
4 Summary:    VA-API based plugins for GStreamer and helper libraries
5 Group:      Multimedia/Gstreamer
6 License:    LGPLv2+ and GPLv2+
7 URL:        http://gitorious.org/vaapi/gstreamer-vaapi
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1001: packaging/gstreamer-vaapi.manifest
10 BuildRequires:  pkgconfig(libva)
11 BuildRequires:  pkgconfig(gstreamer-0.10)
12 BuildRequires:  pkgconfig(gstreamer-basevideo-0.10)
13 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
14 BuildRequires:  pkgconfig(libva-wayland)
15 BuildRequires:  pkgconfig(wayland-client)
16 ## BuildRequires:  pvr-bin-mdfld-devel
17 BuildRequires:  libdrm
18 BuildRequires:  which
19
20 %description
21 Gstreamer-vaapi is a collection of VA-API based plugins for GStreamer
22 and helper libraries. vaapidecode is used to decode MPEG-2, MPEG-4,
23 H.264, VC-1, WMV3 videos to video/x-vaapi-surface surfaces, depending
24 on the underlying HW capabilities. vaapiconvert is used to convert from
25 video/x-raw-yuv pixels to video/x-vaapi-surface surfaces. vaapisink is
26 used to display video/x-vaapi-surface surfaces to the screen.
27
28 %package devel
29 Summary:    Development files for %{name}
30 Group:      Development/Libraries
31 Requires:   %{name} = %{version}-%{release}
32 Requires:   pkgconfig
33
34 %description devel
35 The %{name}-devel package contains libraries and header files for
36 developing applications that use %{name}.
37
38 %prep
39 %setup -q -n %{name}-%{version}
40
41 %build
42 cp %{SOURCE1001} .
43
44 %autogen --disable-jpeg --disable-mpeg4 --enable-encoders
45 make %{?_smp_mflags}
46
47 %install
48 rm -rf %{buildroot}
49 make install DESTDIR=%{buildroot}
50 find %{buildroot} -regex ".*\.la$" | xargs rm -f --
51 find %{buildroot} -regex ".*\.a$" | xargs rm -f --
52
53 %post -p /sbin/ldconfig
54
55 %postun -p /sbin/ldconfig
56
57 %files
58 %manifest gstreamer-vaapi.manifest
59 %defattr(-,root,root,-)
60 %doc AUTHORS COPYING.LIB NEWS README
61 %{_libdir}/*.so.*
62 %{_libdir}/gstreamer-0.10/*.so
63
64 %files devel
65 %manifest gstreamer-vaapi.manifest
66 %defattr(-,root,root,-)
67 %doc README COPYING.LIB
68 %{_includedir}/gstreamer-0.10/gst/vaapi
69 %{_libdir}/*.so
70 %{_libdir}/pkgconfig/%{name}*.pc