update spec for wayland
[profile/ivi/gstreamer-vaapi.git] / packaging / gstreamer-vaapi.spec
1 Name:       gstreamer-vaapi
2 Version:    0.4.0.01.a10ee52
3 Release:    0
4 Summary:    VA-API based plugins for GStreamer and helper libraries
5 Group:      Multimedia/Gstreamer
6 License:    LGPLv2+ and GPLv2+
7 URL:        http://gitorious.org/vaapi/gstreamer-vaapi
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1001: packaging/gstreamer-vaapi.manifest
10 BuildRequires:  pkgconfig(x11)
11 BuildRequires:  pkgconfig(libva)
12 BuildRequires:  pkgconfig(gstreamer-0.10)
13 BuildRequires:  pkgconfig(gstreamer-basevideo-0.10)
14 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
15 BuildRequires:  pkgconfig(libva-wayland)
16 BuildRequires:  pkgconfig(wayland-client)
17 ## BuildRequires:  pvr-bin-mdfld-devel
18 BuildRequires:  libdrm
19 BuildRequires:  which
20
21 %description
22 Gstreamer-vaapi is a collection of VA-API based plugins for GStreamer
23 and helper libraries. vaapidecode is used to decode MPEG-2, MPEG-4,
24 H.264, VC-1, WMV3 videos to video/x-vaapi-surface surfaces, depending
25 on the underlying HW capabilities. vaapiconvert is used to convert from
26 video/x-raw-yuv pixels to video/x-vaapi-surface surfaces. vaapisink is
27 used to display video/x-vaapi-surface surfaces to the screen.
28
29 %package devel
30 Summary:    Development files for %{name}
31 Group:      Development/Libraries
32 Requires:   %{name} = %{version}-%{release}
33 Requires:   pkgconfig
34
35 %description devel
36 The %{name}-devel package contains libraries and header files for
37 developing applications that use %{name}.
38
39 %prep
40 %setup -q -n %{name}-%{version}
41
42 %build
43 cp %{SOURCE1001} .
44
45 %autogen
46 make %{?_smp_mflags}
47
48 %install
49 rm -rf %{buildroot}
50 make install DESTDIR=%{buildroot}
51 find %{buildroot} -regex ".*\.la$" | xargs rm -f --
52 find %{buildroot} -regex ".*\.a$" | xargs rm -f --
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58 %files
59 %manifest gstreamer-vaapi.manifest
60 %defattr(-,root,root,-)
61 %doc AUTHORS COPYING.LIB NEWS README
62 %{_libdir}/*.so.*
63 %{_libdir}/gstreamer-0.10/*.so
64
65 %files devel
66 %manifest gstreamer-vaapi.manifest
67 %defattr(-,root,root,-)
68 %doc README COPYING.LIB
69 %{_includedir}/gstreamer-0.10/gst/vaapi
70 %{_libdir}/*.so
71 %{_libdir}/pkgconfig/%{name}*.pc