b0e3187e29b735352a2d74723b359b8c6764c15c
[platform/upstream/gst-rtsp-server.git] / packaging / gst-rtsp-server.spec
1 Name:       gst-rtsp-server
2 Summary:    Multimedia Framework Library
3 Version:    1.6.1
4 Release:    1
5 Url:        http://gstreamer.freedesktop.org/
6 Group:      System/Libraries
7 License:    LGPL-2.0+
8 Source:     http://gstreamer.freedesktop.org/src/gst-rtsp-server/gst-rtsp-server-%{version}.tar.xz
9 Source100:  common.tar.bz2
10 Requires(post):  /sbin/ldconfig
11 Requires(postun):  /sbin/ldconfig
12 BuildRequires:  pkgconfig(gstreamer-1.0)
13 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
14
15 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
16
17 %description
18
19 %package devel
20 Summary:    Multimedia Framework RTSP server library (DEV)
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25
26 %package factory
27 Summary:    Multimedia Framework RTSP server Library (Factory)
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description factory
32
33 %prep
34 %setup -q -n gst-rtsp-server-%{version}
35 %setup -q -T -D -a 100 
36
37 %build
38
39 NOCONFIGURE=1 ./autogen.sh
40
41 CFLAGS+=" -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" "; export CFLAGS
42 LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"; export LDFLAGS
43
44 # always enable sdk build. This option should go away
45 %configure --disable-static
46
47 # Call make instruction with smp support
48 make %{?jobs:-j%jobs}
49
50 %install
51 rm -rf %{buildroot}
52 %make_install
53 mkdir -p %{buildroot}/%{_datadir}/license
54 cp -rf %{_builddir}/%{name}-%{version}/COPYING %{buildroot}%{_datadir}/license/%{name}
55
56 %clean
57 rm -rf %{buildroot}
58
59 %post
60 /sbin/ldconfig
61
62 %postun
63 /sbin/ldconfig
64
65 %files
66 %manifest gst-rtsp-server.manifest
67 %defattr(-,root,root,-)
68 %{_datadir}/license/%{name}
69 %{_libdir}/*.so.*
70
71 %files devel
72 %defattr(-,root,root,-)
73 %{_libdir}/*.so
74 %{_includedir}/gstreamer-1.0/gst/rtsp-server/rtsp-*.h
75 %{_includedir}/gstreamer-1.0/gst/rtsp-server/gstwfd*.h
76 %{_libdir}/pkgconfig/*