Change audiodec rank to MARGINAL for using avdec
[platform/adaptation/emulator/gst-plugins-emulator.git] / packaging / gst-plugins-emulator.spec
1
2 %bcond_with emulator
3
4 Name: gst-plugins-emulator
5 Version: 1.2.8
6 Release: 0
7 Summary: GStreamer Decoder and Encoder Plugins for Emulator
8 Group: Multimedia/Libraries
9 License: LGPL-2.0+
10 Source0: %{name}-%{version}.tar.gz
11 Source1001: packaging/%{name}.manifest
12 BuildRequires:  pkgconfig(gstreamer-1.0)
13 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
14 BuildRequires:  pkgconfig(glib-2.0)
15
16 %if %{with emulator}
17 ExclusiveArch: %{ix86} x86_64
18 %else
19 ExclusiveArch:
20 %endif
21
22 %description
23 It includes video/audio decoders and encoders for Emulator
24 Its codec set is determined after communicating with emulator
25
26 %prep
27
28 %setup -q
29
30 %build
31 cp %{SOURCE1001} .
32 ./autogen.sh
33 # Add gcc version check as address-of-packed-member warnings are not introduced by GCC-6
34 %define gccversion %(gcc -dumpversion | cut -f1 -d.)
35
36 %if %{gccversion} >= 9
37 CFLAGS+=" -Wno-error=address-of-packed-member"
38 %configure CFLAGS="$CFLAGS" --disable-static \
39  --disable-nls \
40  --prefix=%{_prefix} \
41
42 %else
43 %configure --disable-static \
44  --disable-nls \
45  --prefix=%{_prefix} \
46
47 %endif
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53
54 %make_install
55
56 %clean
57 rm -rf %{buildroot}
58
59 %post -p /sbin/ldconfig
60
61 %postun -p /sbin/ldconfig
62
63 %files
64 %manifest gst-plugins-emulator.manifest
65 %defattr(-,root,root,-)
66 %{_libdir}/gstreamer-1.0/libgstemul.so
67 %license LICENSE.LGPLv2+