ec73ee6b2ab6b37a7acdafe58a3ec02a274d02ef
[framework/multimedia/gst-plugins-base0.10.git] / packaging / gst-plugins-base.spec
1 Name:       gst-plugins-base
2 Summary:    GStreamer streaming media framework base plug-ins
3 Version:    0.10.36
4 Release:    104
5 VCS:        framework/multimedia/gst-plugins-base0.10#gst-plugins-base0.10_0.10.36-70-79-gd8f05149610f32f1a932c39c1dadefc44ce42752
6 Group:      Applications/Multimedia
7 License:    LGPLv2+
8 Source0:    %{name}-%{version}.tar.gz
9 #Patch0:     Samsung-feature-bugs.patch
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(ogg)
13 BuildRequires:  pkgconfig(theora)
14 BuildRequires:  pkgconfig(vorbis)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(alsa)
18 BuildRequires:  pkgconfig(gstreamer-0.10)
19 BuildRequires:  pkgconfig(gstreamer-base-0.10)
20 BuildRequires:  pkgconfig(xv)
21 BuildRequires:  pkgconfig(pango)
22 BuildRequires:  pkgconfig(xfixes)
23 BuildRequires:  pkgconfig(dri2proto)
24 BuildRequires:  pkgconfig(libdri2)
25 BuildRequires:  pkgconfig(libtbm)
26 BuildRequires:  pkgconfig(mm-ta)
27 BuildRequires:  intltool
28
29
30 %description
31 A well-groomed and well-maintained collection of GStreamer plug-ins and elements, 
32 spanning the range of possible types of elements one would want to write for GStreamer.
33
34
35
36 %package devel
37 Summary:    Development tools for GStreamer base plugins
38 Group:      Development/Libraries
39 Requires:   %{name} = %{version}-%{release}
40
41 %description devel
42 Separate sub-package for development based on gstreamer base plugins. 
43
44
45 %package tools
46 Summary:    Gstreamer base plugins utilities
47 Group:      Development/Tools
48 Requires:   %{name} = %{version}-%{release}
49
50 %description tools
51 Separate sub-package contaning helper applications of gstreamer base plugins.
52
53
54
55 %prep
56 %setup -q 
57
58 #%patch0 -p1
59
60 %build
61 %if 0%{?tizen_profile_mobile}
62 cd mobile
63 %else
64 cd wearable
65 %endif
66
67 %autogen --noconfigure
68
69 %if 0%{?tizen_profile_mobile}
70 export CFLAGS+=" -Wall -g -fPIC\
71  -DGST_EXT_XV_ENHANCEMENT\
72  -DGST_EXT_LINK_FIMCCONVERT\
73  -DGST_EXT_TYPEFIND_ENHANCEMENT\
74  -DGST_EXT_MIME_TYPES"
75 %else
76 #Add -DSAMSUNG_WFD_SPEC to enable RTP over TCP streaming support
77 export CFLAGS+=" -Wall -g -fPIC\
78  -DGST_EXT_XV_ENHANCEMENT\
79  -DSAMSUNG_WFD_SPEC\
80  -DGST_EXT_LINK_FIMCCONVERT\
81  -DGST_EXT_MIME_TYPES\
82  -DGST_EXT_ENABLE_SMI\
83  -DGST_EXT_TYPEFIND_ENHANCEMENT\
84  -DGST_EXT_TIME_ANALYSIS\
85  -D_GST_LITEW_OPT_ \
86  -DGST_EXT_DECODEBIN2_QUEUESIZE"
87 %endif
88
89 %configure --prefix=/usr\
90  --disable-static\
91  --disable-nls\
92  --with-html-dir=/tmp/dump\
93  --disable-examples\
94  --disable-audiorate\
95  --disable-gdp\
96  --disable-cdparanoia\
97  --disable-gnome_vfs\
98  --disable-libvisual\
99  --disable-freetypetest\
100  --disable-rpath\
101  --disable-valgrind\
102  --disable-gcov\
103  --disable-gtk-doc\
104  --disable-debug\
105  --with-audioresample-format=int
106
107 make %{?jobs:-j%jobs}
108
109 %install
110 rm -rf %{buildroot}
111
112 %if 0%{?tizen_profile_mobile}
113 cd mobile
114 %else
115 cd wearable
116 %endif
117
118 mkdir -p %{buildroot}/usr/share/license
119 cp COPYING.LIB %{buildroot}/usr/share/license/%{name}
120 cp COPYING.LIB %{buildroot}/usr/share/license/%{name}-devel
121 cp COPYING.LIB %{buildroot}/usr/share/license/%{name}-tools
122 %make_install
123
124
125 rm -rf %{buildroot}/tmp/dump
126
127 %post
128 /sbin/ldconfig
129
130 %postun
131 /sbin/ldconfig
132
133
134 %files
135 %if 0%{?tizen_profile_mobile}
136 %manifest mobile/gst-plugins-base.manifest
137 %else
138 %manifest wearable/gst-plugins-base.manifest
139 %endif
140 %defattr(-,root,root,-)
141 #%doc COPYING 
142 # libraries
143 %{_libdir}/libgstinterfaces-0.10.so.*
144 %{_libdir}/libgstaudio-0.10.so.*
145 %exclude %{_libdir}/libgstcdda-0.10.so.*
146 %{_libdir}/libgstfft-0.10.so.*
147 %{_libdir}/libgstriff-0.10.so.*
148 %{_libdir}/libgsttag-0.10.so.*
149 %{_libdir}/libgstnetbuffer-0.10.so.*
150 %{_libdir}/libgstrtp-0.10.so.*
151 %{_libdir}/libgstvideo-0.10.so.*
152 %{_libdir}/libgstpbutils-0.10.so.*
153 %{_libdir}/libgstrtsp-0.10.so.*
154 %{_libdir}/libgstsdp-0.10.so.*
155 %{_libdir}/libgstapp-0.10.so.*
156 # base plugins without external dependencies
157 %{_libdir}/gstreamer-0.10/libgstadder.so
158 %{_libdir}/gstreamer-0.10/libgstaudioconvert.so
159 %{_libdir}/gstreamer-0.10/libgstaudiotestsrc.so
160 %{_libdir}/gstreamer-0.10/libgstffmpegcolorspace.so
161 %{_libdir}/gstreamer-0.10/libgstdecodebin.so
162 %{_libdir}/gstreamer-0.10/libgstdecodebin2.so
163 %{_libdir}/gstreamer-0.10/libgstplaybin.so
164 %{_libdir}/gstreamer-0.10/libgsttypefindfunctions.so
165 %{_libdir}/gstreamer-0.10/libgstvideotestsrc.so
166 %{_libdir}/gstreamer-0.10/libgstsubparse.so
167 %{_libdir}/gstreamer-0.10/libgstvolume.so
168 %{_libdir}/gstreamer-0.10/libgstvideorate.so
169 %{_libdir}/gstreamer-0.10/libgstvideoscale.so
170 %{_libdir}/gstreamer-0.10/libgsttcp.so
171 %{_libdir}/gstreamer-0.10/libgstaudioresample.so
172 %{_libdir}/gstreamer-0.10/libgstapp.so
173 %{_libdir}/gstreamer-0.10/libgstxvimagesink.so
174 %exclude %{_libdir}/gstreamer-0.10/libgstencodebin.so
175 # base plugins with dependencies
176 %{_libdir}/gstreamer-0.10/libgstalsa.so
177 %{_libdir}/gstreamer-0.10/libgstogg.so
178 %{_libdir}/gstreamer-0.10/libgsttheora.so
179 %{_libdir}/gstreamer-0.10/libgstvorbis.so
180 %{_libdir}/gstreamer-0.10/libgstximagesink.so
181 %{_libdir}/gstreamer-0.10/libgstpango.so
182 %{_libdir}/gstreamer-0.10/libgstgio.so
183 # data
184 %{_datadir}/gst-plugins-base/license-translations.dict
185 # license
186 /usr/share/license/%{name}
187
188 %files devel
189 %defattr(-,root,root,-)
190 %dir %{_includedir}/gstreamer-0.10/gst/app
191 %{_includedir}/gstreamer-0.10/gst/tag/xmpwriter.h
192 %{_includedir}/gstreamer-0.10/gst/app/gstappbuffer.h
193 %{_includedir}/gstreamer-0.10/gst/app/gstappsink.h
194 %{_includedir}/gstreamer-0.10/gst/app/gstappsrc.h
195 %dir %{_includedir}/gstreamer-0.10/gst/audio
196 %{_includedir}/gstreamer-0.10/gst/audio/audio.h
197 %{_includedir}/gstreamer-0.10/gst/audio/audio-enumtypes.h
198 %{_includedir}/gstreamer-0.10/gst/audio/gstaudioclock.h
199 %{_includedir}/gstreamer-0.10/gst/audio/gstaudiodecoder.h
200 %{_includedir}/gstreamer-0.10/gst/audio/gstaudioencoder.h
201 %{_includedir}/gstreamer-0.10/gst/audio/gstaudiofilter.h
202 %{_includedir}/gstreamer-0.10/gst/audio/gstaudioiec61937.h
203 %{_includedir}/gstreamer-0.10/gst/audio/gstaudiosink.h
204 %{_includedir}/gstreamer-0.10/gst/audio/gstaudiosrc.h
205 %{_includedir}/gstreamer-0.10/gst/audio/gstbaseaudiosink.h
206 %{_includedir}/gstreamer-0.10/gst/audio/gstbaseaudiosrc.h
207 %{_includedir}/gstreamer-0.10/gst/audio/gstringbuffer.h
208 %{_includedir}/gstreamer-0.10/gst/audio/mixerutils.h
209 %{_includedir}/gstreamer-0.10/gst/audio/multichannel.h
210 %exclude %dir %{_includedir}/gstreamer-0.10/gst/cdda
211 %exclude %{_includedir}/gstreamer-0.10/gst/cdda/gstcddabasesrc.h
212 %dir %{_includedir}/gstreamer-0.10/gst/floatcast
213 %{_includedir}/gstreamer-0.10/gst/floatcast/floatcast.h
214 %dir %{_includedir}/gstreamer-0.10/gst/fft
215 %{_includedir}/gstreamer-0.10/gst/fft/gstfft*.h
216 %dir %{_includedir}/gstreamer-0.10/gst/interfaces
217 %{_includedir}/gstreamer-0.10/gst/interfaces/cameracontrol.h
218 %{_includedir}/gstreamer-0.10/gst/interfaces/cameracontrolchannel.h
219 %{_includedir}/gstreamer-0.10/gst/interfaces/colorbalance.h
220 %{_includedir}/gstreamer-0.10/gst/interfaces/colorbalancechannel.h
221 %{_includedir}/gstreamer-0.10/gst/interfaces/interfaces-enumtypes.h
222 %{_includedir}/gstreamer-0.10/gst/interfaces/mixer.h
223 %{_includedir}/gstreamer-0.10/gst/interfaces/mixeroptions.h
224 %{_includedir}/gstreamer-0.10/gst/interfaces/mixertrack.h
225 %{_includedir}/gstreamer-0.10/gst/interfaces/navigation.h
226 %{_includedir}/gstreamer-0.10/gst/interfaces/propertyprobe.h
227 %{_includedir}/gstreamer-0.10/gst/interfaces/tuner.h
228 %{_includedir}/gstreamer-0.10/gst/interfaces/tunerchannel.h
229 %{_includedir}/gstreamer-0.10/gst/interfaces/tunernorm.h
230 %{_includedir}/gstreamer-0.10/gst/interfaces/videoorientation.h
231 %{_includedir}/gstreamer-0.10/gst/interfaces/xoverlay.h
232 %{_includedir}/gstreamer-0.10/gst/interfaces/streamvolume.h
233 %dir %{_includedir}/gstreamer-0.10/gst/netbuffer
234 %{_includedir}/gstreamer-0.10/gst/netbuffer/gstnetbuffer.h
235 %dir %{_includedir}/gstreamer-0.10/gst/pbutils
236 %{_includedir}/gstreamer-0.10/gst/pbutils/codec-utils.h
237 %{_includedir}/gstreamer-0.10/gst/pbutils/descriptions.h
238 %{_includedir}/gstreamer-0.10/gst/pbutils/gstdiscoverer.h
239 %{_includedir}/gstreamer-0.10/gst/pbutils/gstpluginsbaseversion.h
240 %{_includedir}/gstreamer-0.10/gst/pbutils/install-plugins.h
241 %{_includedir}/gstreamer-0.10/gst/pbutils/missing-plugins.h
242 %{_includedir}/gstreamer-0.10/gst/pbutils/pbutils.h
243 %{_includedir}/gstreamer-0.10/gst/pbutils/pbutils-enumtypes.h
244 %{_includedir}/gstreamer-0.10/gst/pbutils/encoding-profile.h
245 %{_includedir}/gstreamer-0.10/gst/pbutils/encoding-target.h
246
247 %dir %{_includedir}/gstreamer-0.10/gst/riff
248 %{_includedir}/gstreamer-0.10/gst/riff/riff-ids.h
249 %{_includedir}/gstreamer-0.10/gst/riff/riff-media.h
250 %{_includedir}/gstreamer-0.10/gst/riff/riff-read.h
251 %dir %{_includedir}/gstreamer-0.10/gst/rtp
252 %{_includedir}/gstreamer-0.10/gst/rtp/gstbasertpaudiopayload.h
253 %{_includedir}/gstreamer-0.10/gst/rtp/gstbasertpdepayload.h
254 %{_includedir}/gstreamer-0.10/gst/rtp/gstbasertppayload.h
255 %{_includedir}/gstreamer-0.10/gst/rtp/gstrtcpbuffer.h
256 %{_includedir}/gstreamer-0.10/gst/rtp/gstrtpbuffer.h
257 %{_includedir}/gstreamer-0.10/gst/rtp/gstrtppayloads.h
258 %dir %{_includedir}/gstreamer-0.10/gst/rtsp
259 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtsp-enumtypes.h
260 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspbase64.h
261 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspconnection.h
262 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspdefs.h
263 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspextension.h
264 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspmessage.h
265 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtsprange.h
266 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtsptransport.h
267 %{_includedir}/gstreamer-0.10/gst/rtsp/gstrtspurl.h
268 %dir %{_includedir}/gstreamer-0.10/gst/sdp/
269 %{_includedir}/gstreamer-0.10/gst/sdp/gstsdp.h
270 %{_includedir}/gstreamer-0.10/gst/sdp/gstsdpmessage.h
271 %dir %{_includedir}/gstreamer-0.10/gst/tag
272 %{_includedir}/gstreamer-0.10/gst/tag/tag.h
273 %{_includedir}/gstreamer-0.10/gst/tag/gsttagdemux.h
274 %{_includedir}/gstreamer-0.10/gst/tag/gsttagmux.h
275 %dir %{_includedir}/gstreamer-0.10/gst/video
276 %{_includedir}/gstreamer-0.10/gst/video/gstvideofilter.h
277 %{_includedir}/gstreamer-0.10/gst/video/gstvideosink.h
278 %{_includedir}/gstreamer-0.10/gst/video/video.h
279 %{_includedir}/gstreamer-0.10/gst/video/video-enumtypes.h
280 %{_includedir}/gstreamer-0.10/gst/video/video-overlay-composition.h
281 %{_libdir}/libgstaudio-0.10.so
282 %{_libdir}/libgstinterfaces-0.10.so
283 %{_libdir}/libgstnetbuffer-0.10.so
284 %{_libdir}/libgstriff-0.10.so
285 %{_libdir}/libgstrtp-0.10.so
286 %{_libdir}/libgsttag-0.10.so
287 %{_libdir}/libgstvideo-0.10.so
288 %exclude %{_libdir}/libgstcdda-0.10.so
289 %{_libdir}/libgstpbutils-0.10.so
290 %{_libdir}/libgstrtsp-0.10.so
291 %{_libdir}/libgstsdp-0.10.so
292 %{_libdir}/libgstfft-0.10.so
293 %{_libdir}/libgstapp-0.10.so
294 # pkg-config files
295 %{_libdir}/pkgconfig/*.pc
296 # license
297 /usr/share/license/%{name}-devel
298
299 %files tools
300 %if 0%{?tizen_profile_wearable}
301 %manifest mobile/gst-plugins-base-tools.manifest
302 %else
303 %manifest wearable/gst-plugins-base-tools.manifest
304 %endif
305 %defattr(-,root,root,-)
306 # helper programs
307 %{_bindir}/gst-discoverer-0.10
308 %exclude %{_bindir}/gst-visualise-0.10
309 %exclude %{_mandir}/man1/gst-visualise-0.10*
310 # license
311 /usr/share/license/%{name}-tools
312