enable uvch264 plugin for TIVI-493
[platform/upstream/gst-plugins-bad.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:           gst-plugins-bad
5 Version:        1.2.0
6 Release:        0
7 %define gst_branch 1.0
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        GPL-2.0+ and LGPL-2.1+
10 Group:          Multimedia/Audio
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.bz2
14 Source1001:     gst-plugins-bad.manifest
15 BuildRequires:  gettext-tools
16 BuildRequires:  SDL-devel
17 BuildRequires:  autoconf
18 BuildRequires:  gcc-c++
19 BuildRequires:  glib2-devel >= 2.31.14
20 BuildRequires:  gstreamer-devel >= 1.0.0
21 BuildRequires:  gst-plugins-base-devel >= 1.0.0
22 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
23 BuildRequires:  python
24 BuildRequires:  xsltproc
25 BuildRequires:  pkgconfig(cairo)
26 BuildRequires:  pkgconfig(libusb-1.0)
27 BuildRequires:  pkgconfig(gudev-1.0)
28 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
29 BuildRequires:  pkgconfig(libcrypto)
30 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
31 BuildRequires:  pkgconfig(libexif) >= 0.6.16
32 BuildRequires:  pkgconfig(libpng) >= 1.2
33 BuildRequires:  pkgconfig(openssl) >= 0.9.5
34 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
35 %if %{with wayland}
36 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
37 %endif
38 %if %{with x}
39 BuildRequires:  pkgconfig(x11)
40 %endif
41 Requires(post): glib2-tools
42 Requires(postun): glib2-tools
43 Requires:       gstreamer >= 1.0.2
44 Enhances:       gstreamer
45
46 %description
47 GStreamer is a streaming media framework based on graphs of filters
48 that operate on media data. Applications using this library can do
49 anything media-related,from real-time sound processing to playing
50 videos. Its plug-in-based architecture means that new data types or
51 processing capabilities can be added simply by installing new plug-ins.
52
53
54 %package -n libgstbasecamerabinsrc
55 Summary:        GStreamer Streaming-Media Framework Plug-Ins
56
57 %description -n libgstbasecamerabinsrc
58 GStreamer is a streaming media framework based on graphs of filters
59 that operate on media data. Applications using this library can do
60 anything media-related,from real-time sound processing to playing
61 videos. Its plug-in-based architecture means that new data types or
62 processing capabilities can be added simply by installing new plug-ins.
63
64 %package -n libgstphotography
65 Summary:        GStreamer Streaming-Media Framework Plug-Ins
66
67 %description -n libgstphotography
68 GStreamer is a streaming media framework based on graphs of filters
69 that operate on media data. Applications using this library can do
70 anything media-related,from real-time sound processing to playing
71 videos. Its plug-in-based architecture means that new data types or
72 processing capabilities can be added simply by installing new plug-ins.
73
74 %package -n libgstvdp
75 Summary:        GStreamer Streaming-Media Framework Plug-Ins
76
77 %description -n libgstvdp
78 GStreamer is a streaming media framework based on graphs of filters
79 that operate on media data. Applications using this library can do
80 anything media-related,from real-time sound processing to playing
81 videos. Its plug-in-based architecture means that new data types or
82 processing capabilities can be added simply by installing new plug-ins.
83
84 %package -n libgstcodecparsers
85 Summary:        GStreamer Streaming-Media Framework Plug-Ins
86
87 %description -n libgstcodecparsers
88 GStreamer is a streaming media framework based on graphs of filters
89 that operate on media data. Applications using this library can do
90 anything media-related,from real-time sound processing to playing
91 videos. Its plug-in-based architecture means that new data types or
92 processing capabilities can be added simply by installing new plug-ins.
93
94 %package -n libgstegl
95 Summary:        GStreamer Streaming-Media Framework Plug-Ins
96
97 %description -n libgstegl
98 GStreamer is a streaming media framework based on graphs of filters
99 that operate on media data. Applications using this library can do
100 anything media-related,from real-time sound processing to playing
101 videos. Its plug-in-based architecture means that new data types or
102 processing capabilities can be added simply by installing new plug-ins.
103
104 %package -n libgstinsertbin
105 Summary:        GStreamer Streaming-Media Framework Plug-Ins
106
107 %description -n libgstinsertbin
108 GStreamer is a streaming media framework based on graphs of filters
109 that operate on media data. Applications using this library can do
110 anything media-related,from real-time sound processing to playing
111 videos. Its plug-in-based architecture means that new data types or
112 processing capabilities can be added simply by installing new plug-ins.
113
114 %package -n libgstmpegts
115 Summary:        GStreamer Streaming-Media Framework Plug-Ins
116
117 %description -n libgstmpegts
118 GStreamer is a streaming media framework based on graphs of filters
119 that operate on media data. Applications using this library can do
120 anything media-related,from real-time sound processing to playing
121 videos. Its plug-in-based architecture means that new data types or
122 processing capabilities can be added simply by installing new plug-ins.
123
124 %package -n libgsturidownloader
125 Summary:        GStreamer Streaming-Media Framework Plug-Ins
126
127 %description -n libgsturidownloader
128 GStreamer is a streaming media framework based on graphs of filters
129 that operate on media data. Applications using this library can do
130 anything media-related,from real-time sound processing to playing
131 videos. Its plug-in-based architecture means that new data types or
132 processing capabilities can be added simply by installing new plug-ins.
133
134 %package devel
135 Summary:        GStreamer Streaming-Media Framework Plug-Ins
136 Requires:       gstreamer-devel
137 Requires:       libgstbasecamerabinsrc = %{version}
138 Requires:       libgstcodecparsers = %{version}
139 Requires:       libgstphotography = %{version}
140 Requires:       libgstegl = %{version}
141 Requires:       libgstinsertbin = %{version}
142 Requires:       libgstmpegts = %{version}
143 Requires:       libgsturidownloader = %{version}
144
145 %description devel
146 GStreamer is a streaming media framework based on graphs of filters
147 that operate on media data. Applications using this library can do
148 anything media-related,from real-time sound processing to playing
149 videos. Its plug-in-based architecture means that new data types or
150 processing capabilities can be added simply by installing new plug-ins.
151
152
153 %prep
154 %setup -q -n %{name}-%{version}
155 %setup -q -T -D -a 100
156 cp %{SOURCE1001} .
157
158 %build
159 export V=1
160 NOCONFIGURE=1 ./autogen.sh
161 %configure\
162     --disable-static\
163     --disable-examples\
164     --enable-experimental\
165     --disable-gtk-doc
166 %__make %{?_smp_mflags} V=1
167
168 %install
169 %make_install
170 %find_lang %{name}-%{gst_branch}
171 mv %{name}-%{gst_branch}.lang %{name}.lang
172
173 %lang_package
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post
179 %glib2_gsettings_schema_post
180
181 %postun
182 %glib2_gsettings_schema_postun
183
184 %post -n libgstbasecamerabinsrc -p /sbin/ldconfig
185
186 %post -n libgstphotography -p /sbin/ldconfig
187
188 %post -n libgstcodecparsers -p /sbin/ldconfig
189
190 %post -n libgstvdp -p /sbin/ldconfig
191
192 %post -n libgstegl -p /sbin/ldconfig
193
194 %post -n libgstinsertbin -p /sbin/ldconfig
195
196 %post -n libgstmpegts -p /sbin/ldconfig
197
198 %post -n libgsturidownloader -p /sbin/ldconfig
199
200 %postun -n libgstbasecamerabinsrc -p /sbin/ldconfig
201
202 %postun -n libgstphotography -p /sbin/ldconfig
203
204 %postun -n libgstcodecparsers -p /sbin/ldconfig
205
206 %postun -n libgstvdp -p /sbin/ldconfig
207
208 %postun -n libgstegl -p /sbin/ldconfig
209
210 %postun -n libgstinsertbin -p /sbin/ldconfig
211
212 %postun -n libgstmpegts -p /sbin/ldconfig
213
214 %postun -n libgsturidownloader -p /sbin/ldconfig
215
216 %files
217 %manifest %{name}.manifest
218 %defattr(-, root, root)
219 %license COPYING COPYING.LIB
220 %{_libdir}/gstreamer-%{gst_branch}/libgstadpcmdec.so
221 %{_libdir}/gstreamer-%{gst_branch}/libgstadpcmenc.so
222 %{_libdir}/gstreamer-%{gst_branch}/libgstasfmux.so
223 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiovisualizers.so
224 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstbayer.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin2.so
227 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstcurl.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgstdataurisrc.so
230 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
231 %{_libdir}/gstreamer-%{gst_branch}/libgstdvb.so
232 %{_libdir}/gstreamer-%{gst_branch}/libgstdvbsuboverlay.so
233 %{_libdir}/gstreamer-%{gst_branch}/libgstfestival.so
234 %{_libdir}/gstreamer-%{gst_branch}/libgstgaudieffects.so
235 %{_libdir}/gstreamer-%{gst_branch}/libgstgdp.so
236 %{_libdir}/gstreamer-%{gst_branch}/libgstgeometrictransform.so
237 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
238 %{_libdir}/gstreamer-%{gst_branch}/libgstinter.so
239 %{_libdir}/gstreamer-%{gst_branch}/libgstinterlace.so
240 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
241 %{_libdir}/gstreamer-%{gst_branch}/libgstliveadder.so
242
243 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
244 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
245 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
246 %{_libdir}/gstreamer-%{gst_branch}/libgstpcapparse.so
247 %{_libdir}/gstreamer-%{gst_branch}/libgstpnm.so
248 %{_libdir}/gstreamer-%{gst_branch}/libgstrawparse.so
249 %{_libdir}/gstreamer-%{gst_branch}/libgstremovesilence.so
250 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
251 %{_libdir}/gstreamer-%{gst_branch}/libgstsegmentclip.so
252 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
253 %{_libdir}/gstreamer-%{gst_branch}/libgstsmooth.so
254 %{_libdir}/gstreamer-%{gst_branch}/libgstspeed.so
255 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
256 %{_libdir}/gstreamer-%{gst_branch}/libgsty4mdec.so
257 %{_libdir}/gstreamer-%{gst_branch}/libgstdvdspu.so
258 %{_libdir}/gstreamer-%{gst_branch}/libgstfieldanalysis.so
259 %{_libdir}/gstreamer-%{gst_branch}/libgstfrei0r.so
260 %{_libdir}/gstreamer-%{gst_branch}/libgstsiren.so
261 %{_libdir}/gstreamer-%{gst_branch}/libgstsubenc.so
262 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsmux.so
263 %{_libdir}/gstreamer-%{gst_branch}/libgstdecklink.so
264 %{_libdir}/gstreamer-%{gst_branch}/libgsteglglessink.so
265 %{_libdir}/gstreamer-%{gst_branch}/libgstaccurip.so
266 %{_libdir}/gstreamer-%{gst_branch}/libgstaiff.so
267 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiofxbad.so
268 %{_libdir}/gstreamer-%{gst_branch}/libgstfbdevsink.so
269 %{_libdir}/gstreamer-%{gst_branch}/libgstfreeverb.so
270 %{_libdir}/gstreamer-%{gst_branch}/libgstivtc.so
271 %{_libdir}/gstreamer-%{gst_branch}/libgstmfc.so
272 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
273 %{_libdir}/gstreamer-%{gst_branch}/libgstmxf.so
274 %{_libdir}/gstreamer-%{gst_branch}/libgstrfbsrc.so
275 %{_libdir}/gstreamer-%{gst_branch}/libgstvideofiltersbad.so
276 %{_libdir}/gstreamer-%{gst_branch}/libgstyadif.so
277 %{_libdir}/gstreamer-%{gst_branch}/libgstuvch264.so
278
279 %if %{with wayland}
280 %{_libdir}/gstreamer-%{gst_branch}/libgstwaylandsink.so
281 %endif
282
283 %files -n libgstphotography
284 %manifest %{name}.manifest
285 %defattr(-, root, root)
286 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
287
288 %files -n libgstbasecamerabinsrc
289 %manifest %{name}.manifest
290 %defattr(-, root, root)
291 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
292
293 %files -n libgstcodecparsers
294 %manifest %{name}.manifest
295 %defattr(-, root, root)
296 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
297
298 %files -n libgstegl
299 %manifest %{name}.manifest
300 %defattr(-, root, root)
301 %{_libdir}/libgstegl-%{gst_branch}.so.0*
302
303 %files -n libgstinsertbin
304 %manifest %{name}.manifest
305 %defattr(-, root, root)
306 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
307
308 %files -n libgstmpegts
309 %manifest %{name}.manifest
310 %defattr(-, root, root)
311 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
312
313 %files -n libgsturidownloader
314 %manifest %{name}.manifest
315 %defattr(-, root, root)
316 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
317
318 %files devel
319 %manifest %{name}.manifest
320 %defattr(-, root, root)
321 %{_includedir}/gstreamer-%{gst_branch}
322 %{_libdir}/*.so
323 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
324 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
325 %{_libdir}/pkgconfig/gstreamer-egl-%{gst_branch}.pc
326 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc