packaging: support non X11 configuration (wayland)
[platform/upstream/gst-plugins-bad.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 %bcond_with x
3
4 Name:           gst-plugins-bad
5 Version:        1.2.0
6 Release:        0
7 %define gst_branch 1.0
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        GPL-2.0+ and LGPL-2.1+
10 Group:          Multimedia/Audio
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.bz2
14 Source1001:     gst-plugins-bad.manifest
15 BuildRequires:  gettext-tools
16 BuildRequires:  SDL-devel
17 BuildRequires:  autoconf
18 BuildRequires:  gcc-c++
19 BuildRequires:  glib2-devel >= 2.31.14
20 BuildRequires:  gstreamer-devel >= 1.0.0
21 BuildRequires:  gst-plugins-base-devel >= 1.0.0
22 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
23 BuildRequires:  python
24 BuildRequires:  xsltproc
25 BuildRequires:  pkgconfig(cairo)
26 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
27 BuildRequires:  pkgconfig(libcrypto)
28 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
29 BuildRequires:  pkgconfig(libexif) >= 0.6.16
30 BuildRequires:  pkgconfig(libpng) >= 1.2
31 BuildRequires:  pkgconfig(openssl) >= 0.9.5
32 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
33 %if %{with wayland}
34 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
35 %endif
36 %if %{with x}
37 BuildRequires:  pkgconfig(x11)
38 %endif
39 Requires(post): glib2-tools
40 Requires(postun): glib2-tools
41 Requires:       gstreamer >= 1.0.2
42 Enhances:       gstreamer
43
44 %description
45 GStreamer is a streaming media framework based on graphs of filters
46 that operate on media data. Applications using this library can do
47 anything media-related,from real-time sound processing to playing
48 videos. Its plug-in-based architecture means that new data types or
49 processing capabilities can be added simply by installing new plug-ins.
50
51
52 %package -n libgstbasecamerabinsrc
53 Summary:        GStreamer Streaming-Media Framework Plug-Ins
54
55 %description -n libgstbasecamerabinsrc
56 GStreamer is a streaming media framework based on graphs of filters
57 that operate on media data. Applications using this library can do
58 anything media-related,from real-time sound processing to playing
59 videos. Its plug-in-based architecture means that new data types or
60 processing capabilities can be added simply by installing new plug-ins.
61
62 %package -n libgstphotography
63 Summary:        GStreamer Streaming-Media Framework Plug-Ins
64
65 %description -n libgstphotography
66 GStreamer is a streaming media framework based on graphs of filters
67 that operate on media data. Applications using this library can do
68 anything media-related,from real-time sound processing to playing
69 videos. Its plug-in-based architecture means that new data types or
70 processing capabilities can be added simply by installing new plug-ins.
71
72 %package -n libgstvdp
73 Summary:        GStreamer Streaming-Media Framework Plug-Ins
74
75 %description -n libgstvdp
76 GStreamer is a streaming media framework based on graphs of filters
77 that operate on media data. Applications using this library can do
78 anything media-related,from real-time sound processing to playing
79 videos. Its plug-in-based architecture means that new data types or
80 processing capabilities can be added simply by installing new plug-ins.
81
82 %package -n libgstcodecparsers
83 Summary:        GStreamer Streaming-Media Framework Plug-Ins
84
85 %description -n libgstcodecparsers
86 GStreamer is a streaming media framework based on graphs of filters
87 that operate on media data. Applications using this library can do
88 anything media-related,from real-time sound processing to playing
89 videos. Its plug-in-based architecture means that new data types or
90 processing capabilities can be added simply by installing new plug-ins.
91
92 %package -n libgstegl
93 Summary:        GStreamer Streaming-Media Framework Plug-Ins
94
95 %description -n libgstegl
96 GStreamer is a streaming media framework based on graphs of filters
97 that operate on media data. Applications using this library can do
98 anything media-related,from real-time sound processing to playing
99 videos. Its plug-in-based architecture means that new data types or
100 processing capabilities can be added simply by installing new plug-ins.
101
102 %package -n libgstinsertbin
103 Summary:        GStreamer Streaming-Media Framework Plug-Ins
104
105 %description -n libgstinsertbin
106 GStreamer is a streaming media framework based on graphs of filters
107 that operate on media data. Applications using this library can do
108 anything media-related,from real-time sound processing to playing
109 videos. Its plug-in-based architecture means that new data types or
110 processing capabilities can be added simply by installing new plug-ins.
111
112 %package -n libgstmpegts
113 Summary:        GStreamer Streaming-Media Framework Plug-Ins
114
115 %description -n libgstmpegts
116 GStreamer is a streaming media framework based on graphs of filters
117 that operate on media data. Applications using this library can do
118 anything media-related,from real-time sound processing to playing
119 videos. Its plug-in-based architecture means that new data types or
120 processing capabilities can be added simply by installing new plug-ins.
121
122 %package -n libgsturidownloader
123 Summary:        GStreamer Streaming-Media Framework Plug-Ins
124
125 %description -n libgsturidownloader
126 GStreamer is a streaming media framework based on graphs of filters
127 that operate on media data. Applications using this library can do
128 anything media-related,from real-time sound processing to playing
129 videos. Its plug-in-based architecture means that new data types or
130 processing capabilities can be added simply by installing new plug-ins.
131
132 %package devel
133 Summary:        GStreamer Streaming-Media Framework Plug-Ins
134 Requires:       gstreamer-devel
135 Requires:       libgstbasecamerabinsrc = %{version}
136 Requires:       libgstcodecparsers = %{version}
137 Requires:       libgstphotography = %{version}
138 Requires:       libgstegl = %{version}
139 Requires:       libgstinsertbin = %{version}
140 Requires:       libgstmpegts = %{version}
141 Requires:       libgsturidownloader = %{version}
142
143 %description devel
144 GStreamer is a streaming media framework based on graphs of filters
145 that operate on media data. Applications using this library can do
146 anything media-related,from real-time sound processing to playing
147 videos. Its plug-in-based architecture means that new data types or
148 processing capabilities can be added simply by installing new plug-ins.
149
150
151 %prep
152 %setup -q -n %{name}-%{version}
153 %setup -q -T -D -a 100
154 cp %{SOURCE1001} .
155
156 %build
157 export V=1
158 NOCONFIGURE=1 ./autogen.sh
159 %configure\
160     --disable-static\
161     --disable-examples\
162     --enable-experimental\
163     --disable-gtk-doc
164 %__make %{?_smp_mflags} V=1
165
166 %install
167 %make_install
168 %find_lang %{name}-%{gst_branch}
169 mv %{name}-%{gst_branch}.lang %{name}.lang
170
171 %lang_package
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post
177 %glib2_gsettings_schema_post
178
179 %postun
180 %glib2_gsettings_schema_postun
181
182 %post -n libgstbasecamerabinsrc -p /sbin/ldconfig
183
184 %post -n libgstphotography -p /sbin/ldconfig
185
186 %post -n libgstcodecparsers -p /sbin/ldconfig
187
188 %post -n libgstvdp -p /sbin/ldconfig
189
190 %post -n libgstegl -p /sbin/ldconfig
191
192 %post -n libgstinsertbin -p /sbin/ldconfig
193
194 %post -n libgstmpegts -p /sbin/ldconfig
195
196 %post -n libgsturidownloader -p /sbin/ldconfig
197
198 %postun -n libgstbasecamerabinsrc -p /sbin/ldconfig
199
200 %postun -n libgstphotography -p /sbin/ldconfig
201
202 %postun -n libgstcodecparsers -p /sbin/ldconfig
203
204 %postun -n libgstvdp -p /sbin/ldconfig
205
206 %postun -n libgstegl -p /sbin/ldconfig
207
208 %postun -n libgstinsertbin -p /sbin/ldconfig
209
210 %postun -n libgstmpegts -p /sbin/ldconfig
211
212 %postun -n libgsturidownloader -p /sbin/ldconfig
213
214 %files
215 %manifest %{name}.manifest
216 %defattr(-, root, root)
217 %license COPYING COPYING.LIB
218 %{_libdir}/gstreamer-%{gst_branch}/libgstadpcmdec.so
219 %{_libdir}/gstreamer-%{gst_branch}/libgstadpcmenc.so
220 %{_libdir}/gstreamer-%{gst_branch}/libgstasfmux.so
221 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiovisualizers.so
222 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
223 %{_libdir}/gstreamer-%{gst_branch}/libgstbayer.so
224 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin2.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstcurl.so
227 %{_libdir}/gstreamer-%{gst_branch}/libgstdataurisrc.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgstdvb.so
230 %{_libdir}/gstreamer-%{gst_branch}/libgstdvbsuboverlay.so
231 %{_libdir}/gstreamer-%{gst_branch}/libgstfestival.so
232 %{_libdir}/gstreamer-%{gst_branch}/libgstgaudieffects.so
233 %{_libdir}/gstreamer-%{gst_branch}/libgstgdp.so
234 %{_libdir}/gstreamer-%{gst_branch}/libgstgeometrictransform.so
235 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
236 %{_libdir}/gstreamer-%{gst_branch}/libgstinter.so
237 %{_libdir}/gstreamer-%{gst_branch}/libgstinterlace.so
238 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
239 %{_libdir}/gstreamer-%{gst_branch}/libgstliveadder.so
240
241 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
242 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
243 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
244 %{_libdir}/gstreamer-%{gst_branch}/libgstpcapparse.so
245 %{_libdir}/gstreamer-%{gst_branch}/libgstpnm.so
246 %{_libdir}/gstreamer-%{gst_branch}/libgstrawparse.so
247 %{_libdir}/gstreamer-%{gst_branch}/libgstremovesilence.so
248 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
249 %{_libdir}/gstreamer-%{gst_branch}/libgstsegmentclip.so
250 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
251 %{_libdir}/gstreamer-%{gst_branch}/libgstsmooth.so
252 %{_libdir}/gstreamer-%{gst_branch}/libgstspeed.so
253 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
254 %{_libdir}/gstreamer-%{gst_branch}/libgsty4mdec.so
255 %{_libdir}/gstreamer-%{gst_branch}/libgstdvdspu.so
256 %{_libdir}/gstreamer-%{gst_branch}/libgstfieldanalysis.so
257 %{_libdir}/gstreamer-%{gst_branch}/libgstfrei0r.so
258 %{_libdir}/gstreamer-%{gst_branch}/libgstsiren.so
259 %{_libdir}/gstreamer-%{gst_branch}/libgstsubenc.so
260 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsmux.so
261 %{_libdir}/gstreamer-%{gst_branch}/libgstdecklink.so
262 %{_libdir}/gstreamer-%{gst_branch}/libgsteglglessink.so
263 %{_libdir}/gstreamer-%{gst_branch}/libgstaccurip.so
264 %{_libdir}/gstreamer-%{gst_branch}/libgstaiff.so
265 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiofxbad.so
266 %{_libdir}/gstreamer-%{gst_branch}/libgstfbdevsink.so
267 %{_libdir}/gstreamer-%{gst_branch}/libgstfreeverb.so
268 %{_libdir}/gstreamer-%{gst_branch}/libgstivtc.so
269 %{_libdir}/gstreamer-%{gst_branch}/libgstmfc.so
270 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
271 %{_libdir}/gstreamer-%{gst_branch}/libgstmxf.so
272 %{_libdir}/gstreamer-%{gst_branch}/libgstrfbsrc.so
273 %{_libdir}/gstreamer-%{gst_branch}/libgstvideofiltersbad.so
274 %{_libdir}/gstreamer-%{gst_branch}/libgstyadif.so
275
276 %if %{with wayland}
277 %{_libdir}/gstreamer-%{gst_branch}/libgstwaylandsink.so
278 %endif
279
280 %files -n libgstphotography
281 %manifest %{name}.manifest
282 %defattr(-, root, root)
283 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
284
285 %files -n libgstbasecamerabinsrc
286 %manifest %{name}.manifest
287 %defattr(-, root, root)
288 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
289
290 %files -n libgstcodecparsers
291 %manifest %{name}.manifest
292 %defattr(-, root, root)
293 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
294
295 %files -n libgstegl
296 %manifest %{name}.manifest
297 %defattr(-, root, root)
298 %{_libdir}/libgstegl-%{gst_branch}.so.0*
299
300 %files -n libgstinsertbin
301 %manifest %{name}.manifest
302 %defattr(-, root, root)
303 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
304
305 %files -n libgstmpegts
306 %manifest %{name}.manifest
307 %defattr(-, root, root)
308 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
309
310 %files -n libgsturidownloader
311 %manifest %{name}.manifest
312 %defattr(-, root, root)
313 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
314
315 %files devel
316 %manifest %{name}.manifest
317 %defattr(-, root, root)
318 %{_includedir}/gstreamer-%{gst_branch}
319 %{_libdir}/*.so
320 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
321 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
322 %{_libdir}/pkgconfig/gstreamer-egl-%{gst_branch}.pc
323 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc