Remove gles20 dependency for headless
[platform/upstream/gst-plugins-bad.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 #%bcond_with x
3 %define gst_branch 1.0
4
5 Name:           gst-plugins-bad
6 Version:        1.12.2
7 Release:        0
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        LGPL-2.0+
10 Group:          Multimedia/Framework
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  autoconf
16 BuildRequires:  gcc-c++
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.14
18 BuildRequires:  pkgconfig(gstreamer-1.0) >= 1.12.0
19 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.12.0
20 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
21 BuildRequires:  python
22 BuildRequires:  xsltproc
23 BuildRequires:  pkgconfig(libusb-1.0)
24 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
25 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
26 BuildRequires:  pkgconfig(libexif) >= 0.6.16
27 BuildRequires:  pkgconfig(openssl1.1)
28 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
29 BuildRequires:  pkgconfig(openal)
30 BuildRequires:  pkgconfig(soundtouch) > 1.4
31 %if %{with wayland}
32 %if 0%{?enable_gl:1}
33 BuildRequires:  pkgconfig(gles20)
34 BuildRequires:  pkgconfig(wayland-egl) >= 9.0
35 %endif
36 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
37 BuildRequires:  pkgconfig(wayland-cursor) >= 1.0.0
38 BuildRequires:  pkgconfig(libxml-2.0)
39 %endif
40 %if %{with x}
41 BuildRequires:  pkgconfig(x11)
42 %endif
43 Requires:       gstreamer >= 1.12.0
44
45 %description
46 GStreamer is a streaming media framework based on graphs of filters
47 that operate on media data. Applications using this library can do
48 anything media-related,from real-time sound processing to playing
49 videos. Its plug-in-based architecture means that new data types or
50 processing capabilities can be added simply by installing new plug-ins.
51
52
53 %package devel
54 Summary:        GStreamer Streaming-Media Framework Plug-Ins
55 Requires: %{name} = %{version}-%{release}
56 Requires: gst-plugins-base-devel
57
58 %description devel
59 GStreamer is a streaming media framework based on graphs of filters
60 that operate on media data. Applications using this library can do
61 anything media-related,from real-time sound processing to playing
62 videos. Its plug-in-based architecture means that new data types or
63 processing capabilities can be added simply by installing new plug-ins.
64
65
66 %prep
67 %setup -q -n %{name}-%{version}
68 %setup -q -T -D -a 100
69
70 %build
71 export V=1
72 NOCONFIGURE=1 ./autogen.sh
73 export CFLAGS+=" -Wall -g -fPIC\
74   -DTIZEN_FEATURE_AVOID_PAD_SWITCHING\
75   -DTIZEN_FEATURE_ADAPTIVE_MODIFICATION\
76   -DTIZEN_FEATURE_TSDEMUX_MODIFICATION\
77   -DTIZEN_FEATURE_OALSINK_MODIFICATION\
78   -DTIZEN_FEATURE_UPSTREAM\
79   -fstack-protector-strong\
80   -Wl,-z,relro\
81   -D_FORTIFY_SOURCE=2"
82
83 %configure\
84         --disable-static\
85         --disable-examples\
86         --enable-experimental\
87 %if "%{tizen_profile_name}" == "tv"
88         --enable-tv\
89         --disable-autoconvert\
90         --disable-camerabin2\
91         --disable-dash\
92         --disable-hls\
93         --disable-id3tag\
94         --disable-jpegformat\
95         --disable-mpegdemux\
96         --disable-smoothstreaming\
97         --disable-coloreffects\
98         --disable-rtp\
99         --disable-gl\
100 %endif
101         --disable-accurip\
102         --disable-adpcmdec\
103         --disable-audiofxbad\
104         --disable-decklink\
105         --disable-dvb\
106         --disable-fieldanalysis\
107         --disable-gdp\
108         --disable-ivtc\
109         --disable-liveadder\
110         --disable-rawparse\
111         --disable-videofilters\
112         --disable-yadif\
113         --disable-curl\
114         --disable-dtls\
115         --disable-fbdev\
116         --disable-uvch264\
117         --disable-vcd\
118         --disable-y4m\
119         --disable-adpcmenc\
120         --disable-aiff\
121         --disable-asfmux\
122         --disable-audiomixer\
123         --disable-compositor\
124         --disable-audiovisualizers\
125         --disable-bayer\
126         --disable-cdxaparse\
127         --disable-dataurisrc\
128         --disable-dccp\
129         --disable-dvbsuboverlay\
130         --disable-dvdspu\
131         --disable-faceoverlay\
132         --disable-festival\
133         --disable-freeverb\
134         --disable-frei0r\
135         --disable-gaudieffects\
136         --disable-geometrictransform\
137         --disable-hdvparse\
138         --disable-inter\
139         --disable-interlace\
140         --disable-ivfparse\
141         --disable-jp2kdecimator\
142         --disable-librfb\
143         --disable-mve\
144         --disable-mxf\
145         --disable-nuvdemux\
146         --disable-onvif\
147         --disable-pcapparse\
148         --disable-pnm\
149         --disable-removesilence\
150         --disable-sdi\
151         --disable-segmentclip\
152         --disable-siren\
153         --disable-smooth\
154         --disable-speed\
155         --disable-subenc\
156         --disable-stereo\
157         --disable-tta\
158         --disable-videomeasure\
159         --disable-videosignal\
160         --disable-vmnc\
161         --disable-opengl\
162 %if 0%{?enable_gl:1}
163         --enable-egl=yes\
164         --enable-gles2=yes\
165 %endif
166         --enable-wayland=yes\
167         --disable-glx\
168         --enable-openal=yes\
169         --disable-sndfile\
170         --disable-gtk-doc\
171         --disable-warnings-as-errors\
172         --disable-mpegpsmux
173 %__make %{?_smp_mflags} V=1
174
175 %install
176 %make_install
177 %find_lang %{name}-%{gst_branch}
178 mv %{name}-%{gst_branch}.lang %{name}.lang
179
180 %lang_package
181
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post -p /sbin/ldconfig
187
188
189 %postun -p /sbin/ldconfig
190
191
192 %files
193 %manifest %{name}.manifest
194 %defattr(-, root, root)
195 %license COPYING.LIB
196 %if "%{tizen_profile_name}" != "tv"
197 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
198 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin.so
199 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
200 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
201 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
202 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
203 %{_libdir}/gstreamer-%{gst_branch}/libgstsmoothstreaming.so
204 %{_libdir}/gstreamer-%{gst_branch}/libgstdashdemux.so
205 %if 0%{?enable_gl:1}
206 %{_libdir}/gstreamer-%{gst_branch}/libgstopengl.so
207 %endif
208 %{_libdir}/gstreamer-%{gst_branch}/libgstsoundtouch.so
209 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
210 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
211 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
212 %{_libdir}/libgstbadbase-%{gst_branch}.so.0*
213 %{_libdir}/libgstbadvideo-%{gst_branch}.so.0*
214 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
215 %{_libdir}/libgstadaptivedemux-%{gst_branch}.so.0*
216 %if 0%{?enable_gl:1}
217 %{_libdir}/libgstgl-%{gst_branch}.so.0*
218 %endif
219 %{_libdir}/libgstisoff-%{gst_branch}.so.0*
220 %endif
221 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
222 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
223 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
224 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
227 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstopenal.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgsthls.so
230 %{_libdir}/gstreamer-%{gst_branch}/libgstnetsim.so
231 %{_libdir}/gstreamer-%{gst_branch}/libgsttimecode.so
232 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoframe_audiolevel.so
233 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiomixmatrix.so
234 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiobuffersplit.so
235
236 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
237 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
238 %{_libdir}/libgstbadallocators-%{gst_branch}.so.0*
239 %{_libdir}/libgstbadaudio-%{gst_branch}.so.0*
240 %{_libdir}/libgstplayer-%{gst_branch}.so.0*
241
242 %files devel
243 %manifest %{name}.manifest
244 %defattr(-, root, root)
245 %{_includedir}/gstreamer-%{gst_branch}
246 %if "%{tizen_profile_name}" != "tv"
247 %if 0%{?enable_gl:1}
248 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gl/gstglconfig.h
249 %endif
250 %endif
251 %{_libdir}/*.so
252 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
253 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
254 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc
255 %{_libdir}/pkgconfig/gstreamer-mpegts-%{gst_branch}.pc
256 %if 0%{?enable_gl:1}
257 %{_libdir}/pkgconfig/gstreamer-gl-1.0.pc
258 %endif
259 %{_libdir}/pkgconfig/gstreamer-bad-allocators-1.0.pc
260 %{_libdir}/pkgconfig/gstreamer-bad-audio-1.0.pc
261 %{_libdir}/pkgconfig/gstreamer-bad-base-1.0.pc
262 %{_libdir}/pkgconfig/gstreamer-bad-video-1.0.pc
263 %{_libdir}/pkgconfig/gstreamer-player-1.0.pc