Merge branch 'tizen_gst_1.16.2' into tizen
[platform/upstream/gst-plugins-bad.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 #%bcond_with x
3 %define gst_branch 1.0
4
5 Name:           gst-plugins-bad
6 Version:        1.16.2
7 Release:        0
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        LGPL-2.0+
10 Group:          Multimedia/Framework
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  autoconf
16 BuildRequires:  gcc-c++
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.14
18 BuildRequires:  pkgconfig(gstreamer-1.0) >= 1.12.0
19 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.12.0
20 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
21 BuildRequires:  python
22 BuildRequires:  xsltproc
23 BuildRequires:  pkgconfig(libusb-1.0)
24 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
25 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
26 BuildRequires:  pkgconfig(libexif) >= 0.6.16
27 BuildRequires:  pkgconfig(openssl1.1)
28 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
29 BuildRequires:  pkgconfig(openal)
30 BuildRequires:  pkgconfig(soundtouch) > 1.4
31 %if %{with wayland}
32 %if 0%{?enable_gl:1}
33 BuildRequires:  pkgconfig(gles20)
34 BuildRequires:  pkgconfig(wayland-egl) >= 9.0
35 %endif
36 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
37 BuildRequires:  pkgconfig(wayland-cursor) >= 1.0.0
38 BuildRequires:  pkgconfig(libxml-2.0)
39 %endif
40 %if %{with x}
41 BuildRequires:  pkgconfig(x11)
42 %endif
43 Requires:       gstreamer >= 1.12.0
44
45 %description
46 GStreamer is a streaming media framework based on graphs of filters
47 that operate on media data. Applications using this library can do
48 anything media-related,from real-time sound processing to playing
49 videos. Its plug-in-based architecture means that new data types or
50 processing capabilities can be added simply by installing new plug-ins.
51
52
53 %package devel
54 Summary:        GStreamer Streaming-Media Framework Plug-Ins
55 Requires: %{name} = %{version}-%{release}
56 Requires: gst-plugins-base-devel
57
58 %description devel
59 GStreamer is a streaming media framework based on graphs of filters
60 that operate on media data. Applications using this library can do
61 anything media-related,from real-time sound processing to playing
62 videos. Its plug-in-based architecture means that new data types or
63 processing capabilities can be added simply by installing new plug-ins.
64
65
66 %prep
67 %setup -q -n %{name}-%{version}
68 %setup -q -T -D -a 100
69
70 %build
71 export V=1
72 NOCONFIGURE=1 ./autogen.sh
73 export CFLAGS+=" -Wall -g -fPIC\
74   -DTIZEN_FEATURE_AVOID_PAD_SWITCHING\
75   -DTIZEN_FEATURE_ADAPTIVE_MODIFICATION\
76   -DTIZEN_FEATURE_TSDEMUX_MODIFICATION\
77   -DTIZEN_FEATURE_OALSINK_MODIFICATION\
78   -DTIZEN_FEATURE_UPSTREAM\
79   -fstack-protector-strong\
80   -Wl,-z,relro\
81   -D_FORTIFY_SOURCE=2"
82 export CXXFLAGS+=" -DTIZEN_FEATURE_PITCH_AUDIO_META"
83
84 %configure\
85         --disable-static\
86         --disable-examples\
87         --enable-experimental\
88 %if "%{tizen_profile_name}" == "tv"
89         --enable-tv\
90         --disable-autoconvert\
91         --disable-camerabin2\
92         --disable-dash\
93         --disable-hls\
94         --disable-id3tag\
95         --disable-jpegformat\
96         --disable-mpegdemux\
97         --disable-smoothstreaming\
98         --disable-coloreffects\
99         --disable-rtp\
100         --disable-gl\
101 %endif
102         --disable-accurip\
103         --disable-adpcmdec\
104         --disable-audiofxbad\
105         --disable-decklink\
106         --disable-dvb\
107         --disable-fieldanalysis\
108         --disable-gdp\
109         --disable-ivtc\
110         --disable-liveadder\
111         --disable-rawparse\
112         --disable-videofilters\
113         --disable-yadif\
114         --disable-curl\
115         --disable-dtls\
116         --disable-fbdev\
117         --disable-uvch264\
118         --disable-vcd\
119         --disable-y4m\
120         --disable-adpcmenc\
121         --disable-aiff\
122         --disable-asfmux\
123         --disable-audiomixer\
124         --disable-compositor\
125         --disable-audiovisualizers\
126         --disable-bayer\
127         --disable-cdxaparse\
128         --disable-dataurisrc\
129         --disable-dccp\
130         --disable-dvbsuboverlay\
131         --disable-dvdspu\
132         --disable-faceoverlay\
133         --disable-festival\
134         --disable-freeverb\
135         --disable-frei0r\
136         --disable-gaudieffects\
137         --disable-geometrictransform\
138         --disable-hdvparse\
139         --disable-inter\
140         --disable-interlace\
141         --disable-ivfparse\
142         --disable-jp2kdecimator\
143         --disable-librfb\
144         --disable-mve\
145         --disable-mxf\
146         --disable-nuvdemux\
147         --disable-onvif\
148         --disable-pcapparse\
149         --disable-pnm\
150         --disable-removesilence\
151         --disable-sdi\
152         --disable-segmentclip\
153         --disable-siren\
154         --disable-smooth\
155         --disable-speed\
156         --disable-subenc\
157         --disable-stereo\
158         --disable-tta\
159         --disable-videomeasure\
160         --disable-videosignal\
161         --disable-vmnc\
162         --disable-opengl\
163 %if 0%{?enable_gl:1}
164         --enable-egl=yes\
165         --enable-gles2=yes\
166 %endif
167         --enable-wayland=yes\
168         --disable-glx\
169         --enable-openal=yes\
170         --disable-sndfile\
171         --disable-gtk-doc\
172         --disable-warnings-as-errors\
173         --disable-mpegpsmux
174 %__make %{?_smp_mflags} V=1
175
176 %install
177 %make_install
178 %find_lang %{name}-%{gst_branch}
179 mv %{name}-%{gst_branch}.lang %{name}.lang
180
181 %lang_package
182
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post -p /sbin/ldconfig
188
189
190 %postun -p /sbin/ldconfig
191
192
193 %files
194 %manifest %{name}.manifest
195 %defattr(-, root, root)
196 %license COPYING.LIB
197 %if "%{tizen_profile_name}" != "tv"
198 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
199 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin.so
200 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
201 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
202 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
203 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
204 %{_libdir}/gstreamer-%{gst_branch}/libgstsmoothstreaming.so
205 %{_libdir}/gstreamer-%{gst_branch}/libgstdashdemux.so
206 %if 0%{?enable_gl:1}
207 %{_libdir}/gstreamer-%{gst_branch}/libgstopengl.so
208 %endif
209 %{_libdir}/gstreamer-%{gst_branch}/libgstsoundtouch.so
210 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
211 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
212 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
213 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
214 %{_libdir}/libgstadaptivedemux-%{gst_branch}.so.0*
215 %if 0%{?enable_gl:1}
216 %{_libdir}/libgstgl-%{gst_branch}.so.0*
217 %endif
218 %{_libdir}/libgstisoff-%{gst_branch}.so.0*
219 %endif
220 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
221 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
222 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
223 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
224 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
227 %{_libdir}/gstreamer-%{gst_branch}/libgstopenal.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgsthls.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgstnetsim.so
230 %{_libdir}/gstreamer-%{gst_branch}/libgsttimecode.so
231 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoframe_audiolevel.so
232 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiomixmatrix.so
233 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiobuffersplit.so
234
235 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiolatency.so
236 %{_libdir}/gstreamer-%{gst_branch}/libgstipcpipeline.so
237 %{_libdir}/gstreamer-%{gst_branch}/libgstproxy.so
238
239 %{_libdir}/libgstsctp-%{gst_branch}.so.0*
240 %{_libdir}/libgstwebrtc-%{gst_branch}.so.0*
241 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
242 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
243 %{_libdir}/libgstbadaudio-%{gst_branch}.so.0*
244 %{_libdir}/libgstplayer-%{gst_branch}.so.0*
245
246 %files devel
247 %manifest %{name}.manifest
248 %defattr(-, root, root)
249 %{_includedir}/gstreamer-%{gst_branch}
250 %if "%{tizen_profile_name}" != "tv"
251 %if 0%{?enable_gl:1}
252 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gl/gstglconfig.h
253 %endif
254 %endif
255 %{_libdir}/*.so
256 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
257 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
258 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc
259 %{_libdir}/pkgconfig/gstreamer-mpegts-%{gst_branch}.pc
260 %if 0%{?enable_gl:1}
261 %{_libdir}/pkgconfig/gstreamer-gl-1.0.pc
262 %endif
263 %{_libdir}/pkgconfig/gstreamer-bad-audio-1.0.pc
264 %{_libdir}/pkgconfig/gstreamer-player-1.0.pc
265 %{_libdir}/pkgconfig/gstreamer-sctp-1.0.pc
266 %{_libdir}/pkgconfig/gstreamer-webrtc-1.0.pc