6cdbde85301d102cf4a54e5fc42edce37b40ab98
[platform/upstream/gstreamer.git] / packaging / gst-plugins-bad.spec
1 %bcond_with wayland
2 #%bcond_with x
3 %define gst_branch 1.0
4
5 Name:           gst-plugins-bad
6 Version:        1.16.2
7 Release:        1
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 License:        LGPL-2.0+
10 Group:          Multimedia/Framework
11 Url:            http://gstreamer.freedesktop.org/
12 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
13 Source100:      common.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  autoconf
16 BuildRequires:  gcc-c++
17 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.14
18 BuildRequires:  pkgconfig(gstreamer-1.0) >= 1.12.0
19 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.12.0
20 BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
21 BuildRequires:  python
22 BuildRequires:  xsltproc
23 BuildRequires:  pkgconfig(libusb-1.0)
24 BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
25 BuildRequires:  pkgconfig(libcurl) >= 7.21.0
26 BuildRequires:  pkgconfig(libexif) >= 0.6.16
27 BuildRequires:  pkgconfig(openssl1.1)
28 BuildRequires:  pkgconfig(sndfile) >= 1.0.16
29 BuildRequires:  pkgconfig(openal)
30 BuildRequires:  pkgconfig(soundtouch) > 1.4
31 BuildRequires:  pkgconfig(nice)
32 BuildRequires:  pkgconfig(usrsctp)
33 BuildRequires:  pkgconfig(libsrtp2) >= 2.1.0
34 %if %{with wayland}
35 %if 0%{?enable_gl:1}
36 BuildRequires:  pkgconfig(gles20)
37 BuildRequires:  pkgconfig(wayland-egl) >= 9.0
38 %endif
39 BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
40 BuildRequires:  pkgconfig(wayland-cursor) >= 1.0.0
41 BuildRequires:  pkgconfig(libxml-2.0)
42 %endif
43 %if %{with x}
44 BuildRequires:  pkgconfig(x11)
45 %endif
46 Requires:       gstreamer >= 1.12.0
47
48 %description
49 GStreamer is a streaming media framework based on graphs of filters
50 that operate on media data. Applications using this library can do
51 anything media-related,from real-time sound processing to playing
52 videos. Its plug-in-based architecture means that new data types or
53 processing capabilities can be added simply by installing new plug-ins.
54
55
56 %package devel
57 Summary:        GStreamer Streaming-Media Framework Plug-Ins
58 Requires: %{name} = %{version}-%{release}
59 Requires: gst-plugins-base-devel
60
61 %description devel
62 GStreamer is a streaming media framework based on graphs of filters
63 that operate on media data. Applications using this library can do
64 anything media-related,from real-time sound processing to playing
65 videos. Its plug-in-based architecture means that new data types or
66 processing capabilities can be added simply by installing new plug-ins.
67
68
69 %prep
70 %setup -q -n %{name}-%{version}
71 %setup -q -T -D -a 100
72
73 %build
74 export V=1
75 NOCONFIGURE=1 ./autogen.sh
76 export CFLAGS+=" -Wall -g -fPIC\
77   -DTIZEN_FEATURE_AVOID_PAD_SWITCHING\
78   -DTIZEN_FEATURE_ADAPTIVE_MODIFICATION\
79   -DTIZEN_FEATURE_TSDEMUX_MODIFICATION\
80   -DTIZEN_FEATURE_OALSINK_MODIFICATION\
81   -DTIZEN_FEATURE_UPSTREAM\
82   -fstack-protector-strong\
83   -Wl,-z,relro\
84   -D_FORTIFY_SOURCE=2"
85 export CXXFLAGS+=" -DTIZEN_FEATURE_PITCH_AUDIO_META"
86 # export pthread for checking usrsctp_init at sctp configure
87 export LDFLAGS+=" -pthread "
88
89 %configure\
90         --disable-static\
91         --disable-examples\
92         --enable-experimental\
93 %if "%{tizen_profile_name}" == "tv"
94         --enable-tv\
95         --disable-autoconvert\
96         --disable-camerabin2\
97         --disable-dash\
98         --disable-hls\
99         --disable-id3tag\
100         --disable-jpegformat\
101         --disable-mpegdemux\
102         --disable-smoothstreaming\
103         --disable-coloreffects\
104         --disable-rtp\
105         --disable-gl\
106 %endif
107         --disable-accurip\
108         --disable-adpcmdec\
109         --disable-audiofxbad\
110         --disable-decklink\
111         --disable-dvb\
112         --disable-fieldanalysis\
113         --disable-gdp\
114         --disable-ivtc\
115         --disable-rawparse\
116         --disable-videofilters\
117         --disable-yadif\
118         --disable-curl\
119         --enable-dtls\
120         --disable-fbdev\
121         --disable-uvch264\
122         --disable-y4m\
123         --disable-adpcmenc\
124         --disable-aiff\
125         --disable-asfmux\
126         --disable-audiovisualizers\
127         --disable-bayer\
128         --disable-dvbsuboverlay\
129         --disable-dvdspu\
130         --disable-faceoverlay\
131         --disable-festival\
132         --disable-freeverb\
133         --disable-frei0r\
134         --disable-gaudieffects\
135         --disable-geometrictransform\
136         --disable-inter\
137         --disable-interlace\
138         --disable-ivfparse\
139         --disable-jp2kdecimator\
140         --disable-librfb\
141         --disable-mxf\
142         --disable-onvif\
143         --disable-pcapparse\
144         --disable-pnm\
145         --disable-removesilence\
146         --disable-segmentclip\
147         --disable-siren\
148         --disable-smooth\
149         --disable-speed\
150         --disable-subenc\
151         --disable-videosignal\
152         --disable-vmnc\
153 %if 0%{?enable_gl:1}
154         --enable-egl=yes\
155         --enable-gles2=yes\
156 %endif
157         --enable-wayland=yes\
158         --enable-openal=yes\
159         --disable-sndfile\
160         --disable-gtk-doc\
161         --disable-mpegpsmux
162 %__make %{?_smp_mflags} V=1
163
164 %install
165 %make_install
166 %find_lang %{name}-%{gst_branch}
167 mv %{name}-%{gst_branch}.lang %{name}.lang
168
169 %lang_package
170
171
172 %clean
173 rm -rf $RPM_BUILD_ROOT
174
175 %post -p /sbin/ldconfig
176
177
178 %postun -p /sbin/ldconfig
179
180
181 %files
182 %manifest %{name}.manifest
183 %defattr(-, root, root)
184 %license COPYING.LIB
185 %if "%{tizen_profile_name}" != "tv"
186 %{_libdir}/gstreamer-%{gst_branch}/libgstautoconvert.so
187 %{_libdir}/gstreamer-%{gst_branch}/libgstcamerabin.so
188 %{_libdir}/gstreamer-%{gst_branch}/libgstcoloreffects.so
189 %{_libdir}/gstreamer-%{gst_branch}/libgstid3tag.so
190 %{_libdir}/gstreamer-%{gst_branch}/libgstjpegformat.so
191 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegpsdemux.so
192 %{_libdir}/gstreamer-%{gst_branch}/libgstsmoothstreaming.so
193 %{_libdir}/gstreamer-%{gst_branch}/libgstdashdemux.so
194 %if 0%{?enable_gl:1}
195 %{_libdir}/gstreamer-%{gst_branch}/libgstopengl.so
196 %endif
197 %{_libdir}/gstreamer-%{gst_branch}/libgstsoundtouch.so
198 %{_libdir}/libgstinsertbin-%{gst_branch}.so.0*
199 %{_libdir}/libgstphotography-%{gst_branch}.so.0*
200 %{_libdir}/libgstbasecamerabinsrc-%{gst_branch}.so.0*
201 %{_libdir}/libgsturidownloader-%{gst_branch}.so.0*
202 %{_libdir}/libgstadaptivedemux-%{gst_branch}.so.0*
203 %if 0%{?enable_gl:1}
204 %{_libdir}/libgstgl-%{gst_branch}.so.0*
205 %endif
206 %{_libdir}/libgstisoff-%{gst_branch}.so.0*
207 %endif
208 %{_libdir}/gstreamer-%{gst_branch}/libgstdebugutilsbad.so
209 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsdemux.so
210 %{_libdir}/gstreamer-%{gst_branch}/libgstmpegtsmux.so
211 %{_libdir}/gstreamer-%{gst_branch}/libgstsdpelem.so
212 %{_libdir}/gstreamer-%{gst_branch}/libgstshm.so
213 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoparsersbad.so
214 %{_libdir}/gstreamer-%{gst_branch}/libgstmidi.so
215 %{_libdir}/gstreamer-%{gst_branch}/libgstopenal.so
216 %{_libdir}/gstreamer-%{gst_branch}/libgsthls.so
217 %{_libdir}/gstreamer-%{gst_branch}/libgstnetsim.so
218 %{_libdir}/gstreamer-%{gst_branch}/libgsttimecode.so
219 %{_libdir}/gstreamer-%{gst_branch}/libgstvideoframe_audiolevel.so
220 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiomixmatrix.so
221 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiobuffersplit.so
222 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiolatency.so
223 %{_libdir}/gstreamer-%{gst_branch}/libgstipcpipeline.so
224 %{_libdir}/gstreamer-%{gst_branch}/libgstproxy.so
225 %{_libdir}/gstreamer-%{gst_branch}/libgstwebrtc.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstdtls.so
227 %{_libdir}/gstreamer-%{gst_branch}/libgstsctp.so
228 %{_libdir}/gstreamer-%{gst_branch}/libgstsrtp.so
229 %{_libdir}/gstreamer-%{gst_branch}/libgstopusparse.so
230 %{_libdir}/libgstsctp-%{gst_branch}.so.0*
231 %{_libdir}/libgstwebrtc-%{gst_branch}.so.0*
232 %{_libdir}/libgstcodecparsers-%{gst_branch}.so.0*
233 %{_libdir}/libgstmpegts-%{gst_branch}.so.0*
234 %{_libdir}/libgstbadaudio-%{gst_branch}.so.0*
235 %{_libdir}/libgstplayer-%{gst_branch}.so.0*
236
237 %files devel
238 %manifest %{name}.manifest
239 %defattr(-, root, root)
240 %{_includedir}/gstreamer-%{gst_branch}
241 %if "%{tizen_profile_name}" != "tv"
242 %if 0%{?enable_gl:1}
243 %{_libdir}/gstreamer-%{gst_branch}/include/gst/gl/gstglconfig.h
244 %endif
245 %endif
246 %{_libdir}/*.so
247 %{_libdir}/pkgconfig/gstreamer-codecparsers-%{gst_branch}.pc
248 %{_libdir}/pkgconfig/gstreamer-plugins-bad-%{gst_branch}.pc
249 %{_libdir}/pkgconfig/gstreamer-insertbin-%{gst_branch}.pc
250 %{_libdir}/pkgconfig/gstreamer-mpegts-%{gst_branch}.pc
251 %if 0%{?enable_gl:1}
252 %{_libdir}/pkgconfig/gstreamer-gl-1.0.pc
253 %endif
254 %{_libdir}/pkgconfig/gstreamer-bad-audio-1.0.pc
255 %{_libdir}/pkgconfig/gstreamer-player-1.0.pc
256 %{_libdir}/pkgconfig/gstreamer-sctp-1.0.pc
257 %{_libdir}/pkgconfig/gstreamer-webrtc-1.0.pc