Add .gbs.conf needed to submit from tizen_ivi_genivi branch
[profile/ivi/gst-ffmpeg0.10.git] / packaging / gst-ffmpeg.spec
1 #sbs-git:slp/pkgs/g/gstreamer0.10-ffmpeg gst-ffmpeg 0.10.11 eab91d2292960a6c9af3b27ca939ad65a4418984
2 Name:       gst-ffmpeg0.10
3 Summary:    FFmpeg plugin for GStreamer
4 Version:    0.10.11
5 Release:    19
6 Group:      Application/Multimedia
7 License:    LGPLv2+
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  gettext
10 BuildRequires:  which
11 BuildRequires:  gstreamer0.10-tools
12 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10) 
13 BuildRequires:  pkgconfig(gstreamer-0.10) 
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(zlib)
16 BuildRequires:  pkgconfig(vorbis)
17 BuildRequires:  pkgconfig(theora)
18
19 %description
20 This GStreamer plugin supports a large number of audio and video compression
21 formats through the use of the FFmpeg library.  The plugin contains GStreamer
22 elements for decoding 90+ formats (AVI, MPEG, OGG, Matroska, ASF, ...),
23 demuxing 30+ formats and colorspace conversion.
24
25
26 %prep
27 %setup -q 
28
29 %build
30 ./autogen.sh 
31
32 export CFLAGS+=" -Wall -g -fPIC\
33  -DFFDEC_RANK_MODIFICATION"
34
35 %configure  --disable-static \
36         --disable-nls \
37         --prefix=%{_prefix} \
38         --with-html-dir=/tmp/dump
39
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47
48 %files
49 %manifest gst-ffmpeg.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/gstreamer-0.10/libgstffmpeg.so