tizen 2.3.1 release
[framework/multimedia/gstreamer0.10-ffmpeg.git] / packaging / gst-ffmpeg.spec
1 #sbs-git:slp/pkgs/g/gstreamer0.10-ffmpeg gst-ffmpeg 0.10.11 eab91d2292960a6c9af3b27ca939ad65a4418984
2 Name:       gst-ffmpeg
3 Summary:    FFmpeg plugin for GStreamer
4 Version:    0.10.14
5 Release:    25
6 Group:      TO_BE/FILLED_IN
7 License:    LGPL-2.0+
8 Source0:    %{name}-%{version}.tar.gz
9 #Patch0:     gst-ffmpeg-autotools.patch
10 #Patch1:     gst-ffmpeg-ffmux-ehancement.patch
11 #Patch2:     gst-ffmpeg-swscale-pc.patch
12 BuildRequires:  gettext
13 BuildRequires:  which
14 BuildRequires:  gstreamer-tools
15 BuildRequires:  gst-plugins-base-devel  
16 BuildRequires:  pkgconfig(gstreamer-0.10) 
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(zlib)
19
20 %description
21 This GStreamer plugin supports a large number of audio and video compression
22 formats through the use of the FFmpeg library.  The plugin contains GStreamer
23 elements for decoding 90+ formats (AVI, MPEG, OGG, Matroska, ASF, ...),
24 demuxing 30+ formats and colorspace conversion.
25
26
27 %prep
28 %setup -q 
29 #%patch0 -p1
30 #%patch1 -p1
31 #%patch2 -p1
32
33 %build
34 ./autogen.sh 
35
36 export CFLAGS+=" -Wall -Wno-unused-but-set-variable -Wno-implicit-function-declaration -g -fPIC\
37  -DFFDEC_RANK_MODIFICATION"
38
39 export EXTRA_CONFIGURE="--disable-gpl"
40
41 %ifarch %{arm}
42 export EXTRA_CONFIGURE="$EXTRA_CONFIGURE --disable-libvorbis --disable-libtheora --enable-decoders --enable-encoders"
43 %else
44 export EXTRA_CONFIGURE="$EXTRA_CONFIGURE --disable-libvorbis --disable-libtheora"
45 %endif
46 %configure  --disable-static \
47         --disable-nls \
48         --prefix=%{_prefix} \
49         --with-html-dir=/tmp/dump \
50         --with-ffmpeg-extra-configure="$EXTRA_CONFIGURE"
51
52 make %{?jobs:-j%jobs}
53
54 %install
55 rm -rf %{buildroot}
56 mkdir -p %{buildroot}/usr/share/license
57 cp COPYING.LIB %{buildroot}/usr/share/license/%{name}
58 %make_install
59
60
61 %files
62 %manifest gst-ffmpeg.manifest
63 %defattr(-,root,root,-)
64 /usr/lib/gstreamer-0.10/libgstffmpeg.so
65 /usr/share/license/%{name}