Merged upstream into tizen
[platform/upstream/gssdp.git] / packaging / gssdp.spec
1 %if "%{profile}" == "ivi"
2 %define intro yes
3 %else
4 %define intro no
5 %endif
6
7 Name:       gssdp
8 Summary:    GSSDP implements resource discovery and announcement over SSDP
9 Version:    0.14.4
10 Release:    1
11 Group:      System/Libraries
12 License: LGPL-2.0+
13 URL:        http://www.gupnp.org
14 Source0:    http://download.gnome.org/sources/%{name}/0.14/%{name}-%{version}.tar.xz
15 Requires:   dbus
16 Requires:   libsoup
17 BuildRequires:  pkgconfig(dbus-glib-1)
18 BuildRequires:  pkgconfig(glib-2.0)
19 BuildRequires:  pkgconfig(libxml-2.0)
20 #BuildRequires:  pkgconfig(gconf-2.0)
21 BuildRequires:  pkgconfig(libsoup-2.4)
22 %if "%{profile}" == "ivi"
23 BuildRequires:  gobject-introspection-devel
24 BuildRequires:  vala
25 %endif
26
27
28 %description
29 GSSDP implements resource discovery and announcement over SSDP and is part
30 of gUPnP.  GUPnP is an object-oriented open source framework for creating
31 UPnP devices and control points, written in C using GObject and libsoup.
32 The GUPnP API is intended to be easy to use, efficient and flexible. GSSDP
33 implements resource discovery and announcement over SSDP.
34
35 %package devel
36 Summary:    Development package for gssdp
37 Group:      Development/Libraries
38 LICENSE:    LGPL-2.0+
39 Requires:   %{name} = %{version}-%{release}
40
41 %description devel
42 Development files for gssdp.
43
44 %prep
45 %setup -q -n %{name}-%{version}
46
47 %build
48 %configure --prefix=/usr --enable-introspection=%{intro} --enable-gtk-doc-html=no
49
50 make %{?jobs:-j%jobs}
51
52 %install
53 rm -rf %{buildroot}
54 %make_install
55 rm -rf %{buildroot}/usr/share/gtk-doc
56 mkdir -p %{buildroot}/usr/share/license
57 cp COPYING %{buildroot}/usr/share/license/%{name}
58
59 %clean
60 rm -rf %{buildroot}
61
62 %post
63
64 %postun
65
66 %files
67 %manifest %{name}.manifest
68 %defattr(-,root,root,-)
69 %doc
70 %{_libdir}/*.so*
71 /usr/share/license/%{name}
72
73 %files devel
74 %defattr(-,root,root,-)
75 /usr/include/gssdp-1.0/*
76 #%{_libdir}/*.a
77 %{_libdir}/*.so
78 %{_libdir}/pkgconfig/*
79 %if "%{profile}" == "ivi"
80 %{_libdir}/girepository-1.0/GSSDP-1.0.typelib
81 %{_datadir}/gir-1.0/GSSDP-1.0.gir
82 %{_datadir}/vala/vapi/gssdp-1.0.deps
83 %{_datadir}/vala/vapi/gssdp-1.0.vapi
84 %endif