6d5326850caa8370f54c030a0cd8f71921d498f9
[platform/upstream/gssdp.git] / packaging / gssdp.spec
1 Name:       gssdp
2 Summary:    GSSDP implements resource discovery and announcement over SSDP
3 Version:    0.14.4
4 Release:    1
5 Group:      System/Libraries
6 License: LGPL-2.0+
7 URL:        http://www.gupnp.org
8 Source0:    http://download.gnome.org/sources/%{name}/0.14/%{name}-%{version}.tar.xz
9 Requires:   dbus
10 Requires:   libsoup
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(libxml-2.0)
14 #BuildRequires:  pkgconfig(gconf-2.0)
15 BuildRequires:  pkgconfig(libsoup-2.4)
16 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
17 # if ivi ||"undefined"
18 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
19 BuildRequires:  gobject-introspection-devel
20 BuildRequires:  vala
21 %define intro yes
22 %else
23 %define intro no
24 %endif
25
26
27 %description
28 GSSDP implements resource discovery and announcement over SSDP and is part
29 of gUPnP.  GUPnP is an object-oriented open source framework for creating
30 UPnP devices and control points, written in C using GObject and libsoup.
31 The GUPnP API is intended to be easy to use, efficient and flexible. GSSDP
32 implements resource discovery and announcement over SSDP.
33
34 %package devel
35 Summary:    Development package for gssdp
36 Group:      Development/Libraries
37 LICENSE:    LGPL-2.0+
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 Development files for gssdp.
42
43 %prep
44 %setup -q -n %{name}-%{version}
45
46 %build
47 # Note that enabling-intro only adds additional files in devel package.
48 # There is no different in the main binary package.
49 %configure --prefix=/usr --enable-introspection=%{intro} --enable-gtk-doc-html=no
50
51 make %{?jobs:-j%jobs}
52
53 %install
54 rm -rf %{buildroot}
55 %make_install
56 rm -rf %{buildroot}/usr/share/gtk-doc
57 mkdir -p %{buildroot}/usr/share/license
58 cp COPYING %{buildroot}/usr/share/license/%{name}
59
60 %clean
61 rm -rf %{buildroot}
62
63 %post
64
65 %postun
66
67 %files
68 %manifest %{name}.manifest
69 %defattr(-,root,root,-)
70 %doc
71 %{_libdir}/*.so*
72 /usr/share/license/%{name}
73
74 %files devel
75 %defattr(-,root,root,-)
76 /usr/include/gssdp-1.0/*
77 #%{_libdir}/*.a
78 %{_libdir}/*.so
79 %{_libdir}/pkgconfig/*
80 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
81 # if ivi ||"undefined"
82 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
83 %{_libdir}/girepository-1.0/GSSDP-1.0.typelib
84 %{_datadir}/gir-1.0/GSSDP-1.0.gir
85 %{_datadir}/vala/vapi/gssdp-1.0.deps
86 %{_datadir}/vala/vapi/gssdp-1.0.vapi
87 %endif