31395831b7809fc33ff9926c954f82441c9426ae
[platform/upstream/gssdp.git] / packaging / gssdp.spec
1 Name:       gssdp
2 Summary:    GSSDP implements resource discovery and announcement over SSDP
3 Version:    0.14.4
4 Release:    1
5 Group:      System/Libraries
6 License: LGPL-2.0+
7 URL:        http://www.gupnp.org
8 Source0:    http://download.gnome.org/sources/%{name}/0.14/%{name}-%{version}.tar.xz
9 Requires:   dbus
10 Requires:   libsoup
11 BuildRequires:  pkgconfig(dbus-glib-1)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(libxml-2.0)
14 #BuildRequires:  pkgconfig(gconf-2.0)
15 BuildRequires:  pkgconfig(libsoup-2.4)
16 %define intro no
17
18 %description
19 GSSDP implements resource discovery and announcement over SSDP and is part
20 of gUPnP.  GUPnP is an object-oriented open source framework for creating
21 UPnP devices and control points, written in C using GObject and libsoup.
22 The GUPnP API is intended to be easy to use, efficient and flexible. GSSDP
23 implements resource discovery and announcement over SSDP.
24
25 %package devel
26 Summary:    Development package for gssdp
27 Group:      Development/Libraries
28 LICENSE:    LGPL-2.0+
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 Development files for gssdp.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38 # Note that enabling-intro only adds additional files in devel package.
39 # There is no different in the main binary package.
40 %configure --prefix=/usr --enable-introspection=%{intro} --enable-gtk-doc-html=no
41
42 make %{?jobs:-j%jobs}
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47 rm -rf %{buildroot}/usr/share/gtk-doc
48
49 %clean
50 rm -rf %{buildroot}
51
52 %post
53
54 %postun
55
56 %files
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %doc
60 %{_libdir}/*.so.*
61 %license COPYING
62
63 %files devel
64 %defattr(-,root,root,-)
65 /usr/include/gssdp-1.0/*
66 #%{_libdir}/*.a
67 %{_libdir}/*.so
68 %{_libdir}/pkgconfig/*