f5fa51d20d82907a26559ad56e325edd805c4401
[profile/ivi/gsignond.git] / packaging / gsignond.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type p2p
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.2
10 Release: 9
11 Group: System/Daemons
12 License: LGPL
13 Source: %{name}-%{version}.tar.gz
14 %if %{dbus_type} != "p2p"
15 Requires: dbus-1
16 %endif
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 BuildRequires: pkgconfig(dbus-1)
20 BuildRequires: pkgconfig(glib-2.0) >= 2.30
21 BuildRequires: pkgconfig(gobject-2.0)
22 BuildRequires: pkgconfig(gio-2.0)
23 BuildRequires: pkgconfig(gio-unix-2.0)
24 BuildRequires: pkgconfig(gmodule-2.0)
25 BuildRequires: pkgconfig(sqlite3)
26
27
28 %description
29 %{summary}.
30
31
32 %package devel
33 Summary:    Development files for %{name}
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 %{summary}.
39
40
41 %prep
42 %setup -q -n %{name}-%{version}
43 if [ -f = "gtk-doc.make" ]
44 then
45 rm gtk-doc.make
46 fi
47 touch gtk-doc.make
48 autoreconf -f -i
49
50
51 %build
52 %if %{debug_build} == 1
53 %configure --enable-dbus-type=%{dbus_type} --enable-debug
54 %else
55 %configure --enable-dbus-type=%{dbus_type}
56 %endif
57
58 make %{?_smp_mflags}
59
60
61 %install
62 rm -rf %{buildroot}
63 %make_install
64
65
66 %post
67 /sbin/ldconfig
68 chmod u+s %{_bindir}/%{name}
69
70
71 %postun -p /sbin/ldconfig
72
73
74 %files
75 %defattr(-,root,root,-)
76 %doc AUTHORS COPYING.LIB INSTALL NEWS README
77 %{_bindir}/%{name}
78 %{_bindir}/%{name}-plugind
79 %{_libdir}/lib%{name}-*.so.*
80 %{_libdir}/%{name}/extensions/*.so*
81 %{_libdir}/%{name}/plugins/*.so*
82 %if %{dbus_type} != "p2p"
83 %{_datadir}/dbus-1/services/*SingleSignOn*.service
84 %endif
85
86
87 %files devel
88 %defattr(-,root,root,-)
89 %{_includedir}/%{name}/*.h
90 %{_libdir}/lib%{name}-*.so
91 %{_libdir}/pkgconfig/%{name}.pc
92 %if %{dbus_type} != "p2p"
93 %{_datadir}/dbus-1/interfaces/*SSO*.xml
94 %endif
95