updated distribution specific changes
[profile/ivi/gsignond.git] / packaging / gsignond.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.1
10 Release: 9
11 Group: System/Daemons
12 License: LGPL
13 Source: %{name}-%{version}.tar.gz
14 Requires: dbus-1
15 Requires(post): /sbin/ldconfig
16 Requires(postun): /sbin/ldconfig
17 BuildRequires: pkgconfig(dbus-1)
18 BuildRequires: pkgconfig(glib-2.0) >= 2.30
19 BuildRequires: pkgconfig(gobject-2.0)
20 BuildRequires: pkgconfig(gio-2.0)
21 BuildRequires: pkgconfig(gio-unix-2.0)
22 BuildRequires: pkgconfig(gmodule-2.0)
23 BuildRequires: pkgconfig(sqlite3)
24
25
26 %description
27 %{summary}.
28
29
30 %package devel
31 Summary:    Development files for %{name}
32 Group:      Development/Libraries
33 Requires:   %{name} = %{version}-%{release}
34
35 %description devel
36 %{summary}.
37
38
39 %prep
40 %setup -q -n %{name}-%{version}
41 if [ -f = "gtk-doc.make" ]
42 then
43 rm gtk-doc.make
44 fi
45 touch gtk-doc.make
46 autoreconf -f -i
47
48
49 %build
50 %if %{debug_build} == 1
51 %configure --enable-dbus-type=%{dbus_type} --enable-debug
52 %else
53 %configure --enable-dbus-type=%{dbus_type}
54 %endif
55
56 make %{?_smp_mflags}
57
58
59 %install
60 rm -rf %{buildroot}
61 %make_install
62
63
64 %post
65 /sbin/ldconfig
66 chmod u+s %{_bindir}/%{name}
67
68
69 %postun -p /sbin/ldconfig
70
71
72 %files
73 %defattr(-,root,root,-)
74 %doc AUTHORS COPYING.LIB INSTALL NEWS README
75 %{_bindir}/%{name}
76 %{_bindir}/%{name}-plugind
77 %{_libdir}/lib%{name}-*.so.*
78 %{_libdir}/%{name}/extensions/*.so*
79 %{_libdir}/%{name}/plugins/*.so*
80 %if %{dbus_type} != "p2p"
81 %{_datadir}/dbus-1/services/*SingleSignOn*.service
82 %endif
83
84
85 %files devel
86 %defattr(-,root,root,-)
87 %{_includedir}/%{name}/*.h
88 %{_libdir}/lib%{name}-*.so
89 %{_libdir}/pkgconfig/%{name}.pc
90 %if %{dbus_type} != "p2p"
91 %{_datadir}/dbus-1/interfaces/*SSO*.xml
92 %endif
93