resetting manifest requested domain to floor
[platform/upstream/gptfdisk.git] / packaging / gptfdisk.spec
1 Name:           gptfdisk
2 Version:        0.8.5
3 Release:        0
4 Summary:        GPT partitioning and MBR repair software
5 License:        GPL-2.0
6 Group:          Base/System
7 Url:            http://rodsbooks.com/gdisk
8
9 Source:         %name-%version.tar.xz
10 Source1001:     gptfdisk.manifest
11 BuildRequires:  gcc-c++
12 BuildRequires:  ncurses-devel
13 BuildRequires:  xz
14 BuildRequires:  pkgconfig(icu-io)
15 BuildRequires:  pkgconfig(icu-uc)
16 BuildRequires:  pkgconfig(popt)
17 BuildRequires:  pkgconfig(uuid)
18
19 %description
20 Partitioning software for GPT disks and to repair MBR disks. The
21 gdisk, cgdisk, and sgdisk utilities (in the gdisk package) are
22 GPT-enabled partitioning tools; the fixparts utility (in the fixparts
23 package) fixes some problems with MBR disks that can be created by
24 buggy partitioning software.
25
26 %package fixparts
27 Summary:        A tool for repairing certain types of damage to MBR disks
28 Group:          Applications/System
29
30 %description fixparts
31 A program that corrects errors that can creep into MBR-partitioned
32 disks. Removes stray GPT data, fixes mis-sized extended partitions,
33 and enables changing primary vs. logical partition status. Also
34 provides a few additional partition manipulation features.
35
36 %prep
37 %setup -q
38 cp %{SOURCE1001} .
39
40 %build
41 CFLAGS="%optflags" CXXFLAGS="%optflags" make %{?_smp_mflags}
42
43 %install
44 b="%buildroot";
45 mkdir -p "$b/%_sbindir" "$b/%_mandir/man8";
46 install -pm0755 fixparts {,c,s}gdisk "$b/%_sbindir/";
47 install -pm0644 *.8 "$b/%_mandir/man8/";
48
49 %files
50 %manifest %{name}.manifest
51 %defattr(-,root,root)
52 %license COPYING
53 %_sbindir/gdisk
54 %_sbindir/sgdisk
55 %_sbindir/cgdisk
56 %_mandir/man8/gdisk.8*
57 %_mandir/man8/cgdisk.8*
58 %_mandir/man8/sgdisk.8*
59
60 %files fixparts
61 %manifest %{name}.manifest
62 %defattr(-,root,root)
63 %license COPYING 
64 %_sbindir/fixparts
65 %_mandir/man8/fixparts.8*
66
67 %changelog